aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoranders <anders@FreeBSD.org>2004-11-21 01:12:15 +0800
committeranders <anders@FreeBSD.org>2004-11-21 01:12:15 +0800
commit0f5807432c49eb5e0a7c67f23a76bec6ad993f80 (patch)
tree958829ba32786488d3981542effabd0b8c7130e6 /www
parent0d09019efdf3387b60b0c20e288c736ced8d607e (diff)
downloadfreebsd-ports-gnome-0f5807432c49eb5e0a7c67f23a76bec6ad993f80.tar.gz
freebsd-ports-gnome-0f5807432c49eb5e0a7c67f23a76bec6ad993f80.tar.zst
freebsd-ports-gnome-0f5807432c49eb5e0a7c67f23a76bec6ad993f80.zip
Add forgetHTML, a Python module for object-oriented HTML generation.
Sponsored by: University of Tromsø
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-forgethtml/Makefile32
-rw-r--r--www/py-forgethtml/distinfo2
-rw-r--r--www/py-forgethtml/pkg-descr6
-rw-r--r--www/py-forgethtml/pkg-plist3
5 files changed, 44 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a99f6b162100..ab679a7578fb 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -600,6 +600,7 @@
SUBDIR += py-clientform
SUBDIR += py-cssutils
SUBDIR += py-fcgi
+ SUBDIR += py-forgethtml
SUBDIR += py-htmltestcase
SUBDIR += py-imdbpy
SUBDIR += py-mt
diff --git a/www/py-forgethtml/Makefile b/www/py-forgethtml/Makefile
new file mode 100644
index 000000000000..14988599b1a5
--- /dev/null
+++ b/www/py-forgethtml/Makefile
@@ -0,0 +1,32 @@
+# Ports collection makefile for: py-forgethtml
+# Date created: 20 November 2004
+# Whom: Anders Nordby <anders@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= forgethtml
+PORTVERSION= 20041021
+CATEGORIES= www python
+MASTER_SITES= http://forgethtml.sourceforge.net/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-cvs-2004-10-21
+
+MAINTAINER= anders@FreeBSD.org
+COMMENT= Python module for object-oriented HTML generation
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-build:
+ @cd ${WRKSRC}/lib && ${PYTHON_CMD} -c 'import forgetHTML'
+ @cd ${WRKSRC}/lib && ${PYTHON_CMD} -O -c 'import forgetHTML'
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/lib/forgetHTML.pyc ${PYTHON_SITELIBDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/lib/forgetHTML.pyo ${PYTHON_SITELIBDIR}/
+
+.include <bsd.port.mk>
diff --git a/www/py-forgethtml/distinfo b/www/py-forgethtml/distinfo
new file mode 100644
index 000000000000..83629dcfa30b
--- /dev/null
+++ b/www/py-forgethtml/distinfo
@@ -0,0 +1,2 @@
+MD5 (forgethtml-cvs-2004-10-21.tar.gz) = b8b8a323c7a4364aa4058d5e5c8aaa4d
+SIZE (forgethtml-cvs-2004-10-21.tar.gz) = 6211
diff --git a/www/py-forgethtml/pkg-descr b/www/py-forgethtml/pkg-descr
new file mode 100644
index 000000000000..183ae68e4acd
--- /dev/null
+++ b/www/py-forgethtml/pkg-descr
@@ -0,0 +1,6 @@
+forgetHTML is a Python module providing a totally object-oriented way of
+writing HTML. Each element is a object which may contain other HTML elements
+(ie. objects). Only those elements allowed in HTML to contain each other are
+allowed to be inserted.
+
+WWW: http://forgethtml.sourceforge.net/
diff --git a/www/py-forgethtml/pkg-plist b/www/py-forgethtml/pkg-plist
new file mode 100644
index 000000000000..6ee000accb31
--- /dev/null
+++ b/www/py-forgethtml/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/forgetHTML.py
+%%PYTHON_SITELIBDIR%%/forgetHTML.pyc
+%%PYTHON_SITELIBDIR%%/forgetHTML.pyo