aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorseanc <seanc@FreeBSD.org>2003-01-19 06:50:06 +0800
committerseanc <seanc@FreeBSD.org>2003-01-19 06:50:06 +0800
commit124ab7dda748e809f82a8072a9acf12f288fb745 (patch)
tree92989088209a18169ed2eeb5b01ad91d013e7002 /www
parent864635ab1b7b6c2d573d321e715fa57489ddbe6d (diff)
downloadfreebsd-ports-gnome-124ab7dda748e809f82a8072a9acf12f288fb745.tar.gz
freebsd-ports-gnome-124ab7dda748e809f82a8072a9acf12f288fb745.tar.zst
freebsd-ports-gnome-124ab7dda748e809f82a8072a9acf12f288fb745.zip
Bump libpq version[1] and PORTREVISION. Add POSTGRESQL_PORT tunable.
This should be the last of the PostgreSQL updates and everything should support the POSTGRESQL_PORT tunable. Submitted by: kris/bento[1]
Diffstat (limited to 'www')
-rw-r--r--www/nspostgres/Makefile4
-rw-r--r--www/pgdriver/Makefile5
-rw-r--r--www/udmsearch/Makefile4
3 files changed, 10 insertions, 3 deletions
diff --git a/www/nspostgres/Makefile b/www/nspostgres/Makefile
index 42fc1ae1d54b..23428f5d7db3 100644
--- a/www/nspostgres/Makefile
+++ b/www/nspostgres/Makefile
@@ -15,9 +15,11 @@ DISTNAME= nspostgres3_0
MAINTAINER= jkoshy@freebsd.org
BUILD_DEPENDS= ${LOCALBASE}/aolserver/bin/nsd:${PORTSDIR}/www/aolserver \
- ${LOCALBASE}/bin/postmaster:${PORTSDIR}/databases/postgresql7
+ ${LOCALBASE}/bin/postmaster:${PORTSDIR}/${POSTGRESQL_PORT}
RUN_DEPENDS= ${BUILD_DEPENDS}
+POSTGRESQL_PORT?= databases/postgresql7
+
WRKSRC= ${WRKDIR}/nspostgres
USE_GMAKE= yes
diff --git a/www/pgdriver/Makefile b/www/pgdriver/Makefile
index 3da44edd817b..827147becad9 100644
--- a/www/pgdriver/Makefile
+++ b/www/pgdriver/Makefile
@@ -7,16 +7,19 @@
PORTNAME= pgdriver
PORTVERSION= 2.0
+PORTREVISION= 1
CATEGORIES= www databases
MASTER_SITES= http://openacs.org/sdm/download-package/2/38/
EXTRACT_SUFX= .tgz
MAINTAINER= jkoshy@freebsd.org
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
BUILD_DEPENDS= ${LOCALBASE}/aolserver/bin/nsd:${PORTSDIR}/www/aolserver
RUN_DEPENDS= ${BUILD_DEPENDS}
+POSTGRESQL_PORT?= databases/postgresql7
+
MAKEFILE= makefile
MAKE_ENV+= PREFIX=${PREFIX}
diff --git a/www/udmsearch/Makefile b/www/udmsearch/Makefile
index 0434c90e78c3..b76d31cdf681 100644
--- a/www/udmsearch/Makefile
+++ b/www/udmsearch/Makefile
@@ -7,6 +7,7 @@
PORTNAME= udmsearch
PORTVERSION= 3.0.23
+PORTREVISION= 1
CATEGORIES= www databases
MASTER_SITES= http://mysearch.udm.net/Download/ \
ftp://ftp.izhcom.ru/pub/unix/UdmSearch/ \
@@ -25,7 +26,8 @@ CONFIGURE_ARGS= --enable-charset-guesser \
--localstatedir=/var/udmsearch
.if defined(WITH_PGSQL)
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
CONFIGURE_ARGS+= --with-pgsql=${LOCALBASE}/pgsql
.elif defined(WITH_MSQL)