aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-04-23 04:57:12 +0800
committerpav <pav@FreeBSD.org>2005-04-23 04:57:12 +0800
commit1cad86b033b77141a0432fc72e5cf47b406c0778 (patch)
tree391fcec0220b9a8316089ece3fe7246533d961e7 /www
parente54ae2a4b41c8160cd5623a078fb6491682dbeba (diff)
downloadfreebsd-ports-gnome-1cad86b033b77141a0432fc72e5cf47b406c0778.tar.gz
freebsd-ports-gnome-1cad86b033b77141a0432fc72e5cf47b406c0778.tar.zst
freebsd-ports-gnome-1cad86b033b77141a0432fc72e5cf47b406c0778.zip
- Change path to match frontpage-rtr binaries
PR: ports/76013 Submitted by: Joe Rhett <jrhett@meer.net> Approved by: maintainer timeout (1 month)
Diffstat (limited to 'www')
-rw-r--r--www/mod_frontpage/Makefile1
-rw-r--r--www/mod_frontpage/files/patch-fpstatic.c16
2 files changed, 10 insertions, 7 deletions
diff --git a/www/mod_frontpage/Makefile b/www/mod_frontpage/Makefile
index e583b65dddb0..1a0d1306dc06 100644
--- a/www/mod_frontpage/Makefile
+++ b/www/mod_frontpage/Makefile
@@ -6,6 +6,7 @@
PORTNAME= mod_frontpage
PORTVERSION= 1.6.2
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S/%SUBDIR%/mirfak/g}
DISTFILES= ${PORTNAME}_mirfak-${PORTVERSION}.tar.gz
diff --git a/www/mod_frontpage/files/patch-fpstatic.c b/www/mod_frontpage/files/patch-fpstatic.c
index cbd4eb1ebaf2..043485a04896 100644
--- a/www/mod_frontpage/files/patch-fpstatic.c
+++ b/www/mod_frontpage/files/patch-fpstatic.c
@@ -1,9 +1,12 @@
---- fpstatic.c.orig Tue Feb 5 16:16:46 2002
-+++ fpstatic.c Sun Apr 28 13:33:01 2002
-@@ -435,6 +435,24 @@
+--- fpstatic.c.orig Tue Mar 12 22:07:07 2002
++++ fpstatic.c Fri Apr 22 22:55:33 2005
+@@ -433,7 +433,25 @@
+ } else if ((pos = strstr(uri, ".gif")) != NULL) {
+ pos = strrchr((char *)uri, '/');
snprintf((char *)fnbuf, sizeof(fnbuf), "%s%s%s%s%s",
- FPBASE, _EXES, _VTI_ADM, _IMAGES, pos);
- /*
+- FPBASE, _EXES, _VTI_ADM, _IMAGES, pos);
++ FPBASE, _EXES, _VTI_BIN, _IMAGES, pos);
++ /*
+ * Check to see if the user is changing the password,
+ * which has a URL like _vti_bin/_vti_aut/ passwd.htm.
+ * It's different from other ".htm" files because it
@@ -21,7 +24,6 @@
+ pos = strrchr((char *)uri, '/');
+ snprintf((char *)fnbuf, sizeof(fnbuf), "%s%s%c%04d%s",
+ FPBASE, _ADMIN, '/', Lcid, pos);
-+ /*
+ /*
* If we still have .htm or .css, we end up
* with the admin dir. If we match, we calculate
- * the Lcid from the string.