aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2010-10-10 19:04:23 +0800
committerkuriyama <kuriyama@FreeBSD.org>2010-10-10 19:04:23 +0800
commit1cc2f0dedbdfa1c0c537dd34195f9cc3320a78e1 (patch)
tree69d9b8f63d6dbe2babc42b05cceab4a63ba1f78c /www
parent9c317ef76dbaf0bb23667f50414cc3c9c454fda7 (diff)
downloadfreebsd-ports-gnome-1cc2f0dedbdfa1c0c537dd34195f9cc3320a78e1.tar.gz
freebsd-ports-gnome-1cc2f0dedbdfa1c0c537dd34195f9cc3320a78e1.tar.zst
freebsd-ports-gnome-1cc2f0dedbdfa1c0c537dd34195f9cc3320a78e1.zip
POEx::Role::PSGIServer encapsulates the core PSGI server behaviors
into an easy to consume and extend role. It is based on previous POEx work such as POEx::Role::TCPServer which provides basic TCP socket multiplexing via POE::Wheel::SocketFactory and POE::Wheel::ReadWrite, and POEx::Role::SessionInstantiation which transforms plain Moose objects into POE sessions. WWW: http://search.cpan.org/dist/POEx-Role-PSGIServer/
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-POEx-Role-PSGIServer/Makefile41
-rw-r--r--www/p5-POEx-Role-PSGIServer/distinfo3
-rw-r--r--www/p5-POEx-Role-PSGIServer/pkg-descr8
-rw-r--r--www/p5-POEx-Role-PSGIServer/pkg-plist9
5 files changed, 62 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 57620f26dcfb..e2cd45641a20 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1093,6 +1093,7 @@
SUBDIR += p5-POE-Component-Server-SOAP
SUBDIR += p5-POE-Component-Server-SimpleHTTP
SUBDIR += p5-POE-Filter-HTTP-Parser
+ SUBDIR += p5-POEx-Role-PSGIServer
SUBDIR += p5-PSGI
SUBDIR += p5-ParallelUA
SUBDIR += p5-Path-Class-URI
diff --git a/www/p5-POEx-Role-PSGIServer/Makefile b/www/p5-POEx-Role-PSGIServer/Makefile
new file mode 100644
index 000000000000..aef891ffcbe7
--- /dev/null
+++ b/www/p5-POEx-Role-PSGIServer/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: POEx::Role::PSGIServer
+# Date created: 09 Oct 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POEx-Role-PSGIServer
+PORTVERSION= 1.102531
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/F/FR/FRODWITH
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for encapsulated PSGI server behaviors for POE
+
+RUN_DEPENDS= \
+ p5-Plack>0:${PORTSDIR}/www/p5-Plack \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww \
+ p5-Moose-Autobox>0:${PORTSDIR}/devel/p5-Moose-Autobox \
+ p5-MooseX-Declare>0:${PORTSDIR}/devel/p5-MooseX-Declare \
+ p5-MooseX-Types>0:${PORTSDIR}/devel/p5-MooseX-Types \
+ p5-MooseX-Types-Structured>0:${PORTSDIR}/devel/p5-MooseX-Types-Structured \
+ p5-POE-Filter-HTTP-Parser>0:${PORTSDIR}/www/p5-POE-Filter-HTTP-Parser \
+ p5-POE>0:${PORTSDIR}/devel/p5-POE \
+ p5-POEx-Role-Streaming>0:${PORTSDIR}/devel/p5-POEx-Role-Streaming \
+ p5-POEx-Role-TCPServer>0:${PORTSDIR}/net/p5-POEx-Role-TCPServer \
+ p5-POEx-Types>0:${PORTSDIR}/devel/p5-POEx-Types \
+ p5-Plack>0:${PORTSDIR}/www/p5-Plack \
+ p5-aliased>0:${PORTSDIR}/devel/p5-aliased
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POEx::Role::PSGIServer.3 \
+ POEx::Role::PSGIServer::ProxyWriter.3 \
+ POEx::Role::PSGIServer::Streamer.3 \
+ POEx::Types::PSGIServer.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-POEx-Role-PSGIServer/distinfo b/www/p5-POEx-Role-PSGIServer/distinfo
new file mode 100644
index 000000000000..d773862d4b4b
--- /dev/null
+++ b/www/p5-POEx-Role-PSGIServer/distinfo
@@ -0,0 +1,3 @@
+MD5 (POEx-Role-PSGIServer-1.102531.tar.gz) = f0a7c03d21f9ef4f3aa4f1fff25f62da
+SHA256 (POEx-Role-PSGIServer-1.102531.tar.gz) = 79533702a04a949537051add8013a4efd1662569ad7023c2517a3151e87c7fb3
+SIZE (POEx-Role-PSGIServer-1.102531.tar.gz) = 15255
diff --git a/www/p5-POEx-Role-PSGIServer/pkg-descr b/www/p5-POEx-Role-PSGIServer/pkg-descr
new file mode 100644
index 000000000000..c79558d178d0
--- /dev/null
+++ b/www/p5-POEx-Role-PSGIServer/pkg-descr
@@ -0,0 +1,8 @@
+POEx::Role::PSGIServer encapsulates the core PSGI server behaviors
+into an easy to consume and extend role. It is based on previous POEx
+work such as POEx::Role::TCPServer which provides basic TCP socket
+multiplexing via POE::Wheel::SocketFactory and POE::Wheel::ReadWrite,
+and POEx::Role::SessionInstantiation which transforms plain Moose
+objects into POE sessions.
+
+WWW: http://search.cpan.org/dist/POEx-Role-PSGIServer/
diff --git a/www/p5-POEx-Role-PSGIServer/pkg-plist b/www/p5-POEx-Role-PSGIServer/pkg-plist
new file mode 100644
index 000000000000..527efae5f239
--- /dev/null
+++ b/www/p5-POEx-Role-PSGIServer/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POEx/Role/PSGIServer/.packlist
+%%SITE_PERL%%/POEx/Role/PSGIServer.pm
+%%SITE_PERL%%/POEx/Role/PSGIServer/ProxyWriter.pm
+%%SITE_PERL%%/POEx/Role/PSGIServer/Streamer.pm
+%%SITE_PERL%%/POEx/Types/PSGIServer.pm
+@dirrmtry %%SITE_PERL%%/POEx/Types
+@dirrmtry %%SITE_PERL%%/POEx/Role/PSGIServer
+@dirrmtry %%SITE_PERL%%/POEx/Role
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POEx/Role/PSGIServer