aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2005-04-18 04:38:54 +0800
committerclement <clement@FreeBSD.org>2005-04-18 04:38:54 +0800
commit1cfcc3cd68295a3f024867387b068122e7477cf9 (patch)
tree67cd292df1fe193ecc2e480ae05a4d160736c9bf /www
parent776884aaa473213d886b4cb311499fe172e76095 (diff)
downloadfreebsd-ports-gnome-1cfcc3cd68295a3f024867387b068122e7477cf9.tar.gz
freebsd-ports-gnome-1cfcc3cd68295a3f024867387b068122e7477cf9.tar.zst
freebsd-ports-gnome-1cfcc3cd68295a3f024867387b068122e7477cf9.zip
- Update to 2.0.54
Diffstat (limited to 'www')
-rw-r--r--www/apache2/Makefile3
-rw-r--r--www/apache2/distinfo4
-rw-r--r--www/apache2/files/patch-Makefile.in10
-rw-r--r--www/apache2/files/patch-fix-core_input_filter77
4 files changed, 8 insertions, 86 deletions
diff --git a/www/apache2/Makefile b/www/apache2/Makefile
index 526ef1f85cf2..0873160a4f3a 100644
--- a/www/apache2/Makefile
+++ b/www/apache2/Makefile
@@ -8,8 +8,7 @@
#
PORTNAME= apache
-PORTVERSION= 2.0.53
-PORTREVISION= 1
+PORTVERSION= 2.0.54
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
${MASTER_SITE_LOCAL:S/%SUBDIR%/clement/}:powerlogo
diff --git a/www/apache2/distinfo b/www/apache2/distinfo
index 54fcea96b8b1..db2dc3f33270 100644
--- a/www/apache2/distinfo
+++ b/www/apache2/distinfo
@@ -1,4 +1,4 @@
-MD5 (apache2/httpd-2.0.53.tar.bz2) = 94f3a793fb1665365724943206cce23f
-SIZE (apache2/httpd-2.0.53.tar.bz2) = 5079345
+MD5 (apache2/httpd-2.0.54.tar.bz2) = 4ae8a38c6b5db9046616ce10a0d551a2
+SIZE (apache2/httpd-2.0.54.tar.bz2) = 5566979
MD5 (apache2/powerlogo.gif) = 0f106073b3c7844cf22d4df126b27c62
SIZE (apache2/powerlogo.gif) = 5279
diff --git a/www/apache2/files/patch-Makefile.in b/www/apache2/files/patch-Makefile.in
index 89048db49d3b..e9344df7a041 100644
--- a/www/apache2/files/patch-Makefile.in
+++ b/www/apache2/files/patch-Makefile.in
@@ -1,5 +1,5 @@
--- Makefile.in.orig Wed Nov 24 20:31:09 2004
-+++ Makefile.in Sat Feb 5 12:04:56 2005
++++ Makefile.in Sun Apr 17 10:22:37 2005
@@ -31,15 +31,21 @@
if [ ! -d $(DESTDIR)$(sysconfdir) ]; then \
$(MKINSTALLDIRS) $(DESTDIR)$(sysconfdir) ; \
@@ -78,7 +78,7 @@
+ @test -d $(DESTDIR)$(htdocsdir)-dist || $(MKINSTALLDIRS) $(DESTDIR)$(htdocsdir)-dist
+ @test -d $(htdocs-srcdir) && (cd $(htdocs-srcdir) && cp -rp * $(DESTDIR)$(htdocsdir)-dist)
+ @test -e $(DESTDIR)$(htdocsdir) || ln -sf $(DESTDIR)$(htdocsdir)-dist $(DESTDIR)$(htdocsdir)
-+ -@test "x$(htdocsdir)" != "x" && cd $(DESTDIR)$(htdocsdir)-dist && find -name "CVS" -print | xargs rm -rf
++ -@test "x$(htdocsdir)" != "x" && cd $(DESTDIR)$(htdocsdir)-dist && find . -name ".svn" -print | xargs rm -rf
+.endif
+
install-error:
@@ -95,7 +95,7 @@
+ @echo Installing error documents
+ @test -d $(DESTDIR)$(errordir)-dist || $(MKINSTALLDIRS) $(DESTDIR)$(errordir)-dist
+ cd $(top_srcdir)/docs/error && cp -rp * $(DESTDIR)$(errordir)-dist
-+ -@test "x$(errordir)" != "x" && cd $(DESTDIR)$(errordir)-dist && find . -name "CVS" -print | xargs rm -rf
++ -@test "x$(errordir)" != "x" && cd $(DESTDIR)$(errordir)-dist && find . -name ".svn" -print | xargs rm -rf
+ @test -e $(DESTDIR)$(errordir) || ln -sf $(DESTDIR)$(errordir)-dist $(DESTDIR)$(errordir)
+.endif
+
@@ -113,7 +113,7 @@
+ @echo Installing icons
+ @test -d $(DESTDIR)$(iconsdir)-dist || $(MKINSTALLDIRS) $(DESTDIR)$(iconsdir)-dist
+ cd $(top_srcdir)/docs/icons && cp -rp * $(DESTDIR)$(iconsdir)-dist
-+ -@test "x$(iconsdir)" != "x" && cd $(DESTDIR)$(iconsdir)-dist && find . -name "CVS" -print | xargs rm -rf
++ -@test "x$(iconsdir)" != "x" && cd $(DESTDIR)$(iconsdir)-dist && find . -name ".svn" -print | xargs rm -rf
+ @test -e $(DESTDIR)$(iconsdir) || ln -sf $(DESTDIR)$(iconsdir)-dist $(DESTDIR)$(iconsdir)
+.endif
+
@@ -130,7 +130,7 @@
+ @echo Installing CGIs
+ @test -d $(DESTDIR)$(cgidir)-dist || $(MKINSTALLDIRS) $(DESTDIR)$(cgidir)-dist
+ cd $(top_srcdir)/docs/cgi-examples && cp -rp * $(DESTDIR)$(cgidir)-dist
-+ -@test "x$(cgidir)" != "x" && cd $(DESTDIR)$(cgidir)-dist && find . -name "CVS" -print | xargs rm -rf
++ -@test "x$(cgidir)" != "x" && cd $(DESTDIR)$(cgidir)-dist && find . -name ".svn" -print | xargs rm -rf
+ @test -e $(DESTDIR)$(cgidir) || ln -sf $(DESTDIR)$(cgidir)-dist $(DESTDIR)$(cgidir)
+.endif
diff --git a/www/apache2/files/patch-fix-core_input_filter b/www/apache2/files/patch-fix-core_input_filter
deleted file mode 100644
index bdad48deb0ab..000000000000
--- a/www/apache2/files/patch-fix-core_input_filter
+++ /dev/null
@@ -1,77 +0,0 @@
---- include/httpd.h 2005/02/26 08:26:18 155390
-+++ include/httpd.h 2005/02/26 09:04:10 155391
-@@ -1100,6 +1100,7 @@
-
- typedef struct core_filter_ctx {
- apr_bucket_brigade *b;
-+ apr_bucket_brigade *tmpbb;
- } core_ctx_t;
-
- typedef struct core_net_rec {
---- server/core.c 2005/02/26 08:26:18 155390
-+++ server/core.c 2005/02/26 09:04:10 155391
-@@ -3674,6 +3674,28 @@
- } while (!APR_BRIGADE_EMPTY(b) && (e != APR_BRIGADE_SENTINEL(b))); \
- } while (0)
-
-+
-+/**
-+ * Split the contents of a brigade after bucket 'e' to an existing brigade
-+ *
-+ * XXXX: Should this function be added to APR-Util?
-+ */
-+static void brigade_move(apr_bucket_brigade *b, apr_bucket_brigade *a,
-+ apr_bucket *e)
-+{
-+ apr_bucket *f;
-+
-+ if (e != APR_BRIGADE_SENTINEL(b)) {
-+ f = APR_RING_LAST(&b->list);
-+ APR_RING_UNSPLICE(e, f, link);
-+ APR_RING_SPLICE_HEAD(&a->list, e, f, apr_bucket, link);
-+ }
-+
-+ APR_BRIGADE_CHECK_CONSISTENCY(a);
-+ APR_BRIGADE_CHECK_CONSISTENCY(b);
-+}
-+
-+
- static int core_input_filter(ap_filter_t *f, apr_bucket_brigade *b,
- ap_input_mode_t mode, apr_read_type_e block,
- apr_off_t readbytes)
-@@ -3703,6 +3725,7 @@
- {
- ctx = apr_pcalloc(f->c->pool, sizeof(*ctx));
- ctx->b = apr_brigade_create(f->c->pool, f->c->bucket_alloc);
-+ ctx->tmpbb = apr_brigade_create(ctx->b->p, ctx->b->bucket_alloc);
-
- /* seed the brigade with the client socket. */
- e = apr_bucket_socket_create(net->client_socket, f->c->bucket_alloc);
-@@ -3814,7 +3837,6 @@
- /* read up to the amount they specified. */
- if (mode == AP_MODE_READBYTES || mode == AP_MODE_SPECULATIVE) {
- apr_bucket *e;
-- apr_bucket_brigade *newbb;
-
- AP_DEBUG_ASSERT(readbytes > 0);
-
-@@ -3855,8 +3877,8 @@
- return rv;
- }
-
-- /* Must do split before CONCAT */
-- newbb = apr_brigade_split(ctx->b, e);
-+ /* Must do move before CONCAT */
-+ brigade_move(ctx->b, ctx->tmpbb, e);
-
- if (mode == AP_MODE_READBYTES) {
- APR_BRIGADE_CONCAT(b, ctx->b);
-@@ -3873,7 +3895,7 @@
- }
-
- /* Take what was originally there and place it back on ctx->b */
-- APR_BRIGADE_CONCAT(ctx->b, newbb);
-+ APR_BRIGADE_CONCAT(ctx->b, ctx->tmpbb);
- }
- return APR_SUCCESS;
- }