aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2012-09-05 05:17:06 +0800
committerohauer <ohauer@FreeBSD.org>2012-09-05 05:17:06 +0800
commit1d1f0056e05bc3c07687df5d6f5081eceef9a629 (patch)
treee17a11132a314ce9ce8f288b3314f6c36ce8dd0f /www
parentd14555c4d96e523eda547fc3e9e21176cc66bd4f (diff)
downloadfreebsd-ports-gnome-1d1f0056e05bc3c07687df5d6f5081eceef9a629.tar.gz
freebsd-ports-gnome-1d1f0056e05bc3c07687df5d6f5081eceef9a629.tar.zst
freebsd-ports-gnome-1d1f0056e05bc3c07687df5d6f5081eceef9a629.zip
- Simplify options with the removal of the last APR only related parameter [1]
- disallow IPv6 sockets to handle IPv4 requests per default. [2] - move extra-patch-server__config.c -> patch-server__config.c https://issues.apache.org/bugzilla/show_bug.cgi?id=53823 - bump PORTREVISION [1] Credits to Hajimu UMEMOTO (ume@) for finding the last APR related parameter [2] http://httpd.apache.org/docs/2.2/bind.html with hat apache@
Diffstat (limited to 'www')
-rw-r--r--www/apache22/Makefile6
-rw-r--r--www/apache22/Makefile.doc10
-rw-r--r--www/apache22/Makefile.modules15
-rw-r--r--www/apache22/Makefile.options11
-rw-r--r--www/apache22/files/patch-server__config.c (renamed from www/apache22/files/extra-patch-server__config.c)13
5 files changed, 28 insertions, 27 deletions
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index f26b27f7c8ab..2b3f2812c6b6 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -2,8 +2,8 @@
PORTNAME= apache22
PORTVERSION= 2.2.22
-PORTREVISION= 7
-CATEGORIES= www
+PORTREVISION= 8
+CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
DISTNAME= httpd-${PORTVERSION}
DIST_SUBDIR= apache22
@@ -116,6 +116,8 @@ show-options:
@${SED} -ne 's/^##//p' ${APACHEDIR}/Makefile.doc
post-patch:
+ @${REINPLACE_CMD} -e 's|freebsd5|freebsd|' \
+ ${WRKSRC}/configure.in ${WRKSRC}/configure
@${RM} -f ${WRKSRC}/docs/docroot/*.bak
@${REINPLACE_CMD} -e 's," PLATFORM ",FreeBSD,' ${WRKSRC}/server/core.c
@${INSTALL_DATA} ${WRKSRC}/NOTICE ${WRKSRC}/docs/manual
diff --git a/www/apache22/Makefile.doc b/www/apache22/Makefile.doc
index 0dccb2f3c4a1..580310dc4ede 100644
--- a/www/apache22/Makefile.doc
+++ b/www/apache22/Makefile.doc
@@ -21,7 +21,7 @@
## WITH_STATIC_MODULES)
## WITH_ALL_STATIC_MODULES: All modules will be statically linked.
## WITH_STATIC_MODULES (*): List of modules to build modules statics
-## (usefull for slave ports)
+## (useful for slave ports)
## (They must be already enabled (i.e.
## WITH_MODULES or with default configuration
## use 'make show-modules', to check if they are
@@ -37,7 +37,7 @@
## ${WWWOWN} (www))
## SUEXEC_UMASK: Defines umask for suEXEC'd process(default:
## unset)
-## WITH_DEBUG: Build a debug version of apache (set CFLAGS
+## WITH_DEBUG: Build a debug version of Apache (set CFLAGS
## to "-O0 -g -ggdb3" or ${DEBUG_FLAGS} and
## defines WITH_EXCEPTION_HOOK too)
## WITH_EXCEPTION_HOOK: Enable fatal exception hook
@@ -58,6 +58,12 @@
## Note: If you define your custom options in /etc/make.conf, don't forget
## to do not use quotes.
##
+## Note about OPTION IPV4_MAPPED
+## For security reasons this OPTION is disabled.
+## You can find more information about IP binding and configuration
+## on the Apache website: http://httpd.apache.org/docs/2.2/bind.html
+## To find out which binding was used to build httpd use the command
+## $> httpd -V
MAKE_ENV+= EXAMPLESDIR=${EXAMPLESDIR}
diff --git a/www/apache22/Makefile.modules b/www/apache22/Makefile.modules
index c642233ff195..bf372b93f3a8 100644
--- a/www/apache22/Makefile.modules
+++ b/www/apache22/Makefile.modules
@@ -82,7 +82,9 @@ LATEST_LINK= apache22-${WITH_MPM}-mpm
.if ${WITH_MPM} == "worker" || ${WITH_MPM} == "event"
PORT_OPTIONS+= CGID
.if ${PORT_OPTIONS:MCGI}
-IGNORE= does not build with CGI. Please de-select CGI and select CGID instead
+IGNORE= When using a multi-threaded MPM, the module CGID should be used in place CGI. \
+ Please de-select CGI and select CGID instead. \
+ See http://httpd.apache.org/docs/2.2/mod/mod_cgi.html
.endif
.if exists(${APR_CONFIG}) && !defined(APR_HAS_THREADS)
IGNORE= requires APR threads. Please rebuild APR with THREAD support
@@ -143,16 +145,11 @@ IGNORE= MEM_CACHE requires APR threads. Please rebuild APR with THREAD support
. endif
.endif
-.if empty(PORT_OPTIONS:MIPV6)
-CONFIGURE_ARGS+= --disable-ipv6
+# http://httpd.apache.org/docs/2.2/bind.html
+.if ${PORT_OPTIONS:MIPV4_MAPPED}
+CONFIGURE_ARGS+= --enable-v4-mapped
.else
-CATEGORIES+= ipv6
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-server__config.c
-. if ${PORT_OPTIONS:MIPV6_V6ONLY}
CONFIGURE_ARGS+= --disable-v4-mapped
-. else
-CONFIGURE_ARGS+= --enable-v4-mapped
-. endif
.endif
CONFIGURE_ARGS+= --with-mpm=${WITH_MPM}
diff --git a/www/apache22/Makefile.options b/www/apache22/Makefile.options
index 4f6b21f87244..b3676f79997a 100644
--- a/www/apache22/Makefile.options
+++ b/www/apache22/Makefile.options
@@ -105,6 +105,7 @@ OPTIONS_DEFINE= \
SUEXEC_USERDIR \
REQTIMEOUT \
PROXY \
+ IPV4_MAPPED \
BUCKETEER \
CASE_FILTER \
CASE_FILTER_IN \
@@ -115,9 +116,6 @@ OPTIONS_DEFINE= \
OPTIONAL_FN_IMPORT \
OPTIONAL_FN_EXPORT
-OPTIONS_SINGLE=INET
-OPTIONS_SINGLE_INET=IPV6 IPV4_ONLY IPV6_ONLY
-
OPTIONS_MULTI=PROXY
OPTIONS_MULTI_PROXY=PROXY_AJP PROXY_BALANCER PROXY_CONNECT PROXY_FTP PROXY_HTTP PROXY_SCGI
@@ -158,7 +156,6 @@ OPTIONS_DEFAULT= \
IMAGEMAP \
INCLUDE \
INFO \
- IPV6 \
LOGIO \
LOG_CONFIG \
MIME \
@@ -176,11 +173,6 @@ OPTIONS_DEFAULT= \
VERSION \
VHOST_ALIAS
-# Overwrite Mk/bsd.options.desc.mk
-IPV6_DESC= IPv6 support
-IPV4_ONLY_DESC= IPv4 only
-IPV6_ONLY_DESC= IPv6 only
-
# sort list alphanumeric
ACTIONS_DESC= mod_actions
ALIAS_DESC= mod_alias
@@ -226,6 +218,7 @@ HEADERS_DESC= mod_headers
IMAGEMAP_DESC= mod_imagemap
INCLUDE_DESC= mod_include
INFO_DESC= mod_info
+IPV4_MAPPED_DESC= Allow IPv6 socket to handle IPv4
LDAP_DESC= connection pooling, result caching
LOGIO_DESC= mod_logio
LOG_CONFIG_DESC= mod_log_config
diff --git a/www/apache22/files/extra-patch-server__config.c b/www/apache22/files/patch-server__config.c
index 0c567e7517d5..732a65f1f417 100644
--- a/www/apache22/files/extra-patch-server__config.c
+++ b/www/apache22/files/patch-server__config.c
@@ -1,11 +1,14 @@
---- ./server/config.c.orig 2012-08-13 21:15:02.000000000 +0200
-+++ ./server/config.c 2012-08-13 21:22:15.000000000 +0200
-@@ -1979,6 +1979,11 @@
+Fix for IPv6 only hosts, reported by Curtis Villamizar
+http://lists.freebsd.org/pipermail/freebsd-apache/2012-August/002836.html
+https://issues.apache.org/bugzilla/show_bug.cgi?id=53823
+
+==================================================================
+--- ./server/config.c.orig 2010-10-07 18:56:54.000000000 +0200
++++ ./server/config.c 2012-09-03 21:23:31.000000000 +0200
+@@ -1979,6 +1979,9 @@
/* NOT virtual host; don't match any real network interface */
rv = apr_sockaddr_info_get(&s->addrs->host_addr,
NULL, APR_INET, 0, 0, p);
-+ /* Support for IPv6 only, reported by Curtis Villamizar <curtis@occnc.com> */
-+ /* http://lists.freebsd.org/pipermail/freebsd-apache/2012-August/002836.html */
+ if (rv != APR_SUCCESS)
+ rv = apr_sockaddr_info_get(&s->addrs->host_addr,
+ NULL, APR_INET6, 0, 0, p);