aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2008-08-07 09:54:47 +0800
committermezz <mezz@FreeBSD.org>2008-08-07 09:54:47 +0800
commit1d2040b536e3bb9b096eaebfb835873651c69e20 (patch)
tree6b520f8e850895b872b039f989d560b44e6a8fb1 /www
parent2828a925f8241be04d9c1e654e0981641a135f5d (diff)
downloadfreebsd-ports-gnome-1d2040b536e3bb9b096eaebfb835873651c69e20.tar.gz
freebsd-ports-gnome-1d2040b536e3bb9b096eaebfb835873651c69e20.tar.zst
freebsd-ports-gnome-1d2040b536e3bb9b096eaebfb835873651c69e20.zip
- Update to 1.31, be sure to read in UPDATING.
- Move transmission to transmission-cli, transmission becomes a meta-port. - Add transmission-web, it's a web interface (Clutch) as it has merged into its project. Repocopy: marcus (transmission -> transmission-cli)
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/transmission-web/Makefile22
-rw-r--r--www/transmission-web/pkg-descr16
-rw-r--r--www/transmission-web/pkg-plist46
4 files changed, 85 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 9e8ef3fecb90..c429ec774dfa 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1359,6 +1359,7 @@
SUBDIR += trac-wikitemplates
SUBDIR += trac-wysiwyg
SUBDIR += trac-xmlrpc
+ SUBDIR += transmission-www
SUBDIR += transproxy
SUBDIR += twhttpd
SUBDIR += twig
diff --git a/www/transmission-web/Makefile b/www/transmission-web/Makefile
new file mode 100644
index 000000000000..40144c04d255
--- /dev/null
+++ b/www/transmission-web/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: transmission-web
+# Date created: 14 July 2008
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= www net-p2p
+PKGNAMESUFFIX= -web
+
+MAINTAINER= mezz@FreeBSD.org
+COMMENT= A fast and lightweight WebUI for Transmission BitTorrent client
+
+DESCR= ${.CURDIR}/pkg-descr
+MASTERDIR= ${.CURDIR}/../../net-p2p/transmission-cli
+PLIST= ${.CURDIR}/pkg-plist
+SLAVEPORT= web
+
+NO_BUILD= yes
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/transmission-web/pkg-descr b/www/transmission-web/pkg-descr
new file mode 100644
index 000000000000..5c3661bbedf9
--- /dev/null
+++ b/www/transmission-web/pkg-descr
@@ -0,0 +1,16 @@
+Transmission Web Interface (Clutch) is a WebUI for the Transmission BitTorrent
+client. It allows you to manage your torrents from anywhere you can access the
+internet, and runs on OS X and various flavors of *nix. It provides most of
+the basic features of the desktop client, including torrent upload, torrent
+start/stop, file path selection, speed limiting etc.
+
+Transmission has been built from the ground up to be a lightweight, yet
+powerful BitTorrent client. Its simple, intuitive interface is designed
+to integrate tightly with whatever computing environment you choose to
+use. Transmission strikes a balance between providing useful functionality
+without feature bloat. Furthermore, it is free for anyone to use or modify.
+
+You will need to install either transmission-daemon, transmission-gtk2 or
+both to use WebUI.
+
+WWW: http://www.transmissionbt.com/
diff --git a/www/transmission-web/pkg-plist b/www/transmission-web/pkg-plist
new file mode 100644
index 000000000000..115bad4de10b
--- /dev/null
+++ b/www/transmission-web/pkg-plist
@@ -0,0 +1,46 @@
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%DATADIR%%/web/LICENSE
+%%DATADIR%%/web/images/buttons/info_activity.png
+%%DATADIR%%/web/images/buttons/info_general.png
+%%DATADIR%%/web/images/buttons/tab_backgrounds.png
+%%DATADIR%%/web/images/buttons/toolbar_buttons.png
+%%DATADIR%%/web/images/buttons/torrent_buttons.png
+%%DATADIR%%/web/images/favicon.ico
+%%DATADIR%%/web/images/graphics/browser_firefox.gif
+%%DATADIR%%/web/images/graphics/browser_opera.gif
+%%DATADIR%%/web/images/graphics/browser_safari.gif
+%%DATADIR%%/web/images/graphics/chrome.png
+%%DATADIR%%/web/images/graphics/filter_bar.png
+%%DATADIR%%/web/images/graphics/iphone_chrome.png
+%%DATADIR%%/web/images/graphics/logo.png
+%%DATADIR%%/web/images/graphics/transfer_arrows.png
+%%DATADIR%%/web/images/progress/progress.png
+%%DATADIR%%/web/images/webclip-icon.png
+%%DATADIR%%/web/index.html
+%%DATADIR%%/web/javascript/common.js
+%%DATADIR%%/web/javascript/dialog.js
+%%DATADIR%%/web/javascript/jquery/jquery-dimensions.min.js
+%%DATADIR%%/web/javascript/jquery/jquery.contextmenu.min.js
+%%DATADIR%%/web/javascript/jquery/jquery.form.min.js
+%%DATADIR%%/web/javascript/jquery/jquery.min.js
+%%DATADIR%%/web/javascript/jquery/jquery.transmenu.min.js
+%%DATADIR%%/web/javascript/jquery/json.min.js
+%%DATADIR%%/web/javascript/menu.js
+%%DATADIR%%/web/javascript/torrent.js
+%%DATADIR%%/web/javascript/transmission.js
+%%DATADIR%%/web/javascript/transmission.remote.js
+%%DATADIR%%/web/stylesheets/common.css
+%%DATADIR%%/web/stylesheets/iphone.css
+@dirrm %%DATADIR%%/web/stylesheets
+@dirrm %%DATADIR%%/web/javascript/jquery
+@dirrm %%DATADIR%%/web/javascript
+@dirrm %%DATADIR%%/web/images/progress
+@dirrm %%DATADIR%%/web/images/graphics
+@dirrm %%DATADIR%%/web/images/buttons
+@dirrm %%DATADIR%%/web/images
+@dirrm %%DATADIR%%/web
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%