aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2004-07-04 21:00:43 +0800
committerkuriyama <kuriyama@FreeBSD.org>2004-07-04 21:00:43 +0800
commit2373184a393b6eb00506ce7640527ab4ec0f3dee (patch)
tree4fd528c1fc8e94c1a411ba8d431cdcdde29f71e9 /www
parent6ace60168c9adb3ac70c274f777f941551d6dd88 (diff)
downloadfreebsd-ports-gnome-2373184a393b6eb00506ce7640527ab4ec0f3dee.tar.gz
freebsd-ports-gnome-2373184a393b6eb00506ce7640527ab4ec0f3dee.tar.zst
freebsd-ports-gnome-2373184a393b6eb00506ce7640527ab4ec0f3dee.zip
o Rename p5-Flash-FLAP to p5-AMF-Perl.
o Upgrade to 0.12. Approved by: maintainer
Diffstat (limited to 'www')
-rw-r--r--www/Makefile2
-rw-r--r--www/p5-AMF-Perl/Makefile17
-rw-r--r--www/p5-AMF-Perl/distinfo4
-rw-r--r--www/p5-AMF-Perl/files/patch-Perl.pm27
-rw-r--r--www/p5-AMF-Perl/pkg-plist36
-rw-r--r--www/p5-Flash-FLAP/Makefile30
-rw-r--r--www/p5-Flash-FLAP/distinfo2
-rw-r--r--www/p5-Flash-FLAP/pkg-descr17
-rw-r--r--www/p5-Flash-FLAP/pkg-plist18
9 files changed, 57 insertions, 96 deletions
diff --git a/www/Makefile b/www/Makefile
index 29bcf0aedb8a..1261acec4ef8 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -344,6 +344,7 @@
SUBDIR += openvrml
SUBDIR += opera
SUBDIR += oscommerce
+ SUBDIR += p5-AMF-Perl
SUBDIR += p5-Apache-ASP
SUBDIR += p5-Apache-AddHostPath
SUBDIR += p5-Apache-Admin-Config
@@ -415,7 +416,6 @@
SUBDIR += p5-FAQ-OMatic
SUBDIR += p5-FastCGI
SUBDIR += p5-FastCGI-ProcManager
- SUBDIR += p5-Flash-FLAP
SUBDIR += p5-GtkHTML
SUBDIR += p5-HTML
SUBDIR += p5-HTML-Breadcrumbs
diff --git a/www/p5-AMF-Perl/Makefile b/www/p5-AMF-Perl/Makefile
index 5dcee068cb42..f8b41b9bb765 100644
--- a/www/p5-AMF-Perl/Makefile
+++ b/www/p5-AMF-Perl/Makefile
@@ -5,11 +5,11 @@
# $FreeBSD$
#
-PORTNAME= Flash-FLAP
-PORTVERSION= 0.09
+PORTNAME= AMF-Perl
+PORTVERSION= 0.12
CATEGORIES= www devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= Flash
+MASTER_SITE_SUBDIR= ../../authors/id/S/SI/SIMONF
PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
@@ -17,11 +17,12 @@ COMMENT= Flash Remoting in Perl
PERL_CONFIGURE= yes
-MAN3= Flash::FLAP.3 Flash::FLAP::App::Executive.3 \
- Flash::FLAP::IO::Deserializer.3 Flash::FLAP::IO::InputStream.3 \
- Flash::FLAP::IO::OutputStream.3 Flash::FLAP::IO::Serializer.3 \
- Flash::FLAP::Sql::MysqlRecordSet.3 Flash::FLAP::Util::Object.3 \
- Flash::FLAP::Util::RemotingService.3
+NOMANCOMPRESS= no
+MAN3= AMF::Perl.3 AMF::Perl::App::Executive.3 \
+ AMF::Perl::IO::Deserializer.3 AMF::Perl::IO::InputStream.3 \
+ AMF::Perl::IO::OutputStream.3 AMF::Perl::IO::Serializer.3 \
+ AMF::Perl::Sql::MysqlRecordSet.3 AMF::Perl::Util::Object.3 \
+ AMF::Perl::Util::RemotingService.3
post-configure:
# dirty hack to deceive irritable pod2man
diff --git a/www/p5-AMF-Perl/distinfo b/www/p5-AMF-Perl/distinfo
index 96c1ab76691e..ca29e239ffd1 100644
--- a/www/p5-AMF-Perl/distinfo
+++ b/www/p5-AMF-Perl/distinfo
@@ -1,2 +1,2 @@
-MD5 (Flash-FLAP-0.09.tar.gz) = f20839509ea011e5bbc46c4587e64748
-SIZE (Flash-FLAP-0.09.tar.gz) = 447459
+MD5 (AMF-Perl-0.12.tar.gz) = 660ef0e9fc9e8954b555534eaa1f8a59
+SIZE (AMF-Perl-0.12.tar.gz) = 448171
diff --git a/www/p5-AMF-Perl/files/patch-Perl.pm b/www/p5-AMF-Perl/files/patch-Perl.pm
new file mode 100644
index 000000000000..4f1bda91cc31
--- /dev/null
+++ b/www/p5-AMF-Perl/files/patch-Perl.pm
@@ -0,0 +1,27 @@
+--- lib/AMF/Perl.pm.orig Tue Jun 29 15:39:46 2004
++++ lib/AMF/Perl.pm Tue Jun 29 15:41:17 2004
+@@ -103,18 +103,23 @@
+ John Cowen - datatype io additions, class structure
+ Klaasjan Tukker - modifications, check routines, and register-framework
+
+-==head1 CHANGES
++=head1 CHANGES
++
+ =head2 Thu Apr 29 17:20:07 EDT 2004
++
+ =item Changed "use Apache2" to "require Apache2" to avoid breaking on non-modperl systems.
+
+ =head2 Sat Apr 24 20:41:10 EDT 2004
++
+ =item Another patch from Kostas Chatzikokolakis fixing MP2 issues.
+
+ =head2 Sat Mar 13 16:25:00 EST 2004
+
+ =item Patch from Kostas Chatzikokolakis handling encoding.
++
+ =item Changed non-mod_perl behavior for reading POST data from using <> to using read()
+ to work around a bug in IIS
++
+ =item Joined code for mod_perl 1 and 2. Separated the output code for the mod_perl and non-mod_perl
+ cases.
+
diff --git a/www/p5-AMF-Perl/pkg-plist b/www/p5-AMF-Perl/pkg-plist
index d0b2feb730fe..b8ba63095b36 100644
--- a/www/p5-AMF-Perl/pkg-plist
+++ b/www/p5-AMF-Perl/pkg-plist
@@ -1,18 +1,18 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Flash/FLAP/.packlist
-%%SITE_PERL%%/Flash/FLAP.pm
-%%SITE_PERL%%/Flash/FLAP/App/Executive.pm
-%%SITE_PERL%%/Flash/FLAP/IO/Deserializer.pm
-%%SITE_PERL%%/Flash/FLAP/IO/InputStream.pm
-%%SITE_PERL%%/Flash/FLAP/IO/OutputStream.pm
-%%SITE_PERL%%/Flash/FLAP/IO/Serializer.pm
-%%SITE_PERL%%/Flash/FLAP/Sql/MysqlRecordSet.pm
-%%SITE_PERL%%/Flash/FLAP/Util/Object.pm
-%%SITE_PERL%%/Flash/FLAP/Util/RemotingService.pm
-@dirrm %%SITE_PERL%%/Flash/FLAP/App
-@dirrm %%SITE_PERL%%/Flash/FLAP/IO
-@dirrm %%SITE_PERL%%/Flash/FLAP/Sql
-@dirrm %%SITE_PERL%%/Flash/FLAP/Util
-@dirrm %%SITE_PERL%%/Flash/FLAP
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Flash/FLAP
-@unexec rmdir %D/%%SITE_PERL%%/Flash 2>/dev/null || true
-@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Flash 2>/dev/null || true
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/AMF/Perl/.packlist
+%%SITE_PERL%%/AMF/Perl.pm
+%%SITE_PERL%%/AMF/Perl/App/Executive.pm
+%%SITE_PERL%%/AMF/Perl/IO/Deserializer.pm
+%%SITE_PERL%%/AMF/Perl/IO/InputStream.pm
+%%SITE_PERL%%/AMF/Perl/IO/OutputStream.pm
+%%SITE_PERL%%/AMF/Perl/IO/Serializer.pm
+%%SITE_PERL%%/AMF/Perl/Sql/MysqlRecordSet.pm
+%%SITE_PERL%%/AMF/Perl/Util/Object.pm
+%%SITE_PERL%%/AMF/Perl/Util/RemotingService.pm
+@dirrm %%SITE_PERL%%/AMF/Perl/App
+@dirrm %%SITE_PERL%%/AMF/Perl/IO
+@dirrm %%SITE_PERL%%/AMF/Perl/Sql
+@dirrm %%SITE_PERL%%/AMF/Perl/Util
+@dirrm %%SITE_PERL%%/AMF/Perl
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/AMF/Perl
+@unexec rmdir %D/%%SITE_PERL%%/AMF 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/AMF 2>/dev/null || true
diff --git a/www/p5-Flash-FLAP/Makefile b/www/p5-Flash-FLAP/Makefile
deleted file mode 100644
index 5dcee068cb42..000000000000
--- a/www/p5-Flash-FLAP/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-# New ports collection makefile for: Flash-FLAP
-# Date created: 20 May 2003
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
-# $FreeBSD$
-#
-
-PORTNAME= Flash-FLAP
-PORTVERSION= 0.09
-CATEGORIES= www devel perl5
-MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= Flash
-PKGNAMEPREFIX= p5-
-
-MAINTAINER= skv@FreeBSD.org
-COMMENT= Flash Remoting in Perl
-
-PERL_CONFIGURE= yes
-
-MAN3= Flash::FLAP.3 Flash::FLAP::App::Executive.3 \
- Flash::FLAP::IO::Deserializer.3 Flash::FLAP::IO::InputStream.3 \
- Flash::FLAP::IO::OutputStream.3 Flash::FLAP::IO::Serializer.3 \
- Flash::FLAP::Sql::MysqlRecordSet.3 Flash::FLAP::Util::Object.3 \
- Flash::FLAP::Util::RemotingService.3
-
-post-configure:
-# dirty hack to deceive irritable pod2man
- @${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
-
-.include <bsd.port.mk>
diff --git a/www/p5-Flash-FLAP/distinfo b/www/p5-Flash-FLAP/distinfo
deleted file mode 100644
index 96c1ab76691e..000000000000
--- a/www/p5-Flash-FLAP/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (Flash-FLAP-0.09.tar.gz) = f20839509ea011e5bbc46c4587e64748
-SIZE (Flash-FLAP-0.09.tar.gz) = 447459
diff --git a/www/p5-Flash-FLAP/pkg-descr b/www/p5-Flash-FLAP/pkg-descr
deleted file mode 100644
index 0ed4dba72e64..000000000000
--- a/www/p5-Flash-FLAP/pkg-descr
+++ /dev/null
@@ -1,17 +0,0 @@
-Flash Remoting is a way for Flash movies running in a web browser to
-request structured data from the web server. The following data types
-are supported - strings, numbers, dates, arrays, dictionaries/hashes,
-objects, recordsets. Flash clients talk with the server using the AMF
-protocol, which is proprietary to Macromedia. However, it's not that
-hard to decode.
-
-Using Flash::FLAP it is possible to send arbitrary data between client
-and server using very few lines of code. There is no need to pack
-complicated data structures into CGI form parameteres or XML strings.
-The coding time can be spent on better things - data preparation and
-graphical presentation, not data delivery.
-
-WWW: http://search.cpan.org/dist/Flash-FLAP/
-
--- Sergey Skvortsov
-skv@FreeBSD.org
diff --git a/www/p5-Flash-FLAP/pkg-plist b/www/p5-Flash-FLAP/pkg-plist
deleted file mode 100644
index d0b2feb730fe..000000000000
--- a/www/p5-Flash-FLAP/pkg-plist
+++ /dev/null
@@ -1,18 +0,0 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Flash/FLAP/.packlist
-%%SITE_PERL%%/Flash/FLAP.pm
-%%SITE_PERL%%/Flash/FLAP/App/Executive.pm
-%%SITE_PERL%%/Flash/FLAP/IO/Deserializer.pm
-%%SITE_PERL%%/Flash/FLAP/IO/InputStream.pm
-%%SITE_PERL%%/Flash/FLAP/IO/OutputStream.pm
-%%SITE_PERL%%/Flash/FLAP/IO/Serializer.pm
-%%SITE_PERL%%/Flash/FLAP/Sql/MysqlRecordSet.pm
-%%SITE_PERL%%/Flash/FLAP/Util/Object.pm
-%%SITE_PERL%%/Flash/FLAP/Util/RemotingService.pm
-@dirrm %%SITE_PERL%%/Flash/FLAP/App
-@dirrm %%SITE_PERL%%/Flash/FLAP/IO
-@dirrm %%SITE_PERL%%/Flash/FLAP/Sql
-@dirrm %%SITE_PERL%%/Flash/FLAP/Util
-@dirrm %%SITE_PERL%%/Flash/FLAP
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Flash/FLAP
-@unexec rmdir %D/%%SITE_PERL%%/Flash 2>/dev/null || true
-@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Flash 2>/dev/null || true