aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2002-02-15 15:33:42 +0800
committerkevlo <kevlo@FreeBSD.org>2002-02-15 15:33:42 +0800
commit25444e436d013ac1231d1abe89e3a291d17f3d09 (patch)
treec0d9516ff993ecadd38962639cdabd396d1a39b7 /www
parent24b05515f47e98da5fb7de30e08009e3a4f0a3a1 (diff)
downloadfreebsd-ports-gnome-25444e436d013ac1231d1abe89e3a291d17f3d09.tar.gz
freebsd-ports-gnome-25444e436d013ac1231d1abe89e3a291d17f3d09.tar.zst
freebsd-ports-gnome-25444e436d013ac1231d1abe89e3a291d17f3d09.zip
Initial import of p5-HTML-StickyQuery 0.07
This module is sub class of the HTML::Parser and uses it to parse HTML document and add QUERY_STRING to href attributes. PR: 34256 Submitted by: Seamus Venasse <svenasse@polaris.ca>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTML-StickyQuery/Makefile27
-rw-r--r--www/p5-HTML-StickyQuery/distinfo1
-rw-r--r--www/p5-HTML-StickyQuery/pkg-comment1
-rw-r--r--www/p5-HTML-StickyQuery/pkg-descr8
-rw-r--r--www/p5-HTML-StickyQuery/pkg-plist5
6 files changed, 43 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 366bdfc97c34..31569c213f5b 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -265,6 +265,7 @@
SUBDIR += p5-HTML-Parser
SUBDIR += p5-HTML-QuickCheck
SUBDIR += p5-HTML-SimpleParse
+ SUBDIR += p5-HTML-StickyQuery
SUBDIR += p5-HTML-Stream
SUBDIR += p5-HTML-Summary
SUBDIR += p5-HTML-Table
diff --git a/www/p5-HTML-StickyQuery/Makefile b/www/p5-HTML-StickyQuery/Makefile
new file mode 100644
index 000000000000..fbf6e65618b0
--- /dev/null
+++ b/www/p5-HTML-StickyQuery/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: HTML::StickyQuery
+# Date created: 24 Jan 2002
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-StickyQuery
+PORTVERSION= 0.07
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+PERL_CONFIGURE= yes
+
+MAN3= HTML::StickyQuery.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-StickyQuery/distinfo b/www/p5-HTML-StickyQuery/distinfo
new file mode 100644
index 000000000000..33a55878bd7c
--- /dev/null
+++ b/www/p5-HTML-StickyQuery/distinfo
@@ -0,0 +1 @@
+MD5 (HTML-StickyQuery-0.07.tar.gz) = ba33e5fa4b567814af526fc94d9ebbdf
diff --git a/www/p5-HTML-StickyQuery/pkg-comment b/www/p5-HTML-StickyQuery/pkg-comment
new file mode 100644
index 000000000000..cd4035e8a3da
--- /dev/null
+++ b/www/p5-HTML-StickyQuery/pkg-comment
@@ -0,0 +1 @@
+Add sticky QUERY_STRING to a tag href attributes
diff --git a/www/p5-HTML-StickyQuery/pkg-descr b/www/p5-HTML-StickyQuery/pkg-descr
new file mode 100644
index 000000000000..a3067550eda7
--- /dev/null
+++ b/www/p5-HTML-StickyQuery/pkg-descr
@@ -0,0 +1,8 @@
+This module is sub class of the HTML::Parser and uses it to
+parse HTML document and add QUERY_STRING to href attributes.
+
+You can assign Session ID or any form data without using cookie.
+
+WWW: http://search.cpan.org/search?dist=HTML-StickyQuery
+
+Seamus Venasse <svenasse@polaris.ca>
diff --git a/www/p5-HTML-StickyQuery/pkg-plist b/www/p5-HTML-StickyQuery/pkg-plist
new file mode 100644
index 000000000000..2f2a42ebc1c4
--- /dev/null
+++ b/www/p5-HTML-StickyQuery/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTML/StickyQuery/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/HTML/StickyQuery.pm
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/HTML 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTML/StickyQuery 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTML 2>/dev/null || true