aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-06 14:54:19 +0800
committerbapt <bapt@FreeBSD.org>2013-05-06 14:54:19 +0800
commit2ad539a9d0b6ab43e2c070f8863ca627b4c7b46c (patch)
tree917c9e74d0d7de4a4a9e126b6be668086605c02f /www
parent0cce2ec92885a6236f3297031540b23a3bd3b2a2 (diff)
downloadfreebsd-ports-gnome-2ad539a9d0b6ab43e2c070f8863ca627b4c7b46c.tar.gz
freebsd-ports-gnome-2ad539a9d0b6ab43e2c070f8863ca627b4c7b46c.tar.zst
freebsd-ports-gnome-2ad539a9d0b6ab43e2c070f8863ca627b4c7b46c.zip
Finish converting www from WITHOUT_NLS to PORT_OPTIONS:MNLS
Diffstat (limited to 'www')
-rw-r--r--www/arora/Makefile13
-rw-r--r--www/cadaver/Makefile10
-rw-r--r--www/dillo-i18n/Makefile4
-rw-r--r--www/gallery/Makefile8
-rw-r--r--www/neon29/Makefile55
-rw-r--r--www/sitecopy/Makefile16
6 files changed, 45 insertions, 61 deletions
diff --git a/www/arora/Makefile b/www/arora/Makefile
index 7dd4c7bc25d9..d412bee935a2 100644
--- a/www/arora/Makefile
+++ b/www/arora/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: arora
-# Date created: 08 Aug 2008
-# Whom: Andy Fawcett <andy@athame.co.uk>
-#
+# Created by: Andy Fawcett <andy@athame.co.uk>
# $FreeBSD$
PORTNAME= arora
@@ -23,13 +20,13 @@ MAKE_JOBS_SAFE= yes
MAN1= arora.1 arora-cacheinfo.1 arora-placesimport.1 htmlToXBel.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${ARCH} == ia64
BROKEN= core dump on application startup
.endif
-.if defined(WITHOUT_NLS)
+.if ! ${PORT_OPTIONS:MNLS}
PLIST_SUB+= NLS="@comment "
.else
USE_QT4+= linguist_build
@@ -37,7 +34,7 @@ PLIST_SUB+= NLS=""
.endif
do-configure:
-.if defined(WITHOUT_NLS)
+.if ! ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e "/INSTALLS/s|translations||" \
${WRKSRC}/src/src.pro
@${REINPLACE_CMD} -e "s|target_predeps||" \
@@ -67,4 +64,4 @@ post-install:
${WRKSRC}/tools/placesimport/data/arora-placesimport.1 \
${PREFIX}/man/man1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/cadaver/Makefile b/www/cadaver/Makefile
index 73d4f25248a4..0d71be12716c 100644
--- a/www/cadaver/Makefile
+++ b/www/cadaver/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cadaver
-# Date created: 13 January 2000
-# Whom: Alex Povolotsky <tarkhil@over.ru>
-#
+# Created by: Alex Povolotsky <tarkhil@over.ru>
# $FreeBSD$
-#
PORTNAME= cadaver
PORTVERSION= 0.23.3
@@ -50,7 +46,9 @@ post-install:
#
.endif
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES= gettext iconv
CONFIGURE_ARGS+=--with-libiconv-prefix=${LOCALBASE} \
--with-libintl-prefix=${LOCALBASE}
diff --git a/www/dillo-i18n/Makefile b/www/dillo-i18n/Makefile
index af4bc28e837c..848c526e1866 100644
--- a/www/dillo-i18n/Makefile
+++ b/www/dillo-i18n/Makefile
@@ -42,7 +42,9 @@ CONFIGURE_ARGS= --enable-cookies --enable-threaded-dns \
CONFLICTS= dillo-[0-9].[0-9].[0-9]*
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB= NLS=""
CONFIGURE_ARGS+= --enable-nls
diff --git a/www/gallery/Makefile b/www/gallery/Makefile
index 45d158821e37..cde04ee211ca 100644
--- a/www/gallery/Makefile
+++ b/www/gallery/Makefile
@@ -14,12 +14,14 @@ COMMENT= Slick web based photo album written using PHP
RUN_DEPENDS= giftopnm:${PORTSDIR}/graphics/netpbm \
jhead:${PORTSDIR}/graphics/jhead \
- unzip:${PORTSDIR}/archivers/unzip
+ ${UNZIP_CMD}:${PORTSDIR}/archivers/unzip
USE_PHP= pcre session
WANT_PHP_WEB= yes
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USE_PHP+= gettext
USES+= gettext
@@ -98,7 +100,7 @@ do-install:
-o -print | ${CPIO} ${CPIOARGS} ${WWWOWN}:${WWWGRP} ${WWWDIR}
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@ ${INSTALL} -d ${DOCSDIR}
@ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
diff --git a/www/neon29/Makefile b/www/neon29/Makefile
index a6e153e55b1f..fd19bda6c095 100644
--- a/www/neon29/Makefile
+++ b/www/neon29/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: neon
-# Date created: 13 October 2000
-# Whom: Mikhail Teterin <mi@aldan.algebra.com>
-#
+# Created by: Mikhail Teterin <mi@aldan.algebra.com>
# $FreeBSD$
-#
PORTNAME= neon29
PORTVERSION= 0.29.6
@@ -17,56 +13,53 @@ COMMENT= An HTTP and WebDAV client library for Unix systems
CONFLICTS= neon2[6|8]-[0-9]*
-OPTIONS= EXPAT "Build with expat-based XML parser" on \
- XML "Build with libxml-based XML parser" off \
- OPENSSL "Build with SSL support" on \
- NLS "Build with NLS support" on \
- GSSAPI "Build with GSSAPI support" on \
- PROXY "Build with libproxy support" off
+OPTIONS_DEFINE= OPENSSL NLS GSSAPI PROXY DOCS
+OPTIONS_DEFAULT= EXPAT OPENSSL NLS GSSAPI
+OPTIONS_SINGLE= XML
+OPTIONS_SINGLE_XML= EXPAT LIBXML
+XML_DESC= XML parser library
+LIBXML_DESC= libxml2 XML parser support
+PROXY_DESC= libproxy support
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-USE_GNOME= gnomehack ltverhack
+USES= pathfix
+USE_GNOME= ltverhack
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared \
--with-libs=${LOCALBASE}:${PREFIX}
-.include "bsd.port.options.mk"
+.include <bsd.port.options.mk>
-.if defined(WITH_EXPAT) && defined(WITH_XML)
-BROKEN=expat and libxml is not compatible
-.endif
-
-# expat is default unless WITH_XML is choosen
-.if !defined(WITHOUT_EXPAT) && !defined(WITH_XML)
+.if ${PORT_OPTIONS:MEXPAT}
CONFIGURE_ARGS+=--with-expat
LIB_DEPENDS+= expat.6:${PORTSDIR}/textproc/expat2
.endif
-.if defined(WITH_XML)
+.if ${PORT_OPTIONS:MLIBXML}
CONFIGURE_ARGS+=--with-libxml2
LIB_DEPENDS+= xml2.5:${PORTSDIR}/textproc/libxml2
.endif
-.if !defined(WITHOUT_OPENSSL)
+.if ${PORT_OPTIONS:MOPENSSL}
CONFIGURE_ARGS+=--with-ssl
USE_OPENSSL= yes
.endif
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
-.if defined(WITHOUT_GSSAPI)
+.if ! ${PORT_OPTIONS:MGSSAPI}
CONFIGURE_ARGS+=--without-gssapi
.endif
-.if defined(WITH_PROXY)
+.if ${PORT_OPTIONS:MPROXY}
CONFIGURE_ARGS+=--with-libproxy
LIB_DEPENDS+= proxy.1:${PORTSDIR}/net/libproxy
.else
@@ -149,16 +142,10 @@ MLINKS= ne_add_request_header.3 ne_print_request_header.3 \
PLIST_SUB+= PORTVERSION=${PORTVERSION}
DOCSDIR= ${PREFIX}/share/doc/neon
-pre-everything::
-.if defined(WITH_EXPAT) && defined(WITH_XML)
- @${ECHO_CMD} "please choose between expat and libxml2 not both"
- @${FALSE}
-.endif
-
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/man/*.1 ${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/doc/man/*.3 ${MANPREFIX}/man/man3
-.ifndef NOPORTDOCS
+.if ${PORT_OPTIONS:MDOCS}
(cd ${WRKSRC} ; ${MAKE} install-html)
.endif
diff --git a/www/sitecopy/Makefile b/www/sitecopy/Makefile
index 1cdc2d6578c9..4d38379e23ab 100644
--- a/www/sitecopy/Makefile
+++ b/www/sitecopy/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: sitecopy
-# Date created: 15 January 1999
-# Whom: nik
-#
+# Created by: nik
# $FreeBSD$
-#
PORTNAME= sitecopy
PORTVERSION= 0.16.6
@@ -26,13 +22,15 @@ CONFIGURE_ARGS= --with-neon --with-libxml2
USE_GNOME= libxml2
USE_GMAKE= yes
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
LIBS+= -lintl
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
.ifndef WITHOUT_SSL