aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-02-07 04:59:29 +0800
committerpi <pi@FreeBSD.org>2016-02-07 04:59:29 +0800
commit3a15f5a02377f7b86602e10a5281c7f17cc6446b (patch)
tree8ef57923690aa9148ee01e559cb98f14b2175f24 /www
parent6fcc76c5c591934e123ac8571a0de1f4d5a151a9 (diff)
downloadfreebsd-ports-gnome-3a15f5a02377f7b86602e10a5281c7f17cc6446b.tar.gz
freebsd-ports-gnome-3a15f5a02377f7b86602e10a5281c7f17cc6446b.tar.zst
freebsd-ports-gnome-3a15f5a02377f7b86602e10a5281c7f17cc6446b.zip
New port: www/guacamole-client
guacamole-client is the superproject containing all Maven-based projects that make Guacamole, an HTML5 web application that provides access to your desktop using remote desktop protocols. guacamole-client is used to build the subprojects that make up Guacamole, and to provide a common central repository. Each project contained here is completely independent of guacamole-client and can be built separately, though the others may have to be built first. If all projects are built using guacamole-client, Maven will take care of the proper build order. WWW: https://github.com/glyptodon/guacamole-client PR: 202755 Submitted by: ultima1252@gmail.com
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/guacamole-client/Makefile73
-rw-r--r--www/guacamole-client/distinfo4
-rw-r--r--www/guacamole-client/files/guacamole.properties.sample10
-rw-r--r--www/guacamole-client/files/logback.xml.sample20
-rw-r--r--www/guacamole-client/files/pkg-message.in8
-rw-r--r--www/guacamole-client/files/user-mapping.xml.sample39
-rw-r--r--www/guacamole-client/pkg-descr12
-rw-r--r--www/guacamole-client/pkg-plist9
9 files changed, 176 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a9d51523b043..6d1fd3ac727b 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -246,6 +246,7 @@
SUBDIR += gstreamer1-plugins-neon
SUBDIR += gtkhtml3
SUBDIR += gtkhtml4
+ SUBDIR += guacamole-client
SUBDIR += guile-www
SUBDIR += gurlchecker
SUBDIR += h2o
diff --git a/www/guacamole-client/Makefile b/www/guacamole-client/Makefile
new file mode 100644
index 000000000000..c457fffdc9af
--- /dev/null
+++ b/www/guacamole-client/Makefile
@@ -0,0 +1,73 @@
+# Created by: Ultima <ultima1252@gmail.com>
+# $FreeBSD$
+
+PORTNAME= guacamole-client
+PORTVERSION= 0.9.9
+CATEGORIES= www java
+MASTER_SITES+= https://sourceforge.net/projects/distfiles/files/${PORTNAME}/:repo \
+ http://sourceforge.net/projects/distfiles/files/${PORTNAME}/:repo
+DISTNAME= ${PORTVERSION}
+DISTFILES= ${PORTVERSION}_GH${EXTRACT_SUFX} \
+ repository-${PORTVERSION}${EXTRACT_SUFX}:repo
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ultima1252@gmail.com
+COMMENT= HTML5 Clientless Remote Desktop
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${LOCALBASE}/share/java/maven33/bin/mvn:${PORTSDIR}/devel/maven33
+
+USE_GITHUB= yes
+GH_ACCOUNT= glyptodon
+GH_TAGNAME= ${PORTVERSION}
+
+MVN= mvn
+MVN_ARGS= package -Duser.home=${WRKDIR}
+USE_JAVA= yes
+JAVA_VERSION= 1.8+
+
+OPTIONS_DEFINE= MK_LINK SERVER TOMCAT
+OPTIONS_DEFAULT= MK_LINK SERVER TOMCAT
+OPTIONS_SUB= yes
+MK_LINK_DESC= Make sybolic links
+TOMCAT_RUN_DEPENDS= ${LOCALBASE}/apache-tomcat-8.0/bin/bootstrap.jar:${PORTSDIR}/www/tomcat8
+TOMCAT_DESC= Use Tomcat as your servlet
+
+SERVER_RUN_DEPENDS= guacd:${PORTSDIR}/net/guacamole-server
+SERVER_DESC= Include Guacamole Server
+
+GUACAMOLE_CONF= ${PREFIX}/etc/guacamole
+GUACAMOLE_DATA= ${PREFIX}/share/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+do-build:
+ cd ${WRKSRC} && ${MVN} ${MVN_ARGS}
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${GUACAMOLE_DATA}
+ @${MKDIR} ${STAGEDIR}${GUACAMOLE_CONF}
+
+ @${CP} ${WRKSRC}/guacamole/target/guacamole-${PORTVERSION}.war \
+ ${STAGEDIR}${GUACAMOLE_DATA}/guacamole.war
+ @${CP} ${WRKSRC}/extensions/guacamole-auth-jdbc/target/guacamole-auth-jdbc-${PORTVERSION}.tar.gz \
+ ${STAGEDIR}/${GUACAMOLE_DATA}/guacamole-auth-jdbc.tar.gz
+ @${CP} ${WRKSRC}/extensions/guacamole-auth-ldap/target/guacamole-auth-ldap-${PORTVERSION}.tar.gz \
+ ${STAGEDIR}/${GUACAMOLE_DATA}/guacamole-auth-ldap.tar.gz
+ @${CP} ${WRKSRC}/extensions/guacamole-auth-noauth/target/guacamole-auth-noauth-${PORTVERSION}.tar.gz \
+ ${STAGEDIR}/${GUACAMOLE_DATA}/guacamole-auth-noauth.tar.gz
+
+.if ${PORT_OPTIONS:MMK_LINK}
+ @${MKDIR} ${STAGEDIR}/root
+ @${MKDIR} ${STAGEDIR}${PREFIX}/apache-tomcat-8.0/webapps
+ @${LN} -s ${GUACAMOLE_CONF} ${STAGEDIR}/root/.guacamole
+ @${LN} -s ${GUACAMOLE_DATA}/guacamole.war \
+ ${STAGEDIR}${PREFIX}/apache-tomcat-8.0/webapps/
+.endif
+ @${CP} ${FILESDIR}/user-mapping.xml.sample ${STAGEDIR}${GUACAMOLE_CONF}/
+ @${CP} ${FILESDIR}/logback.xml.sample ${STAGEDIR}${GUACAMOLE_CONF}/
+ @${CP} ${FILESDIR}/guacamole.properties.sample ${STAGEDIR}${GUACAMOLE_CONF}/
+
+.include <bsd.port.post.mk>
diff --git a/www/guacamole-client/distinfo b/www/guacamole-client/distinfo
new file mode 100644
index 000000000000..30bea3dff8f1
--- /dev/null
+++ b/www/guacamole-client/distinfo
@@ -0,0 +1,4 @@
+SHA256 (guacamole-client/0.9.9_GH.tar.gz) = d6a1f824115c2dc87c9d611b4a6cbe2a489604a512227af5c79a832c2690783f
+SIZE (guacamole-client/0.9.9_GH.tar.gz) = 1698262
+SHA256 (guacamole-client/repository-0.9.9.tar.gz) = 79bc3064fac3add03842d96f21d3eb24677dffcea19f6a72cdeb200734ad71f6
+SIZE (guacamole-client/repository-0.9.9.tar.gz) = 42806341
diff --git a/www/guacamole-client/files/guacamole.properties.sample b/www/guacamole-client/files/guacamole.properties.sample
new file mode 100644
index 000000000000..2985c10f9fb3
--- /dev/null
+++ b/www/guacamole-client/files/guacamole.properties.sample
@@ -0,0 +1,10 @@
+###
+### guacamole.properties.sample
+###
+
+
+### The Host the Guacamole proxy daemon (guacd) is listening on.
+#
+guacd-host: localhost
+guacd-port: 4822
+#guacd-ssl: true ### default is false
diff --git a/www/guacamole-client/files/logback.xml.sample b/www/guacamole-client/files/logback.xml.sample
new file mode 100644
index 000000000000..a96d83e7765f
--- /dev/null
+++ b/www/guacamole-client/files/logback.xml.sample
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!-- Guacamole logs all messages to console by default. Servlet containers
+ like Tomcat will automattically redirect these messages to a log file,
+ catalina.out in the case of Tomcat. Valid levels= error, warn, info,
+ debug -->
+<configuration>
+
+ <!-- Appender for debugging -->
+ <appender name="GUAC-DEBUG" class="ch.qos.logback.core.ConsoleAppender">
+ <encoder>
+ <pattern>%d{HH:mm:ss.SSS} [%thread] %-5level %logger{36} - %msg%n</pattern>
+ </encoder>
+ </appender>
+
+ <!-- Log at DEBUG level -->
+ <root level="debug">
+ <appender-ref ref="GUAC-DEBUG"/>
+ </root>
+
+</configuration>
diff --git a/www/guacamole-client/files/pkg-message.in b/www/guacamole-client/files/pkg-message.in
new file mode 100644
index 000000000000..f40ab220c699
--- /dev/null
+++ b/www/guacamole-client/files/pkg-message.in
@@ -0,0 +1,8 @@
+### Guacamole-client requires authentecation to start.
+### cp %%PREFIX%%/etc/guacamole/user-mapping.xml.sample \
+### %%PREFIX%%/etc/guacamole/user-mapping.xml
+###
+### Once tomcat8 and guacd are running
+### http://localhost:8080/guacamole Only ssh is installed
+### by default. To add more protocols, rebuild guacamole-
+### server.
diff --git a/www/guacamole-client/files/user-mapping.xml.sample b/www/guacamole-client/files/user-mapping.xml.sample
new file mode 100644
index 000000000000..6c8120f3e9e2
--- /dev/null
+++ b/www/guacamole-client/files/user-mapping.xml.sample
@@ -0,0 +1,39 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!-- Guacamole's default authentication module is a simple xml file.
+ Each user is specified with a corresponding <authorized> tag. This
+ tag contains all authorized connections for that user each denoted
+ with a <connections> tag. Each <connection> tag contains a
+ protocol and set of protocol-specific parameters, specified with
+ the <protocol> and <param> tags respectively. For more information
+ visit http://guac-dev.org/doc/gug/configuring-guacamole.html -->
+
+
+<user-mapping>
+
+ <!-- Per-user authentication and config information -->
+ <authorize username="guacamole" password="guacamole">
+<!-- <connection name="vnc">
+ <protocol>vnc</protocol>
+ <param name="hostname">localhost</param>
+ <param name="port">5901</param>
+ </connection>
+ <connection name="rdp">
+ <protocol>rdp</protocol>
+ <param name="hostname">localhost</param>
+ <param name="port">3389</param>
+ </connection> -->
+ <connection name="ssh">
+ <protocol>ssh</protocol>
+ <param name="hostname">localhost</param>
+ <param name="port">22</param>
+ <param name="font-name">monospace</param>
+ </connection>
+ <connection name="delete me">
+ <protocol>ssh</protocol>
+ <param name="hostname">none</param>
+ <param name="port">22</param>
+ <param name="font-name">monospace</param>
+ </connection>
+ </authorize>
+
+</user-mapping>
diff --git a/www/guacamole-client/pkg-descr b/www/guacamole-client/pkg-descr
new file mode 100644
index 000000000000..093a107eafcc
--- /dev/null
+++ b/www/guacamole-client/pkg-descr
@@ -0,0 +1,12 @@
+guacamole-client is the superproject containing all Maven-based
+projects that make Guacamole, an HTML5 web application that provides
+access to your desktop using remote desktop protocols.
+
+guacamole-client is used to build the subprojects that make up
+Guacamole, and to provide a common central repository. Each project
+contained here is completely independent of guacamole-client and
+can be built separately, though the others may have to be built
+first. If all projects are built using guacamole-client, Maven will
+take care of the proper build order.
+
+WWW: https://github.com/glyptodon/guacamole-client
diff --git a/www/guacamole-client/pkg-plist b/www/guacamole-client/pkg-plist
new file mode 100644
index 000000000000..3dd445f09895
--- /dev/null
+++ b/www/guacamole-client/pkg-plist
@@ -0,0 +1,9 @@
+%%MK_LINK%%/root/.guacamole
+%%TOMCAT%%apache-tomcat-8.0/webapps/guacamole.war
+etc/guacamole/guacamole.properties.sample
+etc/guacamole/logback.xml.sample
+etc/guacamole/user-mapping.xml.sample
+%%DATADIR%%/guacamole-auth-jdbc.tar.gz
+%%DATADIR%%/guacamole-auth-ldap.tar.gz
+%%DATADIR%%/guacamole-auth-noauth.tar.gz
+%%DATADIR%%/guacamole.war