aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2017-09-27 17:05:04 +0800
committertz <tz@FreeBSD.org>2017-09-27 17:05:04 +0800
commit3b0dd0cbee6d6e5061788340a05ee538baa76047 (patch)
treec95b0166cf2d1ed88ec9d68c684a5d31a5c3e340 /www
parentc72338d98151fa77d0296b5fa648f985e8ead884 (diff)
downloadfreebsd-ports-gnome-3b0dd0cbee6d6e5061788340a05ee538baa76047.tar.gz
freebsd-ports-gnome-3b0dd0cbee6d6e5061788340a05ee538baa76047.tar.zst
freebsd-ports-gnome-3b0dd0cbee6d6e5061788340a05ee538baa76047.zip
www/gitlab: Fix options which do the opposite
Currently we have MYSQL and PG option. Since the last change the MYSQL option installs the PG configuration and vise versa. This is now fixed.
Diffstat (limited to 'www')
-rw-r--r--www/gitlab/Makefile9
-rw-r--r--www/gitlab/files/patch-Gemfile9
2 files changed, 14 insertions, 4 deletions
diff --git a/www/gitlab/Makefile b/www/gitlab/Makefile
index 319912f15e57..cebaed1bc0a8 100644
--- a/www/gitlab/Makefile
+++ b/www/gitlab/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gitlab
PORTVERSION= 9.3.11
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= www devel
@@ -205,15 +206,19 @@ GROUPS= git
NO_ARCH= yes
NO_BUILD= yes
+post-patch-MYSQL-on:
+ ${CP} ${WRKSRC}/config/database.yml.mysql ${WRKSRC}/config/database.yml.sample
+
post-patch-MYSQL-off:
${REINPLACE_CMD} -e "/gem 'mysql2'/d" ${WRKSRC}/Gemfile
${REINPLACE_CMD} -e "/gem 'peek-mysql2'/d" ${WRKSRC}/Gemfile
- ${CP} ${WRKSRC}/config/database.yml.mysql ${WRKSRC}/config/database.yml.sample
+
+post-patch-PGSQL-on:
+ ${CP} ${WRKSRC}/config/database.yml.postgresql ${WRKSRC}/config/database.yml.sample
post-patch-PGSQL-off:
${REINPLACE_CMD} -e "/gem 'pg'/d" ${WRKSRC}/Gemfile
${REINPLACE_CMD} -e "/gem 'peek-pg'/d" ${WRKSRC}/Gemfile
- ${CP} ${WRKSRC}/config/database.yml.postgresql ${WRKSRC}/config/database.yml.sample
do-install:
${FIND} ${WRKSRC} -name '*.orig' -delete
diff --git a/www/gitlab/files/patch-Gemfile b/www/gitlab/files/patch-Gemfile
index d33867ba1e7d..fe2ea339ae21 100644
--- a/www/gitlab/files/patch-Gemfile
+++ b/www/gitlab/files/patch-Gemfile
@@ -1,6 +1,6 @@
--- Gemfile.orig 2017-09-06 21:34:31 UTC
+++ Gemfile
-@@ -1,12 +1,12 @@
+@@ -1,48 +1,47 @@
source 'https://rubygems.org'
-gem 'rails', '4.2.8'
@@ -15,7 +15,12 @@
# Default values for AR models
gem 'default_value_for', '~> 3.0.0'
-@@ -17,32 +17,31 @@ gem 'pg', '~> 0.18.2', group: :postgres
+
+ # Supported DBs
+-gem 'mysql2', '~> 0.3.16', group: :mysql
+-gem 'pg', '~> 0.18.2', group: :postgres
++gem 'mysql2', '>= 0.3.16', group: :mysql
++gem 'pg', '>= 0.18.2', group: :postgres
gem 'rugged', '~> 0.25.1.1'