aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2009-07-21 21:53:14 +0800
committerosa <osa@FreeBSD.org>2009-07-21 21:53:14 +0800
commit3c9b0bd693647d3ec7ec2ad11d4bec8cab142dc1 (patch)
tree6c75457a9d5cd1dee8732b995968f6678d1d382b /www
parent0701112e8dd2b628902389f9708653c45d78509e (diff)
downloadfreebsd-ports-gnome-3c9b0bd693647d3ec7ec2ad11d4bec8cab142dc1.tar.gz
freebsd-ports-gnome-3c9b0bd693647d3ec7ec2ad11d4bec8cab142dc1.tar.zst
freebsd-ports-gnome-3c9b0bd693647d3ec7ec2ad11d4bec8cab142dc1.zip
Add support for http_geoip module (introduced in 0.8.6).
Do not bump PORTREVISION.
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index bf3161885b12..15d8d3fed692 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -25,6 +25,7 @@ OPTIONS= DEBUG "Enable nginx debugging" off \
HTTP_CACHE_MODULE "Enable http_cache module" on \
HTTP_DAV_MODULE "Enable http_webdav module" off \
HTTP_FLV_MODULE "Enable http_flv module" off \
+ HTTP_GEOIP_MODULE "Enable http_geoip module" off \
HTTP_GZIP_STATIC_MODULE "Enable http_gzip_static module" off \
HTTP_PERL_MODULE "Enable http_perl module" off \
HTTP_RANDOM_INDEX_MODULE "Enable http_random_index module" off \
@@ -157,6 +158,11 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx-fancyindex-${NGINX_FANCYINDEX_MODUL
CONFIGURE_ARGS+=--with-http_flv_module
.endif
+.if defined(WITH_HTTP_GEOIP_MODULE)
+CONFIGURE_ARGS+=--with-http_geoip_module
+LIB_DEPENDS+= GeoIP.5:${PORTSDIR}/net/GeoIP
+.endif
+
.if defined(WITH_HTTP_GZIP_STATIC_MODULE)
CONFIGURE_ARGS+=--with-http_gzip_static_module
.endif