aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authortmseck <tmseck@FreeBSD.org>2013-05-02 02:33:28 +0800
committertmseck <tmseck@FreeBSD.org>2013-05-02 02:33:28 +0800
commit3ca9b6d0da2415349b2e5f1eabf4e9b92d2ccbc7 (patch)
tree4cf5c811c5d88cac2f35146dfbac6bb43c3a70c8 /www
parente2c202ee8f7664989b8847f0e14d676737ffdcd8 (diff)
downloadfreebsd-ports-gnome-3ca9b6d0da2415349b2e5f1eabf4e9b92d2ccbc7.tar.gz
freebsd-ports-gnome-3ca9b6d0da2415349b2e5f1eabf4e9b92d2ccbc7.tar.zst
freebsd-ports-gnome-3ca9b6d0da2415349b2e5f1eabf4e9b92d2ccbc7.zip
- Update to 3.2.11
- Add a patch to correct the default "localhost" ACL in squid.conf for IPv4-only systems [1] PR: ports/176951 [1] Submitted by: Oleg Strizhak Approved by: crees (mentor)
Diffstat (limited to 'www')
-rw-r--r--www/squid32/Makefile6
-rw-r--r--www/squid32/distinfo4
-rw-r--r--www/squid32/files/extra-patch-src-cf.data.pre.noipv626
-rw-r--r--www/squid32/files/patch-helpers-basic_auth-LDAP-config.test12
-rw-r--r--www/squid32/files/patch-helpers-basic_auth-SASL-config.test12
-rw-r--r--www/squid32/files/patch-helpers-external_acl-LDAP_group-config.test12
-rw-r--r--www/squid32/files/squid.in9
7 files changed, 36 insertions, 45 deletions
diff --git a/www/squid32/Makefile b/www/squid32/Makefile
index 11d437148a68..ace27f825098 100644
--- a/www/squid32/Makefile
+++ b/www/squid32/Makefile
@@ -76,7 +76,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LATEST_LINK= squid32
-SQUID_STABLE_VER= 9
+SQUID_STABLE_VER= 11
CONFLICTS_INSTALL= squid-2.[0-9].* squid-3.[!2].* cacheboy-[0-9]* lusca-head-[0-9]*
GNU_CONFIGURE= yes
@@ -119,7 +119,6 @@ HTCP_DESC= Enable HTCP support
ICAP_DESC= Enable the ICAP client
ICMP_DESC= Enable ICMP pinging and network measurement
IDENT_DESC= Enable Ident lookups (RFC 931)
-IPV6_DESC= Enable IPv6 support
KQUEUE_DESC= Enable kqueue(2) support
LARGEFILE_DESC= Support large (>2GB) cache and log files
SNMP_DESC= Enable SNMP support
@@ -134,7 +133,7 @@ VIA_DB_DESC= Enable Forward/Via database
WCCPV2_DESC= Enable Web Cache Coordination Protocol v2
WCCP_DESC= Enable Web Cache Coordination Protocol
-OPTIONS_DEFAULT= AUTH_KERB AUTH_NIS FS_AUFS HTCP IDENT IPV6 KQUEUE \
+OPTIONS_DEFAULT= AUTH_KERB AUTH_NIS FS_AUFS HTCP IDENT KQUEUE \
SNMP WCCP WCCPV2
etc_files= squid/cachemgr.conf.default \
@@ -364,6 +363,7 @@ libexec+= url_fake_rewrite url_fake_rewrite.sh
.if empty(PORT_OPTIONS:MIPV6) || defined(WITHOUT_IPV6)
CONFIGURE_ARGS+= --disable-ipv6
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-src-cf.data.pre.noipv6
.endif
.if ${PORT_OPTIONS:MDELAY_POOLS}
CONFIGURE_ARGS+= --enable-delay-pools
diff --git a/www/squid32/distinfo b/www/squid32/distinfo
index 58b108be4d84..3f2dcdb5336b 100644
--- a/www/squid32/distinfo
+++ b/www/squid32/distinfo
@@ -1,2 +1,2 @@
-SHA256 (squid3.2/squid-3.2.9.tar.bz2) = 82d3d4cecfa4379b5197026198e34870a26977e6f6b175f5257241a3075767e6
-SIZE (squid3.2/squid-3.2.9.tar.bz2) = 2897511
+SHA256 (squid3.2/squid-3.2.11.tar.bz2) = 5d5a140e9b72753e6efe467cfa3c56d4db8ba6a8313beeca25145d34ddcadc49
+SIZE (squid3.2/squid-3.2.11.tar.bz2) = 2897354
diff --git a/www/squid32/files/extra-patch-src-cf.data.pre.noipv6 b/www/squid32/files/extra-patch-src-cf.data.pre.noipv6
new file mode 100644
index 000000000000..bb1a1ff1b817
--- /dev/null
+++ b/www/squid32/files/extra-patch-src-cf.data.pre.noipv6
@@ -0,0 +1,26 @@
+--- src/cf.data.pre.orig 2013-04-27 05:07:29.000000000 +0200
++++ src/cf.data.pre 2013-04-28 21:30:23.000000000 +0200
+@@ -733,8 +733,8 @@
+ LOC: Config.aclList
+ DEFAULT: all src all
+ DEFAULT: manager url_regex -i ^cache_object:// +i ^https?://[^/]+/squid-internal-mgr/
+-DEFAULT: localhost src 127.0.0.1/32 ::1
+-DEFAULT: to_localhost dst 127.0.0.0/8 0.0.0.0/32 ::1
++DEFAULT: localhost src 127.0.0.1/32
++DEFAULT: to_localhost dst 127.0.0.0/8 0.0.0.0/32
+ DEFAULT_DOC: ACLs all, manager, localhost, and to_localhost are predefined.
+ DOC_START
+ Defining an Access List
+--- src/cf.data.pre.orig 2013-04-27 05:07:29.000000000 +0200
++++ src/cf.data.pre 2013-04-28 21:30:23.000000000 +0200
+@@ -733,8 +733,8 @@
+ LOC: Config.aclList
+ DEFAULT: all src all
+ DEFAULT: manager url_regex -i ^cache_object:// +i ^https?://[^/]+/squid-internal-mgr/
+-DEFAULT: localhost src 127.0.0.1/32 ::1
+-DEFAULT: to_localhost dst 127.0.0.0/8 0.0.0.0/32 ::1
++DEFAULT: localhost src 127.0.0.1/32
++DEFAULT: to_localhost dst 127.0.0.0/8 0.0.0.0/32
+ DEFAULT_DOC: ACLs all, manager, localhost, and to_localhost are predefined.
+ DOC_START
+ Defining an Access List
diff --git a/www/squid32/files/patch-helpers-basic_auth-LDAP-config.test b/www/squid32/files/patch-helpers-basic_auth-LDAP-config.test
deleted file mode 100644
index 9961e5fa44cb..000000000000
--- a/www/squid32/files/patch-helpers-basic_auth-LDAP-config.test
+++ /dev/null
@@ -1,12 +0,0 @@
---- helpers/basic_auth/LDAP/config.test.orig 2012-10-20 14:39:49.000000000 +0200
-+++ helpers/basic_auth/LDAP/config.test 2012-10-21 20:49:49.000000000 +0200
-@@ -1,8 +1,2 @@
- #!/bin/sh
--if [ -f /usr/include/ldap.h ]; then
-- exit 0
--fi
--if [ -f /usr/include/winldap.h ]; then
-- exit 0
--fi
--exit 1
-+exit 0
diff --git a/www/squid32/files/patch-helpers-basic_auth-SASL-config.test b/www/squid32/files/patch-helpers-basic_auth-SASL-config.test
deleted file mode 100644
index 4952c279e82f..000000000000
--- a/www/squid32/files/patch-helpers-basic_auth-SASL-config.test
+++ /dev/null
@@ -1,12 +0,0 @@
---- helpers/basic_auth/SASL/config.test.orig 2012-10-20 14:39:49.000000000 +0200
-+++ helpers/basic_auth/SASL/config.test 2012-10-21 20:50:57.000000000 +0200
-@@ -1,8 +1,2 @@
- #!/bin/sh
--if [ -f /usr/include/sasl.h ]; then
-- exit 0
--fi
--if [ -f /usr/include/sasl/sasl.h ]; then
-- exit 0
--fi
--exit 1
-+exit 0
diff --git a/www/squid32/files/patch-helpers-external_acl-LDAP_group-config.test b/www/squid32/files/patch-helpers-external_acl-LDAP_group-config.test
deleted file mode 100644
index d7b6fe19f770..000000000000
--- a/www/squid32/files/patch-helpers-external_acl-LDAP_group-config.test
+++ /dev/null
@@ -1,12 +0,0 @@
---- helpers/external_acl/LDAP_group/config.test.orig 2012-10-20 14:39:49.000000000 +0200
-+++ helpers/external_acl/LDAP_group/config.test 2012-10-21 20:51:53.000000000 +0200
-@@ -1,8 +1,2 @@
- #!/bin/sh
--if [ -f /usr/include/ldap.h ]; then
-- exit 0
--fi
--if [ -f /usr/include/winldap.h ]; then
-- exit 0
--fi
--exit 1
-+exit 0
diff --git a/www/squid32/files/squid.in b/www/squid32/files/squid.in
index aff0418b0003..81695299345f 100644
--- a/www/squid32/files/squid.in
+++ b/www/squid32/files/squid.in
@@ -54,6 +54,11 @@ load_rc_config ${name}
: ${squid_user:=squid}
command=%%PREFIX%%/sbin/squid
+
+# Make sure that we invoke squid with "-f ${squid_conf}"; define this
+# variable early so reload_cmd and stop_precmd pick it up:
+
+command_args="-f ${squid_conf}"
extra_commands=reload
reload_cmd="${command} ${command_args} ${squid_flags} -k reconfigure"
start_precmd=squid_setfib
@@ -70,10 +75,6 @@ required_dirs=${squid_chdir}
required_files=${squid_conf}
-# Now make sure that we invoke squid with "-f ${squid_conf}":
-
-command_args="-f ${squid_conf}"
-
squid_setfib()
{
if command -v check_namevarlist > /dev/null 2>&1; then