aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2008-08-18 14:58:12 +0800
committeredwin <edwin@FreeBSD.org>2008-08-18 14:58:12 +0800
commit4af1711160c3a20ff6b7558c32e7ca8c7d426dad (patch)
tree8cbaecb5f864250ffcf50014f93cf5087f821649 /www
parent1e4eaf08f899202b13f67d436b681367a823380b (diff)
downloadfreebsd-ports-gnome-4af1711160c3a20ff6b7558c32e7ca8c7d426dad.tar.gz
freebsd-ports-gnome-4af1711160c3a20ff6b7558c32e7ca8c7d426dad.tar.zst
freebsd-ports-gnome-4af1711160c3a20ff6b7558c32e7ca8c7d426dad.zip
www/squidguard does not work unless its UID/GID are modified
www/squigguard installs blacklist files to /var/db/squidGuard and the UID:GID of the installed files is set to nobody:nogroup. The permission for the files is 0550 or 0660. On the other hand, www/squid specifies squid:squid as UID:GID. As a result, squidGuard cannot handle blacklist files so websites that should not be accessed cannot be filtered. PR: ports/120923 Submitted by: Jiro Kita <ktj@ktjdragon.com> Approved by: maintainer timeout
Diffstat (limited to 'www')
-rw-r--r--www/squidguard/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/www/squidguard/Makefile b/www/squidguard/Makefile
index 10acd5dc76bf..0ad8075bb001 100644
--- a/www/squidguard/Makefile
+++ b/www/squidguard/Makefile
@@ -26,8 +26,8 @@ CONFIGURE_ARGS= --with-db-inc=${BDB_INCLUDE_DIR} \
CFGINPUT= ${.CURDIR}/files/sgcfg.in
-SQUID_UID?= nobody
-SQUID_GID?= nogroup
+SQUID_UID?= squid
+SQUID_GID?= squid
DATADIR?= /var/db/${PORTNAME}
LOGDIR?= /var/log
@@ -36,10 +36,10 @@ PLIST:= ${WRKDIR}/PLIST
PLIST_SUB= DATADIR=${DATADIR}
pre-fetch:
- @if [ ${SQUID_UID} = "nobody" -o ${SQUID_GID} = "nogroup" ] ; then \
+ @if [ ${SQUID_UID} = "squid" -o ${SQUID_GID} = "squid" ] ; then \
${ECHO_MSG} "===> SQUID_UID is set to \"${SQUID_UID}\" and SQUID_GID is set to \"${SQUID_GID}\"." ; \
${ECHO_MSG} " To change this specify them with your make arguments, e.g." ; \
- ${ECHO_MSG} " make SQUID_UID=squid SQUID_GID=squid" ; \
+ ${ECHO_MSG} " make SQUID_UID=nobody SQUID_GID=nogroup" ; \
fi
post-patch:
@@ -134,7 +134,7 @@ post-install:
@${ECHO_MSG} " "
@${ECHO_MSG} "==================================================================="
@${ECHO_MSG} "= In order to activate ${PORTNAME} you have to edit squid.conf"
- @${ECHO_MSG} "= To the contain \"redirect_program ${PREFIX}/bin/${PORTNAME}\""
+ @${ECHO_MSG} "= To the contain \"url_rewrite_program ${PREFIX}/bin/${PORTNAME}\""
@${ECHO_MSG} "= and create a configuration file for ${PORTNAME}."
@${ECHO_MSG} "="
@${ECHO_MSG} "= To activate the changes do a ${PREFIX}/sbin/squid -k reconfigure"