aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
committertijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
commit55e5c34e31b90aa95311b10bd4a3072f2163ebfe (patch)
tree69c07cdc4812f0f8be0cc44c38513f540c058778 /www
parent0c15193d405451f0e1452ba981c8efb1df1447dd (diff)
downloadfreebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.gz
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.zst
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.zip
When linking a library libA with a library libB using libtool, if libB.la
exists, libtool will add all libraries libB.la refers to (dependency_libs field) to the linker command line and store them in the dependency_libs field of libA.la. So everything that subsequently links with libA will also link to these extra libraries. This causes too much overlinking. This commit modifies Mk/Uses/libtool.mk so it empties the dependency_libs field in .la libraries during staging. However, because .la libraries have very limited use when dependency_libs is empty it makes sense to completely remove them during staging. So with this commit USES=libtool is modified to remove .la libraries and a new form (USES=libtool:keepla) is introduced in case they need to be kept (dependency_libs is still emptied). PORTREVISION is bumped on all ports with USES=libtool that install .la libraries. Most ports are also changed to add :keepla because .la libraries have to be kept around as long as there are dependent ports with .la libraries that refer to them in their dependency_libs field. In most cases :keepla can be removed again as soon as all dependent ports that install .la libraries have some form of USES=libtool added to their Makefile. PR: ports/188759 Exp-run: bdrewery Approved by: portmgr (bdrewery)
Diffstat (limited to 'www')
-rw-r--r--www/flickcurl/Makefile4
-rw-r--r--www/gstreamer1-plugins-neon/Makefile2
-rw-r--r--www/libecap/Makefile4
-rw-r--r--www/swfdec-plugin/Makefile4
4 files changed, 7 insertions, 7 deletions
diff --git a/www/flickcurl/Makefile b/www/flickcurl/Makefile
index 651a2e0b4bd0..331f4013e680 100644
--- a/www/flickcurl/Makefile
+++ b/www/flickcurl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= flickcurl
PORTVERSION= 1.25
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= http://download.dajobe.org/flickcurl/
@@ -23,7 +23,7 @@ RAPTOR_DESC= Use Raptor to serialize to triples
OFFLINE_DESC= Offline use of captured XML web service responses
CAPTURE_DESC= Capturing web service responses
-USES= libtool pathfix pkgconfig
+USES= libtool:keepla pathfix pkgconfig
USE_GNOME= libxml2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
diff --git a/www/gstreamer1-plugins-neon/Makefile b/www/gstreamer1-plugins-neon/Makefile
index dd3f19b0f5e0..b73438287705 100644
--- a/www/gstreamer1-plugins-neon/Makefile
+++ b/www/gstreamer1-plugins-neon/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= www
COMMENT= Gstreamer neon http source plugin
diff --git a/www/libecap/Makefile b/www/libecap/Makefile
index 13636cd132ac..b78f113885ca 100644
--- a/www/libecap/Makefile
+++ b/www/libecap/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libecap
PORTVERSION= 0.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www security
MASTER_SITES= http://www.measurement-factory.com/tmp/ecap/
@@ -14,7 +14,7 @@ LICENSE= BSD2CLAUSE
OPTIONS_DEFINE= DOCS
-USES= libtool
+USES= libtool:keepla
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/www/swfdec-plugin/Makefile b/www/swfdec-plugin/Makefile
index 1d867c9ffb07..8effadeba294 100644
--- a/www/swfdec-plugin/Makefile
+++ b/www/swfdec-plugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= swfdec-plugin
PORTVERSION= 0.8.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www
MASTER_SITES= http://swfdec.freedesktop.org/download/swfdec-mozilla/0.8/
DISTNAME= swfdec-mozilla-${PORTVERSION}
@@ -13,7 +13,7 @@ COMMENT= Flash rendering plugin
LIB_DEPENDS= libswfdec-0.8.so:${PORTSDIR}/graphics/swfdec
-USES= pkgconfig webplugin:gecko libtool
+USES= libtool:keepla pkgconfig webplugin:gecko
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip