aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-10-10 19:52:45 +0800
committerclsung <clsung@FreeBSD.org>2006-10-10 19:52:45 +0800
commit57e621fe1dffcb4291017addceafd07cfbd21854 (patch)
tree095348607cecefb61a60ce43f70971cbe54e150f /www
parentd77474c3b2e006e6dc71b6786a6ef762fe82c87f (diff)
downloadfreebsd-ports-gnome-57e621fe1dffcb4291017addceafd07cfbd21854.tar.gz
freebsd-ports-gnome-57e621fe1dffcb4291017addceafd07cfbd21854.tar.zst
freebsd-ports-gnome-57e621fe1dffcb4291017addceafd07cfbd21854.zip
Add flat-frog 2.2.13, a templating engine working in php.
PR: ports/104242 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/flat-frog/Makefile33
-rw-r--r--www/flat-frog/distinfo3
-rw-r--r--www/flat-frog/pkg-descr5
-rw-r--r--www/flat-frog/pkg-plist58
5 files changed, 100 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 6e260b4e87ad..0c2b8d402b3a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -138,6 +138,7 @@
SUBDIR += firefox-remote
SUBDIR += flashplugin
SUBDIR += flashplugin-mozilla
+ SUBDIR += flat-frog
SUBDIR += flock
SUBDIR += flood
SUBDIR += fluxcms
diff --git a/www/flat-frog/Makefile b/www/flat-frog/Makefile
new file mode 100644
index 000000000000..cda5da3881f2
--- /dev/null
+++ b/www/flat-frog/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: flat-frog
+# Date created: 2006-10-10
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flat-frog
+PORTVERSION= 2.2.13
+CATEGORIES= www
+MASTER_SITES= SOURCEFORGE
+MASTER_SITE_SUBDIR= flatfrog
+
+MAINTAINER= gslin@gslin.org
+COMMENT= A templating engine working in php
+
+NO_BUILD= yes
+USE_PHP= yes
+USE_ZIP= yes
+
+do-install:
+ ${MKDIR} ${DATADIR} ${DATADIR}/plugins
+ ${INSTALL_DATA} ${WRKSRC}/src/class.* ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/src/plugins/* ${DATADIR}/plugins
+ ${MKDIR} ${EXAMPLESDIR} ${EXAMPLESDIR}/templates
+ ${INSTALL_DATA} ${WRKSRC}/demo/test.* ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/demo/templates/* ${EXAMPLESDIR}/templates
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/flat-frog/distinfo b/www/flat-frog/distinfo
new file mode 100644
index 000000000000..6307edb82161
--- /dev/null
+++ b/www/flat-frog/distinfo
@@ -0,0 +1,3 @@
+MD5 (flat-frog-2.2.13.zip) = 06046ea568c8c4e4b8b6083bc6551c7e
+SHA256 (flat-frog-2.2.13.zip) = 934e04254767904f549f766a465657afb55850da4cfc538bd13977734f1d2ce3
+SIZE (flat-frog-2.2.13.zip) = 79441
diff --git a/www/flat-frog/pkg-descr b/www/flat-frog/pkg-descr
new file mode 100644
index 000000000000..e02acf5de8c3
--- /dev/null
+++ b/www/flat-frog/pkg-descr
@@ -0,0 +1,5 @@
+Flat Frog is a templating engine working in php allowing the most
+usefull functions : loops, test, switch, inclusion of files and plugin
+capabilities. It has compiling and caching capabilites.
+
+WWW: http://sourceforge.net/projects/flatfrog
diff --git a/www/flat-frog/pkg-plist b/www/flat-frog/pkg-plist
new file mode 100644
index 000000000000..98567c27a64f
--- /dev/null
+++ b/www/flat-frog/pkg-plist
@@ -0,0 +1,58 @@
+@comment $FreeBSD$
+%%DATADIR%%/class.compiler.php
+%%DATADIR%%/class.config.php
+%%DATADIR%%/class.template.php
+%%DATADIR%%/plugins/block.capture.php
+%%DATADIR%%/plugins/block.strip.php
+%%DATADIR%%/plugins/function.counter.php
+%%DATADIR%%/plugins/function.cycle.php
+%%DATADIR%%/plugins/function.html_checkbox.php
+%%DATADIR%%/plugins/function.html_hidden.php
+%%DATADIR%%/plugins/function.html_image.php
+%%DATADIR%%/plugins/function.html_input.php
+%%DATADIR%%/plugins/function.html_options.php
+%%DATADIR%%/plugins/function.html_radio.php
+%%DATADIR%%/plugins/function.html_textbox.php
+%%DATADIR%%/plugins/function.urlencode.php
+%%DATADIR%%/plugins/modifier.bbcode2html.php
+%%DATADIR%%/plugins/modifier.capitalize.php
+%%DATADIR%%/plugins/modifier.count.php
+%%DATADIR%%/plugins/modifier.date.php
+%%DATADIR%%/plugins/modifier.default.php
+%%DATADIR%%/plugins/modifier.lower.php
+%%DATADIR%%/plugins/modifier.nl2br.php
+%%DATADIR%%/plugins/modifier.number_format.php
+%%DATADIR%%/plugins/modifier.replace.php
+%%DATADIR%%/plugins/modifier.string_format.php
+%%DATADIR%%/plugins/modifier.strip.php
+%%DATADIR%%/plugins/modifier.strip_tags.php
+%%DATADIR%%/plugins/modifier.truncate.php
+%%DATADIR%%/plugins/modifier.upper.php
+%%DATADIR%%/plugins/modifier.urlencode.php
+%%DATADIR%%/plugins/modifier.wordwrap.php
+%%EXAMPLESDIR%%/templates/footer.tpl
+%%EXAMPLESDIR%%/templates/header.tpl
+%%EXAMPLESDIR%%/templates/index.tpl
+%%EXAMPLESDIR%%/templates/test.conf
+%%EXAMPLESDIR%%/test.php
+%%PORTDOCS%%%%DOCSDIR%%/appendix.caching.html
+%%PORTDOCS%%%%DOCSDIR%%/appendix.groups.html
+%%PORTDOCS%%%%DOCSDIR%%/favicon.ico
+%%PORTDOCS%%%%DOCSDIR%%/flat-frog-doc.css
+%%PORTDOCS%%%%DOCSDIR%%/flat-frog-logo.gif
+%%PORTDOCS%%%%DOCSDIR%%/getting.started.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/language.config.html
+%%PORTDOCS%%%%DOCSDIR%%/language.functions.custom.html
+%%PORTDOCS%%%%DOCSDIR%%/language.functions.html
+%%PORTDOCS%%%%DOCSDIR%%/language.modifiers.combining.html
+%%PORTDOCS%%%%DOCSDIR%%/language.modifiers.html
+%%PORTDOCS%%%%DOCSDIR%%/language.variables.html
+%%PORTDOCS%%%%DOCSDIR%%/programming.methods.html
+%%PORTDOCS%%%%DOCSDIR%%/programming.variables.html
+%%PORTDOCS%%%%DOCSDIR%%/what.is.html
+@dirrm %%EXAMPLESDIR%%/templates
+@dirrm %%EXAMPLESDIR%%
+@dirrm %%DATADIR%%/plugins
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%