aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2013-11-26 22:57:45 +0800
committermat <mat@FreeBSD.org>2013-11-26 22:57:45 +0800
commit5be041401389b32fc002c4a08609da592a579204 (patch)
tree3c638ab313bf583ef06173e70753ea915df49aac /www
parent5f06070a98c7b9c606bcdcef64e0c4e2b08842e6 (diff)
downloadfreebsd-ports-gnome-5be041401389b32fc002c4a08609da592a579204.tar.gz
freebsd-ports-gnome-5be041401389b32fc002c4a08609da592a579204.tar.zst
freebsd-ports-gnome-5be041401389b32fc002c4a08609da592a579204.zip
Fix build with ECAP.
USES can't be fiddled with after including bsd.port.pre.mk. maintainer timeout PR: ports/183894 Submitted by: mat
Diffstat (limited to 'www')
-rw-r--r--www/squid32/Makefile3
-rw-r--r--www/squid33/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/www/squid32/Makefile b/www/squid32/Makefile
index db758c437a99..1a85717561ab 100644
--- a/www/squid32/Makefile
+++ b/www/squid32/Makefile
@@ -101,6 +101,8 @@ WCCP_DESC= Enable Web Cache Coordination Protocol
OPTIONS_DEFAULT= AUTH_KERB AUTH_NIS FS_AUFS HTCP IDENT KQUEUE \
SNMP WCCP WCCPV2
+ECAP_USES= pkgconfig:build
+
etc_files= squid/cachemgr.conf.default \
squid/errorpage.css.default \
squid/mib.txt \
@@ -423,7 +425,6 @@ CONFIGURE_ARGS+= --enable-ecap
LIB_DEPENDS+= ecap:${PORTSDIR}/www/libecap
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USES+= pkgconfig:build
.else
CONFIGURE_ARGS+= --disable-ecap
.endif
diff --git a/www/squid33/Makefile b/www/squid33/Makefile
index 846b2270042f..1b58ca3aeeef 100644
--- a/www/squid33/Makefile
+++ b/www/squid33/Makefile
@@ -107,6 +107,8 @@ WCCP_DESC= Enable Web Cache Coordination Protocol
OPTIONS_DEFAULT= AUTH_KERB AUTH_NIS FS_AUFS HTCP IDENT KQUEUE \
SNMP WCCP WCCPV2
+ECAP_USES= pkgconfig:build
+
etc_files= squid/cachemgr.conf.default \
squid/errorpage.css.default \
squid/mib.txt \
@@ -433,7 +435,6 @@ CONFIGURE_ARGS+= --enable-ecap
LIB_DEPENDS+= ecap:${PORTSDIR}/www/libecap
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USES+= pkgconfig:build
.else
CONFIGURE_ARGS+= --disable-ecap
.endif