aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2015-08-30 05:07:07 +0800
committermatthew <matthew@FreeBSD.org>2015-08-30 05:07:07 +0800
commit5c37cfa949f7d32abffe3837ba0a2ed878799d16 (patch)
tree990a8badfe4e651b5cc499e5e392665c19c539fa /www
parentd7d61b8ba7c0715d366a1d7505a73804cf80c62b (diff)
downloadfreebsd-ports-gnome-5c37cfa949f7d32abffe3837ba0a2ed878799d16.tar.gz
freebsd-ports-gnome-5c37cfa949f7d32abffe3837ba0a2ed878799d16.tar.zst
freebsd-ports-gnome-5c37cfa949f7d32abffe3837ba0a2ed878799d16.zip
Prepare for perl-5.22
- Add dependency on www/p5-CGI conditional on perl version. CGI is no-longer a core module with 5.22. - Make the default web server interface Apache + FCGI rather than Apache + mod_perl. Current versions of mod_perl aren't compatible with perl-5.22
Diffstat (limited to 'www')
-rw-r--r--www/rt42/Makefile11
-rw-r--r--www/rt42/Makefile.cpan13
2 files changed, 11 insertions, 13 deletions
diff --git a/www/rt42/Makefile b/www/rt42/Makefile
index e6ed74b0d0f7..92105cc4c008 100644
--- a/www/rt42/Makefile
+++ b/www/rt42/Makefile
@@ -2,6 +2,7 @@
PORTNAME= rt
DISTVERSION= 4.2.12
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://download.bestpractical.com/pub/rt/release/
PKGNAMESUFFIX= 42
@@ -37,7 +38,7 @@ OPTIONS_SINGLE_DB= MYSQL ORACLE PGSQL SQLITE
OPTIONS_RADIO= WEB
OPTIONS_RADIO_WEB= AP_MODFASTCGI AP_MODPERL LIGHTTPD SPAWN_FCGI
-OPTIONS_DEFAULT= AP_MODPERL GD GPG MYSQL
+OPTIONS_DEFAULT= AP_MODFASTCGI GD GPG MYSQL
USERS?= www
GROUPS?= rt www
@@ -201,4 +202,10 @@ post-install:
(cd ${WRKSRC}/etc && \
${COPYTREE_SHARE} upgrade ${STAGEDIR}${DOCSDIR} "! -name *\.in")
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} >= 502200
+CORE_DEPS+= p5-CGI>4.0:${PORTSDIR}/www/p5-CGI
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/rt42/Makefile.cpan b/www/rt42/Makefile.cpan
index 17543385bfda..e1678539d16a 100644
--- a/www/rt42/Makefile.cpan
+++ b/www/rt42/Makefile.cpan
@@ -1,8 +1,8 @@
###############################################################################
### --- Core_DEPS ---
### Apache::Session 1.53
-### CGI 3.38 perl std
-### CGI::Cookie 1.20 perl std
+### CGI 3.38 perl std (perl<5.22)
+### CGI::Cookie 1.20 perl std (perl<5.22)
### CGI::Emulate::PSGI
### CGI::PSGI 0.12
### CSS::Squish 0.06
@@ -133,15 +133,6 @@ CORE_DEPS= p5-Apache-Session>=1.53:${PORTSDIR}/www/p5-Apache-Session \
p5-UNIVERSAL-require>0:${PORTSDIR}/devel/p5-UNIVERSAL-require \
p5-XML-RSS>=1.05:${PORTSDIR}/textproc/p5-XML-RSS
-### Wants CGI => 4.00 for perl 5.20, meaning effectively www/p5-CGI.pm
-### rather than the version bundled with perl (as CGI is being
-### deprecated as a core perl module). Except that a) www/p5-CGI.pm
-### is still at version 3.63 and b) ${PERL_LEVEL} doesn't seem to be in
-### scope at this point either.
-#.if ${PERL_LEVEL} >= 502000
-#CORE_DEPS+= p5-CGI.pm>=4.00:${PORTSDIR}/www/p5-CGI.pm
-#.endif
-
### --- MAILGATE ---
### Crypt::SSLeay
### Getopt::Long perl std