aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-05-07 12:59:28 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-05-07 12:59:28 +0800
commit5db8225796b6b82a14f415e0484309c2281f7a0b (patch)
tree0cddb52b23b66b0b29c0363d7d20e2a9cacf012d /www
parentf780c8d9fb70d6841308e3bb362d78318c8d6ad8 (diff)
downloadfreebsd-ports-gnome-5db8225796b6b82a14f415e0484309c2281f7a0b.tar.gz
freebsd-ports-gnome-5db8225796b6b82a14f415e0484309c2281f7a0b.tar.zst
freebsd-ports-gnome-5db8225796b6b82a14f415e0484309c2281f7a0b.zip
- fix ldap support
--with-ldap switches on LDAP library linking in apr-util --enable-ldap option switches on the LDAP caching module --enable-auth-ldap option switches on the LDAP authentication module also apply a custom patch to fix the linking - add a missing quote to OPTIONS desc - ldap is not in the default package, so no PORTREVISION bump PR: ports/128079 Reported by: koitsu, skreuzer With Hat: apache@
Diffstat (limited to 'www')
-rw-r--r--www/apache20/Makefile8
-rw-r--r--www/apache20/files/patch-modules__experimental__config.m411
2 files changed, 15 insertions, 4 deletions
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index 15f7a687662b..98815f463cdf 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -45,7 +45,7 @@ OPTIONS= \
DEBUG "Enable debugging" Off \
EXCEPTION_HOOK "Enable Exception Hook" On \
LDAP "Enable LDAP Support" Off \
- THREADS "Enable threads in apr Off
+ THREADS "Enable threads in apr" Off
.if defined(WITH_KQUEUE_SUPPORT)
EXTRA_PATCHES+= ${FILESDIR}/exp-apr-kqueue.patch
@@ -136,9 +136,9 @@ APACHEDIR= ${MASTERDIR}
.if defined (WITH_LDAP) || defined (WITH_LDAP_MODULES)
USE_OPENLDAP= YES
-CONFIGURE_ARGS+= --with-ldap \
- --with-ldap-lib="${LOCALBASE}/lib" \
- --with-ldap-include="${LOCALBASE}/include"
+CONFIGURE_ARGS+= --enable-ldap=shared --enable-auth-ldap --with-ldap \
+ --with-ldap-lib="${LOCALBASE}/lib" \
+ --with-ldap-include="${LOCALBASE}/include"
.endif
.include "${APACHEDIR}/Makefile.doc"
diff --git a/www/apache20/files/patch-modules__experimental__config.m4 b/www/apache20/files/patch-modules__experimental__config.m4
new file mode 100644
index 000000000000..20e2c435d597
--- /dev/null
+++ b/www/apache20/files/patch-modules__experimental__config.m4
@@ -0,0 +1,11 @@
+--- modules/experimental/config.m4.orig 2010-05-07 00:41:44.796911069 -0400
++++ modules/experimental/config.m4 2010-05-07 00:41:27.000000000 -0400
+@@ -33,7 +33,7 @@
+ ldap_objects="util_ldap.lo util_ldap_cache.lo util_ldap_cache_mgr.lo"
+ APACHE_MODULE(ldap, LDAP caching and connection pooling services, $ldap_objects, , no)
+
+-auth_ldap_objects="mod_auth_ldap.lo"
++auth_ldap_objects="mod_auth_ldap.lo $ldap_objects"
+ APACHE_MODULE(auth_ldap, LDAP based authentication, $auth_ldap_objects, , no)
+
+ APACHE_MODPATH_FINISH