aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2018-03-02 19:53:35 +0800
committerkoobs <koobs@FreeBSD.org>2018-03-02 19:53:35 +0800
commit5f5e57a271da0f107d24d58147099cab27685b6c (patch)
treeb49e9bd623a4722df494a2257980fa91e4f93d94 /www
parentadd4de70a68172a72eae95f3a1ad6132e0966402 (diff)
downloadfreebsd-ports-gnome-5f5e57a271da0f107d24d58147099cab27685b6c.tar.gz
freebsd-ports-gnome-5f5e57a271da0f107d24d58147099cab27685b6c.tar.zst
freebsd-ports-gnome-5f5e57a271da0f107d24d58147099cab27685b6c.zip
www/py-requests: Update to 2.18.4
While I'm here: Add note about test suite issue. There's no clear & quick way to resolve this in the short term without further investigation/yak shaving. Changelog: https://github.com/requests/requests/blob/v2.18.4/HISTORY.rst PR: 226078 Submitted by: yuri
Diffstat (limited to 'www')
-rw-r--r--www/py-requests/Makefile13
-rw-r--r--www/py-requests/distinfo6
-rw-r--r--www/py-requests/files/patch-setup.py18
3 files changed, 12 insertions, 25 deletions
diff --git a/www/py-requests/Makefile b/www/py-requests/Makefile
index 677952c31085..ed4dfc10f444 100644
--- a/www/py-requests/Makefile
+++ b/www/py-requests/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= requests
-PORTVERSION= 2.18.1
-PORTREVISION= 1
+PORTVERSION= 2.18.4
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,10 +17,9 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}chardet>=3.0.2:textproc/py-chardet@${FLAVOR}
${PYTHON_PKGNAMEPREFIX}idna>=2.5:dns/py-idna@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}urllib3>=1.21.1:net/py-urllib3@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}certifi>=2017.4.17:security/py-certifi@${FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=2.8.1:devel/py-pytest@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-xdist>0:devel/py-pytest-xdist@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}execnet>=1.1:sysutils/py-execnet@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=2.8.0:devel/py-pytest@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-mock>0:devel/py-pytest-mock@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-xdist>0:devel/py-pytest-xdist@${FLAVOR}
# Actually 2.6-2.7,3.3+
USES= python
@@ -31,6 +29,9 @@ CONFLICTS_INSTALL= py*-requests1-*
NO_ARCH= yes
+# Automated tests failinng due to httpbin issue
+# https://github.com/kennethreitz/httpbin/issues/403
+
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
diff --git a/www/py-requests/distinfo b/www/py-requests/distinfo
index 6fdd215d7a2e..31d868f0849e 100644
--- a/www/py-requests/distinfo
+++ b/www/py-requests/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1500092996
-SHA256 (requests-2.18.1.tar.gz) = c6f3bdf4a4323ac7b45d01e04a6f6c20e32a052cd04de81e05103abc049ad9b9
-SIZE (requests-2.18.1.tar.gz) = 124229
+TIMESTAMP = 1519435351
+SHA256 (requests-2.18.4.tar.gz) = 9c443e7324ba5b85070c4a818ade28bfabedf16ea10206da1132edaa6dda237e
+SIZE (requests-2.18.4.tar.gz) = 126224
diff --git a/www/py-requests/files/patch-setup.py b/www/py-requests/files/patch-setup.py
index e67cbe55b224..70f8f043af0b 100644
--- a/www/py-requests/files/patch-setup.py
+++ b/www/py-requests/files/patch-setup.py
@@ -1,22 +1,8 @@
-From 8d1228cd1943bfe89ffaae32e15b2feb3f8479f5 Mon Sep 17 00:00:00 2001
-From: Cory Benfield <lukasaoz@gmail.com>
-Date: Thu, 20 Jul 2017 10:08:50 +0100
-Subject: [PATCH] Allow urllib3 1.22
-
----
- setup.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
# pytest-cov and its dependencies are not compulsory
---- setup.py.orig 2017-06-14 17:44:15 UTC
+--- setup.py.orig 2018-02-24 01:49:05 UTC
+++ setup.py
-@@ -44,11 +44,11 @@ packages = ['requests']
- requires = [
- 'chardet>=3.0.2,<3.1.0',
- 'idna>=2.5,<2.6',
-- 'urllib3>=1.21.1,<1.22',
-+ 'urllib3>=1.21.1,<1.23',
+@@ -48,7 +48,7 @@ requires = [
'certifi>=2017.4.17'
]