aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-06-28 10:29:01 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-06-28 10:29:01 +0800
commit5f87848748a696fbc5661b370e8ebbc934d805d8 (patch)
tree90e23e3e488da46329414f69f8933680eef87e8b /www
parenta2a60421337316312491ddab1d4df26ae9351d21 (diff)
downloadfreebsd-ports-gnome-5f87848748a696fbc5661b370e8ebbc934d805d8.tar.gz
freebsd-ports-gnome-5f87848748a696fbc5661b370e8ebbc934d805d8.tar.zst
freebsd-ports-gnome-5f87848748a696fbc5661b370e8ebbc934d805d8.zip
- Add py-django-reversion 1.6.1
django-reversion is an extension to the Django web framework that provides comprehensive version control facilities: - Roll back to any point in a model's history - an unlimited undo facility! - Recover deleted models - never lose data again! - Admin integration for maximum usability. - Group related changes into revisions that can be rolled back in a single transaction. - Automatically save a new version whenever your model changes using Django's flexible signalling framework. - Automate your revision management with easy-to-use middleware. django-reversion can be easily added to your existing Django project with an absolute minimum of code changes. WWW: http://pypi.python.org/pypi/django-reversion/ PR: ports/169269 Submitted by: Matthew X. Economou <xenophon+fbsdports@irtnog.org>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-reversion/Makefile27
-rw-r--r--www/py-django-reversion/distinfo2
-rw-r--r--www/py-django-reversion/pkg-descr17
-rw-r--r--www/py-django-reversion/pkg-message9
-rw-r--r--www/py-django-reversion/pkg-plist109
6 files changed, 165 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 4af88b1c2c2e..70f0c6d08571 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1471,6 +1471,7 @@
SUBDIR += py-django-piston
SUBDIR += py-django-profiles
SUBDIR += py-django-registration
+ SUBDIR += py-django-reversion
SUBDIR += py-django-sekizai
SUBDIR += py-django-signals-ahoy
SUBDIR += py-django-storages
diff --git a/www/py-django-reversion/Makefile b/www/py-django-reversion/Makefile
new file mode 100644
index 000000000000..d1483feeac1f
--- /dev/null
+++ b/www/py-django-reversion/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: py-django-reversion
+# Date created: 19 Jun 2012
+# Whom: Matthew X. Economou <xenophon+fbsdports@irtnog.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= django-reversion
+PORTVERSION= 1.6.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= xenophon+fbsdports@irtnog.org
+COMMENT= Provides comprehensive version control facilities to Django apps
+
+LICENSE= BSD
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django>=0:${PORTSDIR}/www/py-django
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/py-django-reversion/distinfo b/www/py-django-reversion/distinfo
new file mode 100644
index 000000000000..c646e29cac88
--- /dev/null
+++ b/www/py-django-reversion/distinfo
@@ -0,0 +1,2 @@
+SHA256 (django-reversion-1.6.1.tar.gz) = f0a2db55336ab7a584c891b15d009656f4ca15559c03447a2bffd6b925fadabe
+SIZE (django-reversion-1.6.1.tar.gz) = 44034
diff --git a/www/py-django-reversion/pkg-descr b/www/py-django-reversion/pkg-descr
new file mode 100644
index 000000000000..3c32a910f74a
--- /dev/null
+++ b/www/py-django-reversion/pkg-descr
@@ -0,0 +1,17 @@
+django-reversion is an extension to the Django web framework that
+provides comprehensive version control facilities:
+
+- Roll back to any point in a model's history - an unlimited undo
+ facility!
+- Recover deleted models - never lose data again!
+- Admin integration for maximum usability.
+- Group related changes into revisions that can be rolled back in a
+ single transaction.
+- Automatically save a new version whenever your model changes using
+ Django's flexible signalling framework.
+- Automate your revision management with easy-to-use middleware.
+
+django-reversion can be easily added to your existing Django project
+with an absolute minimum of code changes.
+
+WWW: http://pypi.python.org/pypi/django-reversion/
diff --git a/www/py-django-reversion/pkg-message b/www/py-django-reversion/pkg-message
new file mode 100644
index 000000000000..36f6adb23d03
--- /dev/null
+++ b/www/py-django-reversion/pkg-message
@@ -0,0 +1,9 @@
+**********************************************************************
+
+To add django-reversion to a django project:
+
+1. Add 'reversion' to your INSTALLED_APPS setting.
+
+2. Run the command "manage.py syncdb".
+
+**********************************************************************
diff --git a/www/py-django-reversion/pkg-plist b/www/py-django-reversion/pkg-plist
new file mode 100644
index 000000000000..e38180a0a3f9
--- /dev/null
+++ b/www/py-django-reversion/pkg-plist
@@ -0,0 +1,109 @@
+%%PYTHON_SITELIBDIR%%/reversion/__init__.py
+%%PYTHON_SITELIBDIR%%/reversion/__init__.pyc
+%%PYTHON_SITELIBDIR%%/reversion/__init__.pyo
+%%PYTHON_SITELIBDIR%%/reversion/admin.py
+%%PYTHON_SITELIBDIR%%/reversion/admin.pyc
+%%PYTHON_SITELIBDIR%%/reversion/admin.pyo
+%%PYTHON_SITELIBDIR%%/reversion/helpers.py
+%%PYTHON_SITELIBDIR%%/reversion/helpers.pyc
+%%PYTHON_SITELIBDIR%%/reversion/helpers.pyo
+%%PYTHON_SITELIBDIR%%/reversion/locale/cs/LC_MESSAGES/django.mo
+%%PYTHON_SITELIBDIR%%/reversion/locale/cs/LC_MESSAGES/django.po
+%%PYTHON_SITELIBDIR%%/reversion/locale/de/LC_MESSAGES/django.mo
+%%PYTHON_SITELIBDIR%%/reversion/locale/de/LC_MESSAGES/django.po
+%%PYTHON_SITELIBDIR%%/reversion/locale/fr/LC_MESSAGES/django.mo
+%%PYTHON_SITELIBDIR%%/reversion/locale/fr/LC_MESSAGES/django.po
+%%PYTHON_SITELIBDIR%%/reversion/locale/he/LC_MESSAGES/django.mo
+%%PYTHON_SITELIBDIR%%/reversion/locale/he/LC_MESSAGES/django.po
+%%PYTHON_SITELIBDIR%%/reversion/locale/it/LC_MESSAGES/django.mo
+%%PYTHON_SITELIBDIR%%/reversion/locale/it/LC_MESSAGES/django.po
+%%PYTHON_SITELIBDIR%%/reversion/locale/nb/LC_MESSAGES/django.mo
+%%PYTHON_SITELIBDIR%%/reversion/locale/nb/LC_MESSAGES/django.po
+%%PYTHON_SITELIBDIR%%/reversion/locale/pl/LC_MESSAGES/django.mo
+%%PYTHON_SITELIBDIR%%/reversion/locale/pl/LC_MESSAGES/django.po
+%%PYTHON_SITELIBDIR%%/reversion/locale/pt_BR/LC_MESSAGES/django.mo
+%%PYTHON_SITELIBDIR%%/reversion/locale/pt_BR/LC_MESSAGES/django.po
+%%PYTHON_SITELIBDIR%%/reversion/locale/ru/LC_MESSAGES/django.mo
+%%PYTHON_SITELIBDIR%%/reversion/locale/ru/LC_MESSAGES/django.po
+%%PYTHON_SITELIBDIR%%/reversion/locale/sv/LC_MESSAGES/django.mo
+%%PYTHON_SITELIBDIR%%/reversion/locale/sv/LC_MESSAGES/django.po
+%%PYTHON_SITELIBDIR%%/reversion/management/__init__.py
+%%PYTHON_SITELIBDIR%%/reversion/management/__init__.pyc
+%%PYTHON_SITELIBDIR%%/reversion/management/__init__.pyo
+%%PYTHON_SITELIBDIR%%/reversion/management/commands/__init__.py
+%%PYTHON_SITELIBDIR%%/reversion/management/commands/__init__.pyc
+%%PYTHON_SITELIBDIR%%/reversion/management/commands/__init__.pyo
+%%PYTHON_SITELIBDIR%%/reversion/management/commands/createinitialrevisions.py
+%%PYTHON_SITELIBDIR%%/reversion/management/commands/createinitialrevisions.pyc
+%%PYTHON_SITELIBDIR%%/reversion/management/commands/createinitialrevisions.pyo
+%%PYTHON_SITELIBDIR%%/reversion/management/commands/deleterevisions.py
+%%PYTHON_SITELIBDIR%%/reversion/management/commands/deleterevisions.pyc
+%%PYTHON_SITELIBDIR%%/reversion/management/commands/deleterevisions.pyo
+%%PYTHON_SITELIBDIR%%/reversion/middleware.py
+%%PYTHON_SITELIBDIR%%/reversion/middleware.pyc
+%%PYTHON_SITELIBDIR%%/reversion/middleware.pyo
+%%PYTHON_SITELIBDIR%%/reversion/migrations/0001_initial.py
+%%PYTHON_SITELIBDIR%%/reversion/migrations/0001_initial.pyc
+%%PYTHON_SITELIBDIR%%/reversion/migrations/0001_initial.pyo
+%%PYTHON_SITELIBDIR%%/reversion/migrations/0002_auto__add_field_version_type.py
+%%PYTHON_SITELIBDIR%%/reversion/migrations/0002_auto__add_field_version_type.pyc
+%%PYTHON_SITELIBDIR%%/reversion/migrations/0002_auto__add_field_version_type.pyo
+%%PYTHON_SITELIBDIR%%/reversion/migrations/0003_auto__add_field_version_object_id_int.py
+%%PYTHON_SITELIBDIR%%/reversion/migrations/0003_auto__add_field_version_object_id_int.pyc
+%%PYTHON_SITELIBDIR%%/reversion/migrations/0003_auto__add_field_version_object_id_int.pyo
+%%PYTHON_SITELIBDIR%%/reversion/migrations/0004_populate_object_id_int.py
+%%PYTHON_SITELIBDIR%%/reversion/migrations/0004_populate_object_id_int.pyc
+%%PYTHON_SITELIBDIR%%/reversion/migrations/0004_populate_object_id_int.pyo
+%%PYTHON_SITELIBDIR%%/reversion/migrations/0005_auto__add_field_revision_manager_slug.py
+%%PYTHON_SITELIBDIR%%/reversion/migrations/0005_auto__add_field_revision_manager_slug.pyc
+%%PYTHON_SITELIBDIR%%/reversion/migrations/0005_auto__add_field_revision_manager_slug.pyo
+%%PYTHON_SITELIBDIR%%/reversion/migrations/__init__.py
+%%PYTHON_SITELIBDIR%%/reversion/migrations/__init__.pyc
+%%PYTHON_SITELIBDIR%%/reversion/migrations/__init__.pyo
+%%PYTHON_SITELIBDIR%%/reversion/models.py
+%%PYTHON_SITELIBDIR%%/reversion/models.pyc
+%%PYTHON_SITELIBDIR%%/reversion/models.pyo
+%%PYTHON_SITELIBDIR%%/reversion/revisions.py
+%%PYTHON_SITELIBDIR%%/reversion/revisions.pyc
+%%PYTHON_SITELIBDIR%%/reversion/revisions.pyo
+%%PYTHON_SITELIBDIR%%/reversion/templates/reversion/change_list.html
+%%PYTHON_SITELIBDIR%%/reversion/templates/reversion/object_history.html
+%%PYTHON_SITELIBDIR%%/reversion/templates/reversion/recover_form.html
+%%PYTHON_SITELIBDIR%%/reversion/templates/reversion/recover_list.html
+%%PYTHON_SITELIBDIR%%/reversion/templates/reversion/revision_form.html
+%%PYTHON_SITELIBDIR%%/reversion/tests.py
+%%PYTHON_SITELIBDIR%%/reversion/tests.pyc
+%%PYTHON_SITELIBDIR%%/reversion/tests.pyo
+%%PYTHON_SITELIBDIR%%/reversion/tests_deprecated.py
+%%PYTHON_SITELIBDIR%%/reversion/tests_deprecated.pyc
+%%PYTHON_SITELIBDIR%%/reversion/tests_deprecated.pyo
+%%PYTHON_SITELIBDIR%%/reversion/version.py
+%%PYTHON_SITELIBDIR%%/reversion/version.pyc
+%%PYTHON_SITELIBDIR%%/reversion/version.pyo
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/templates/reversion
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/templates
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/migrations
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/management/commands
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/management
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/locale/sv/LC_MESSAGES
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/locale/sv
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/locale/ru/LC_MESSAGES
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/locale/ru
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/locale/pt_BR/LC_MESSAGES
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/locale/pt_BR
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/locale/pl/LC_MESSAGES
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/locale/pl
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/locale/nb/LC_MESSAGES
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/locale/nb
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/locale/it/LC_MESSAGES
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/locale/it
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/locale/he/LC_MESSAGES
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/locale/he
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/locale/fr/LC_MESSAGES
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/locale/fr
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/locale/de/LC_MESSAGES
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/locale/de
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/locale/cs/LC_MESSAGES
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/locale/cs
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion/locale
+@dirrmtry %%PYTHON_SITELIBDIR%%/reversion