aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2015-08-31 00:55:14 +0800
committerriggs <riggs@FreeBSD.org>2015-08-31 00:55:14 +0800
commit6a8d3e5f39d2efa99acd15c8991e7c8a98fa2225 (patch)
tree5b232d95fbfad49a5d9ef0004b4b309e4f59712b /www
parent5c15d58e97f1ea0605ccb1417fbb2c1b6d0599bc (diff)
downloadfreebsd-ports-gnome-6a8d3e5f39d2efa99acd15c8991e7c8a98fa2225.tar.gz
freebsd-ports-gnome-6a8d3e5f39d2efa99acd15c8991e7c8a98fa2225.tar.zst
freebsd-ports-gnome-6a8d3e5f39d2efa99acd15c8991e7c8a98fa2225.zip
Add www/py-pyocclient: the Python OwnCloud client library
PR: 201996 Submitted by: che@bein.link (maintainer) Reviewed by: koobs, riggs
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-pyocclient/Makefile26
-rw-r--r--www/py-pyocclient/distinfo2
-rw-r--r--www/py-pyocclient/pkg-descr5
4 files changed, 34 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 6850bcf0cad7..07b619217d4f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1702,6 +1702,7 @@
SUBDIR += py-py-restclient
SUBDIR += py-pyjwt
SUBDIR += py-pylons
+ SUBDIR += py-pyocclient
SUBDIR += py-pyquery
SUBDIR += py-pyramid
SUBDIR += py-pyramid_rpc
diff --git a/www/py-pyocclient/Makefile b/www/py-pyocclient/Makefile
new file mode 100644
index 000000000000..feecefbff393
--- /dev/null
+++ b/www/py-pyocclient/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= pyocclient
+PORTVERSION= 0.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= che@bein.link
+COMMENT= Python Owncloud client library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.0.1:${PORTSDIR}/www/py-requests
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} >= 3000
+BROKEN= pyocclient only supports Python 2.x at the moment
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/py-pyocclient/distinfo b/www/py-pyocclient/distinfo
new file mode 100644
index 000000000000..282d1d0300e4
--- /dev/null
+++ b/www/py-pyocclient/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pyocclient-0.1.tar.gz) = b3505e4973bfadda11f9f5d426018f9ea3a373c3ef47b77324ed4f88f195ff43
+SIZE (pyocclient-0.1.tar.gz) = 11749
diff --git a/www/py-pyocclient/pkg-descr b/www/py-pyocclient/pkg-descr
new file mode 100644
index 000000000000..25cbb1aad363
--- /dev/null
+++ b/www/py-pyocclient/pkg-descr
@@ -0,0 +1,5 @@
+This library makes it possible to connect to an ownCloud instance and perform
+file, share and attribute operations in python. Please note that this is not
+a sync client implementation but rather a wrapper around various APIs.
+
+WWW: https://github.com/owncloud/pyocclient