aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-08-24 05:37:24 +0800
committerswills <swills@FreeBSD.org>2014-08-24 05:37:24 +0800
commit6b0f111910530c6ffaac43779144161ec81419f1 (patch)
tree0e3602f243716e5e23b9e68441861e5a7fd75e68 /www
parent2b1970730890d3354c75343a8afcc1253cd78776 (diff)
downloadfreebsd-ports-gnome-6b0f111910530c6ffaac43779144161ec81419f1.tar.gz
freebsd-ports-gnome-6b0f111910530c6ffaac43779144161ec81419f1.tar.zst
freebsd-ports-gnome-6b0f111910530c6ffaac43779144161ec81419f1.zip
www/rubygem-http_parser.rb: create port for rubygem-http_parser.rb
Ruby bindings to http://github.com/ry/http-parser and http://github.com/a2800276/http-parser.java WWW: http://github.com/tmm1/http_parser.rb
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-http_parser.rb/Makefile16
-rw-r--r--www/rubygem-http_parser.rb/distinfo2
-rw-r--r--www/rubygem-http_parser.rb/pkg-descr4
4 files changed, 23 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index c0dd7a1c964d..e18843ae229d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1805,6 +1805,7 @@
SUBDIR += rubygem-html2haml
SUBDIR += rubygem-http
SUBDIR += rubygem-http-cookie
+ SUBDIR += rubygem-http_parser.rb
SUBDIR += rubygem-httpi
SUBDIR += rubygem-httparty
SUBDIR += rubygem-httpclient
diff --git a/www/rubygem-http_parser.rb/Makefile b/www/rubygem-http_parser.rb/Makefile
new file mode 100644
index 000000000000..ee223b8ef7bd
--- /dev/null
+++ b/www/rubygem-http_parser.rb/Makefile
@@ -0,0 +1,16 @@
+# Created by: Steve Wills <swills@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= http_parser.rb
+PORTVERSION= 0.6.0
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Simple callback-based HTTP request/response parser
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST=yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-http_parser.rb/distinfo b/www/rubygem-http_parser.rb/distinfo
new file mode 100644
index 000000000000..7987f168dbf9
--- /dev/null
+++ b/www/rubygem-http_parser.rb/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/http_parser.rb-0.6.0.gem) = f11d0aec50ef26a7d1f991e627ac88acdb5979282aeba7a5c3be6ce0636ed196
+SIZE (rubygem/http_parser.rb-0.6.0.gem) = 177664
diff --git a/www/rubygem-http_parser.rb/pkg-descr b/www/rubygem-http_parser.rb/pkg-descr
new file mode 100644
index 000000000000..2b7e8f5f0183
--- /dev/null
+++ b/www/rubygem-http_parser.rb/pkg-descr
@@ -0,0 +1,4 @@
+Ruby bindings to http://github.com/ry/http-parser and
+http://github.com/a2800276/http-parser.java
+
+WWW: http://github.com/tmm1/http_parser.rb