aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormarkp <markp@FreeBSD.org>2003-02-04 22:05:41 +0800
committermarkp <markp@FreeBSD.org>2003-02-04 22:05:41 +0800
commit6e94bf3d7a28e032ff300ecd51ac8a957e654f6f (patch)
treed45e6d4a10be9cead77eeb4c997ce384f1e175dc /www
parent559ce1ee1e50fe2079ef2cb09eb89d8957322de3 (diff)
downloadfreebsd-ports-gnome-6e94bf3d7a28e032ff300ecd51ac8a957e654f6f.tar.gz
freebsd-ports-gnome-6e94bf3d7a28e032ff300ecd51ac8a957e654f6f.tar.zst
freebsd-ports-gnome-6e94bf3d7a28e032ff300ecd51ac8a957e654f6f.zip
Fix build after REINPLACE change.
Change MAINTAINER to ports.
Diffstat (limited to 'www')
-rw-r--r--www/cgichk/Makefile7
-rw-r--r--www/cgichk/files/patch-cgichk.h10
2 files changed, 13 insertions, 4 deletions
diff --git a/www/cgichk/Makefile b/www/cgichk/Makefile
index c12669ecda56..ead1bb01ea93 100644
--- a/www/cgichk/Makefile
+++ b/www/cgichk/Makefile
@@ -12,17 +12,16 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}_${PORTVERSION}
-MAINTAINER= markp@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
WRKSRC= ${WRKDIR}/${PORTNAME}
ALL_TARGET= cgichk
USE_REINPLACE= yes
-pre-patch:
+post-patch:
${REINPLACE_CMD} -e "s/^(CC|CFLAGS).+//g" ${WRKSRC}/Makefile
${REINPLACE_CMD} -e \
- "s@/etc/@${PREFIX}/etc/@g; s/#include <getopt.h>//g; \
- s@^(?=.+sys/socket.h)@#include <sys/types.h>\n@g;" \
+ "s@/etc/@${PREFIX}/etc/@g; s/#include <getopt.h>//g;" \
${WRKSRC}/cgichk.h
do-install:
diff --git a/www/cgichk/files/patch-cgichk.h b/www/cgichk/files/patch-cgichk.h
new file mode 100644
index 000000000000..6223def2179d
--- /dev/null
+++ b/www/cgichk/files/patch-cgichk.h
@@ -0,0 +1,10 @@
+--- cgichk.h.orig Wed Feb 5 00:36:57 2003
++++ cgichk.h Wed Feb 5 00:37:05 2003
+@@ -19,6 +19,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <netdb.h>