aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2014-10-07 20:01:51 +0800
committerwg <wg@FreeBSD.org>2014-10-07 20:01:51 +0800
commit6e998ab56251384d1bd373d84463b6bf1232618b (patch)
tree6b275fc885b65b1162403e6d9e4bf751641a96c0 /www
parent5ed6d11a8f8f87d5d33b1406fff58f2e5f3d947b (diff)
downloadfreebsd-ports-gnome-6e998ab56251384d1bd373d84463b6bf1232618b.tar.gz
freebsd-ports-gnome-6e998ab56251384d1bd373d84463b6bf1232618b.tar.zst
freebsd-ports-gnome-6e998ab56251384d1bd373d84463b6bf1232618b.zip
www/twms: switch from py-imaging to py-pillow
With hat: python Approved by: portmgr (bdrewery, implicit)
Diffstat (limited to 'www')
-rw-r--r--www/twms/Makefile4
-rw-r--r--www/twms/files/patch-twms__canvas.py18
-rw-r--r--www/twms/files/patch-twms__drawing.py18
-rw-r--r--www/twms/files/patch-twms__fetchers.py18
-rw-r--r--www/twms/files/patch-twms__filter.py13
-rw-r--r--www/twms/files/patch-twms__reproject.py11
6 files changed, 80 insertions, 2 deletions
diff --git a/www/twms/Makefile b/www/twms/Makefile
index 4dce6d896ce5..188060c10b27 100644
--- a/www/twms/Makefile
+++ b/www/twms/Makefile
@@ -3,7 +3,7 @@
PORTNAME= twms
PORTVERSION= 0.02w
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www astro
MASTER_SITES= GOOGLE_CODE
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pyproj/__init__.py:${PORTSDIR}/graphics/py-pyproj \
${PYTHON_SITELIBDIR}/web/__init__.py:${PORTSDIR}/www/webpy \
- ${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imaging
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:${PORTSDIR}/graphics/py-pillow
USES= python tar:bzip2
NO_BUILD= yes
diff --git a/www/twms/files/patch-twms__canvas.py b/www/twms/files/patch-twms__canvas.py
new file mode 100644
index 000000000000..58a9ec3a3232
--- /dev/null
+++ b/www/twms/files/patch-twms__canvas.py
@@ -0,0 +1,18 @@
+--- twms/canvas.py.orig 2014-10-07 11:58:01 UTC
++++ twms/canvas.py
+@@ -24,7 +24,7 @@
+
+
+ import projections
+-import Image, ImageFilter
++from PIL import Image, ImageFilter
+ import urllib2
+ import StringIO
+ import datetime
+@@ -132,4 +132,4 @@
+ tiles = self.tiles.keys()
+ for tile in tiles:
+ self.tiles[tile]["im"] = self.tiles[tile]["im"].filter(ImageFilter.MedianFilter(size))
+- self.tiles[tile]["pix"] = self.tiles[tile]["im"].load()
+\ No newline at end of file
++ self.tiles[tile]["pix"] = self.tiles[tile]["im"].load()
diff --git a/www/twms/files/patch-twms__drawing.py b/www/twms/files/patch-twms__drawing.py
new file mode 100644
index 000000000000..3607f7fd5194
--- /dev/null
+++ b/www/twms/files/patch-twms__drawing.py
@@ -0,0 +1,18 @@
+--- twms/drawing.py.orig 2014-10-07 11:57:57 UTC
++++ twms/drawing.py
+@@ -13,7 +13,7 @@
+
+ # You should have received a copy of the GNU General Public License
+ # along with tWMS. If not, see <http://www.gnu.org/licenses/>.
+-import Image, ImageDraw
++from PIL import Image, ImageDraw
+ import urllib
+ import os, sys
+
+@@ -79,4 +79,4 @@
+ draw.ellipse((coords[0][0]-3,coords[0][1]-3,coords[0][0]+3,coords[0][1]+3),fill=color,outline=color)
+ elif geometry == "POLYGON":
+ draw.polygon(coords, fill=color, outline=color)
+- return img
+\ No newline at end of file
++ return img
diff --git a/www/twms/files/patch-twms__fetchers.py b/www/twms/files/patch-twms__fetchers.py
new file mode 100644
index 000000000000..a635d1a43cd7
--- /dev/null
+++ b/www/twms/files/patch-twms__fetchers.py
@@ -0,0 +1,18 @@
+--- twms/fetchers.py.orig 2014-10-07 11:58:04 UTC
++++ twms/fetchers.py
+@@ -21,7 +21,7 @@
+ import math
+ import sys
+ import StringIO
+-import Image
++from PIL import Image
+
+ import config
+ import projections
+@@ -115,4 +115,4 @@
+ tne.close()
+ os.remove(local+ this_layer["ext"])
+ return False
+- return im
+\ No newline at end of file
++ return im
diff --git a/www/twms/files/patch-twms__filter.py b/www/twms/files/patch-twms__filter.py
new file mode 100644
index 000000000000..6dc693586d94
--- /dev/null
+++ b/www/twms/files/patch-twms__filter.py
@@ -0,0 +1,13 @@
+--- twms/filter.py.orig 2014-10-07 11:57:53 UTC
++++ twms/filter.py
+@@ -15,8 +15,8 @@
+ # along with tWMS. If not, see <http://www.gnu.org/licenses/>.
+
+
+-import ImageFilter
+-import ImageEnhance
++from PIL import ImageFilter
++from PIL import ImageEnhance
+
+ def raster(result_img, filt):
+ """
diff --git a/www/twms/files/patch-twms__reproject.py b/www/twms/files/patch-twms__reproject.py
new file mode 100644
index 000000000000..a1659dec9790
--- /dev/null
+++ b/www/twms/files/patch-twms__reproject.py
@@ -0,0 +1,11 @@
+--- twms/reproject.py.orig 2014-10-07 11:58:11 UTC
++++ twms/reproject.py
+@@ -14,7 +14,7 @@
+ # You should have received a copy of the GNU General Public License
+ # along with tWMS. If not, see <http://www.gnu.org/licenses/>.
+
+-import Image
++from PIL import Image
+ import projections
+ import sys
+