aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2014-08-03 16:07:20 +0800
committermva <mva@FreeBSD.org>2014-08-03 16:07:20 +0800
commit737c214e4f70b28971e4c2a5935412f92548756b (patch)
treee62dae232034e664a65b4e666798196afb6710ed /www
parenta1170ecb321b60ee6d926651f67bf4dcb58f94aa (diff)
downloadfreebsd-ports-gnome-737c214e4f70b28971e4c2a5935412f92548756b.tar.gz
freebsd-ports-gnome-737c214e4f70b28971e4c2a5935412f92548756b.tar.zst
freebsd-ports-gnome-737c214e4f70b28971e4c2a5935412f92548756b.zip
- Unbreak the build after the recent lang/python27 update.
PR: 192348 Submitted by: peter@
Diffstat (limited to 'www')
-rw-r--r--www/mod_python33/Makefile2
-rw-r--r--www/mod_python33/files/patch-configure23
2 files changed, 13 insertions, 12 deletions
diff --git a/www/mod_python33/Makefile b/www/mod_python33/Makefile
index 3bdb2654e50c..6c0119046b98 100644
--- a/www/mod_python33/Makefile
+++ b/www/mod_python33/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mod_python
PORTVERSION= 3.3.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= www python
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
MASTER_SITE_SUBDIR= modpython
diff --git a/www/mod_python33/files/patch-configure b/www/mod_python33/files/patch-configure
index e979f312021d..731799fa07d2 100644
--- a/www/mod_python33/files/patch-configure
+++ b/www/mod_python33/files/patch-configure
@@ -1,11 +1,12 @@
---- configure.orig Sat Aug 5 09:51:23 2006
-+++ configure Sat Aug 5 09:57:47 2006
-@@ -2899,7 +2899,7 @@
- PyLIBP=${PY_STD_LIB}
- PyLIBPL=${PyLIBP}/config
- PyPYTHONLIBS=${PyLIBPL}/libpython${PyVERSION}.a
--PyLIBS=`grep "^LIB[SMC]=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' ' '`
-+PyLIBS=`ldd $PYTHON_BIN | sed -n 's,^.* => [^ ]*/lib\(.*\)\.so[^ ]* \((.*)\),-l\1,p' | grep -v '^-lc$' | xargs echo`
- PyMODLIBS=`grep "^LOCALMODLIBS=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' ' '`
- PyFRAMEWORK=`grep "^PYTHONFRAMEWORK=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' ' '`
- PyFRAMEWORKDIR=`grep "^PYTHONFRAMEWORKDIR=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' ' ' | awk '{print $1}'`
+--- ./configure.orig 2006-03-11 03:46:52.000000000 +0000
++++ ./configure 2014-08-02 22:49:33.000000000 +0000
+@@ -3013,7 +3013,7 @@
+ echo $ECHO_N "checking linker flags used to link Python... $ECHO_C" >&6
+
+ PyLFS=`grep "^LINKFORSHARED=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' ' '`
+-PyLDFLAGS=`grep "^LDFLAGS=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' ' '`
++PyLDFLAGS=`grep "^LDFLAGS=" ${PyLIBPL}/Makefile | sed 's,^LDFLAGS=,,' | tr '\011\012\015' ' '`
+ LDFLAGS="${LDFLAGS} ${PyLFS} ${PyLDFLAGS}"
+ LDFLAGS="${LDFLAGS} ${PY_LDFLAGS}"
+ echo "$as_me:$LINENO: result: $PY_LDFLAGS" >&5
+