aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-10-27 02:58:07 +0800
committerrm <rm@FreeBSD.org>2012-10-27 02:58:07 +0800
commit78149c29c8190b21df7f1ca35aad7e0eee071a18 (patch)
treea84c1ec4770a5d1c04d9f28870ed307bfbce3f3e /www
parent4a7bd4bad757e65a78561df8f073c860858068ed (diff)
downloadfreebsd-ports-gnome-78149c29c8190b21df7f1ca35aad7e0eee071a18.tar.gz
freebsd-ports-gnome-78149c29c8190b21df7f1ca35aad7e0eee071a18.tar.zst
freebsd-ports-gnome-78149c29c8190b21df7f1ca35aad7e0eee071a18.zip
- do not directly depend on setuptools, use USE_DISTUTILS instead
- bump PORTREVISION because of dependency change - trim Makefile header - limit python version to 2.x only - move pkg-plist contents into Makefile:PLIST_FILES PR: 173108 Submitted by: rm (myself) Approved by: glarkin (maintainer, by mail) Feature safe: yes
Diffstat (limited to 'www')
-rw-r--r--www/trac-pendingticket/Makefile20
-rw-r--r--www/trac-pendingticket/pkg-plist3
2 files changed, 8 insertions, 15 deletions
diff --git a/www/trac-pendingticket/Makefile b/www/trac-pendingticket/Makefile
index 3b6ebb78d73e..f160550b820a 100644
--- a/www/trac-pendingticket/Makefile
+++ b/www/trac-pendingticket/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: trac-pendingticket
-# Date created: May 18 2007
-# Whom: Gerrit Beine <gerrit.beine@gmx.de>
-#
+# Created by: Gerrit Beine <gerrit.beine@gmx.de>
# $FreeBSD$
-#
PORTNAME= pendingticket
PORTVERSION= 0.0.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www devel python
MASTER_SITES= http://www.gerritbeine.de/download/trac/
PKGNAMEPREFIX= trac-
@@ -16,15 +12,15 @@ DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
MAINTAINER= glarkin@FreeBSD.org
COMMENT= Support for pending tickets
-BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
WRKSRC= ${WRKDIR}/${PORTNAME}plugin/removependingplugin
-NO_BUILD= yes
-USE_PYTHON= 2.5+
-USE_PYDISTUTILS=yes
-PLIST_SUB+= PORTVERSION=${PORTVERSION} PYTHONVERSION=${_PYTHON_VERSION}
-PYDISTUTILS_NOEGGINFO= yes
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_PKGNAME= RemovePendingStatusPlugin
+PLIST_FILES= bin/close_old_pending.py \
+ bin/migrate_pending_attrib_to_status.py \
+ %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
post-patch:
cd ${WRKDIR}/${PORTNAME}plugin && ${PATCH} < ${PATCHDIR}/close_old_pending.py.patch
diff --git a/www/trac-pendingticket/pkg-plist b/www/trac-pendingticket/pkg-plist
deleted file mode 100644
index 58320158324b..000000000000
--- a/www/trac-pendingticket/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/close_old_pending.py
-bin/migrate_pending_attrib_to_status.py
-%%PYTHON_SITELIBDIR%%/RemovePendingStatusPlugin-%%PORTVERSION%%-py%%PYTHONVERSION%%.egg