aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorgblach <gblach@FreeBSD.org>2016-07-24 02:31:55 +0800
committergblach <gblach@FreeBSD.org>2016-07-24 02:31:55 +0800
commit7b3f674b014bf09b11870f57000c401b1b10b955 (patch)
tree56d30268ee04edc7cafc4a8eb8d7710d7296dec0 /www
parent4c08d9596175320e64c543b2901e605470eddd58 (diff)
downloadfreebsd-ports-gnome-7b3f674b014bf09b11870f57000c401b1b10b955.tar.gz
freebsd-ports-gnome-7b3f674b014bf09b11870f57000c401b1b10b955.tar.zst
freebsd-ports-gnome-7b3f674b014bf09b11870f57000c401b1b10b955.zip
Update to 4.4.1
Diffstat (limited to 'www')
-rw-r--r--www/py-tornado/Makefile11
-rw-r--r--www/py-tornado/distinfo5
-rw-r--r--www/py-tornado/files/patch-setup.py9
3 files changed, 6 insertions, 19 deletions
diff --git a/www/py-tornado/Makefile b/www/py-tornado/Makefile
index 381094d7a6da..0a4be8347f4b 100644
--- a/www/py-tornado/Makefile
+++ b/www/py-tornado/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tornado
-PORTVERSION= 4.3
+PORTVERSION= 4.4.1
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,19 +12,14 @@ COMMENT= Python Web Server from FriendFeed
LICENSE= APACHE20
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}certifi>0:security/py-certifi
-
USES= python
USE_PYTHON= autoplist distutils
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} < 3000
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}futures>0:devel/py-futures
-.endif
-
.if ${PYTHON_REL} < 3400
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}singledispatch>0:devel/py-singledispatch
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}singledispatch>0:devel/py-singledispatch \
+ ${PYTHON_PKGNAMEPREFIX}certifi>0:security/py-certifi
.endif
.if ${PYTHON_REL} < 3500
diff --git a/www/py-tornado/distinfo b/www/py-tornado/distinfo
index 0e634a3da2f7..ef7f493d9385 100644
--- a/www/py-tornado/distinfo
+++ b/www/py-tornado/distinfo
@@ -1,2 +1,3 @@
-SHA256 (tornado-4.3.tar.gz) = c9c2d32593d16eedf2cec1b6a41893626a2649b40b21ca9c4cac4243bde2efbf
-SIZE (tornado-4.3.tar.gz) = 450916
+TIMESTAMP = 1469297044
+SHA256 (tornado-4.4.1.tar.gz) = 371d0cf3d56c47accc66116a77ad558d76eebaa8458a6b677af71ca606522146
+SIZE (tornado-4.4.1.tar.gz) = 456992
diff --git a/www/py-tornado/files/patch-setup.py b/www/py-tornado/files/patch-setup.py
index 483e282195fb..dc22450431ac 100644
--- a/www/py-tornado/files/patch-setup.py
+++ b/www/py-tornado/files/patch-setup.py
@@ -1,14 +1,5 @@
--- setup.py.orig 2015-11-06 20:08:26 UTC
+++ setup.py
-@@ -125,7 +125,7 @@ if setuptools is not None:
- if sys.version_info < (2, 7):
- # Only needed indirectly, for singledispatch.
- install_requires.append('ordereddict')
-- if sys.version_info < (3, 2):
-+ if sys.version_info < (2, 7, 9):
- install_requires.append('backports.ssl_match_hostname')
- if sys.version_info < (3, 4):
- install_requires.append('singledispatch')
@@ -147,9 +147,6 @@ setup(
# in the sdist tarball)
"tornado.test": [