aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-11-30 18:05:54 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-11-30 18:05:54 +0800
commit8269c65baea87424cba794560d35c1303caa90ea (patch)
tree2c1bb02ad76f29a41580d5400035672379da2bb8 /www
parent4ffd8fb69b43576047fe881e1eb4b66e03f4ed49 (diff)
downloadfreebsd-ports-gnome-8269c65baea87424cba794560d35c1303caa90ea.tar.gz
freebsd-ports-gnome-8269c65baea87424cba794560d35c1303caa90ea.tar.zst
freebsd-ports-gnome-8269c65baea87424cba794560d35c1303caa90ea.zip
- Use PORTDOCS and PORTEXAMPLES
- Simplify Makefile
Diffstat (limited to 'www')
-rw-r--r--www/py-qp/Makefile11
-rw-r--r--www/py-qp/pkg-plist28
2 files changed, 4 insertions, 35 deletions
diff --git a/www/py-qp/Makefile b/www/py-qp/Makefile
index 23db8621333c..bde16a916af3 100644
--- a/www/py-qp/Makefile
+++ b/www/py-qp/Makefile
@@ -24,15 +24,12 @@ USE_PYTHON= -2.7
SUB_FILES= pkg-message
-.include <bsd.port.options.mk>
+PORTDOCS= CHANGES.txt LICENSE.txt README.txt
+PORTEXAMPLES= *
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}/
- cd ${WRKSRC}/ && ${INSTALL_DATA} CHANGES.txt LICENSE.txt README.txt ${STAGEDIR}${DOCSDIR}/
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/ ${STAGEDIR}${EXAMPLESDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
cd ${WRKSRC}/ && ${PYTHON_CMD} ${PYSETUP} install_demo_sites ${STAGEDIR}${EXAMPLESDIR}/
-.endif
.include <bsd.port.mk>
diff --git a/www/py-qp/pkg-plist b/www/py-qp/pkg-plist
index 1711ce4c9bb2..1ba27b74510a 100644
--- a/www/py-qp/pkg-plist
+++ b/www/py-qp/pkg-plist
@@ -114,31 +114,3 @@ bin/qpcensus.py
@dirrm %%PYTHON_SITELIBDIR%%/qp/fill
@dirrm %%PYTHON_SITELIBDIR%%/qp/sites
@dirrm %%PYTHON_SITELIBDIR%%/qp
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES.txt
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
-%%PORTDOCS%%%%DOCSDIR%%/README.txt
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/__init__.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo/slash.qpy
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo/__init__.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo/var/here.txt
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello/slash.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello/__init__.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello/var/here.txt
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/proto/forms.qpy
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/proto/qwiki.qpy
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/proto/slash.qpy
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/proto/__init__.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/proto/static/all.css
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/proto/static/favicon.ico
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/proto/static/favicon.png
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/proto/static/proto.js
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/proto/var/here.txt
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/echo/var
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/echo
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/hello/var
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/hello
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/proto/static
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/proto/var
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/proto
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%