aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2015-08-10 03:14:13 +0800
committernetchild <netchild@FreeBSD.org>2015-08-10 03:14:13 +0800
commit8725235f35a03fb0dd1da17304424701f84e15dd (patch)
tree5205db7c3150c2000d8091bebe7ce6fc273be03c /www
parentb3c031084f5535608ae04c365e4eea69d5c7ad16 (diff)
downloadfreebsd-ports-gnome-8725235f35a03fb0dd1da17304424701f84e15dd.tar.gz
freebsd-ports-gnome-8725235f35a03fb0dd1da17304424701f84e15dd.tar.zst
freebsd-ports-gnome-8725235f35a03fb0dd1da17304424701f84e15dd.zip
Re-commit of
64 bit linuxulator support (not activated by default): - most of the work was done by Alan Jude - all errors are mine - 64bit (may) have rough edges - I validated * that the 32bit part doesn't has deinstall regressions (incl. EXP runs by antoine) * 29 of 72 64bit ports ports don't have deinstall leftovers (more validation later, when I dare to activate the 64bit linuxulator in the kernel) - the infrastructure part looks mature enough to let more test-bunnies get some experience with the new 64 bit parts - to use it you shall have no linux ports installed and have to specify (on your own risk) the following in make.conf before installing the ports: OVERRIDE_LINUX_BASE_PORT=c6_64 OVERRIDE_LINUX_NONBASE_PORTS=c6_64 This is on top of the exiting c6 linux ports. Given that CentOS 7 is 64bits only, we decided to have it as an "overlay" instead of new ports. The 64bit part only installs 64bit executables, the 32bit ports can not be installed at the same time (if needed we can think of letting the 64bit overlay install the 32bit parts too, but given the CentOS 7 comment above...). Differential Revision: https://reviews.freebsd.org/D174 Submitted by: alanjude Sponsored by: Essen FreeBSD Hackathon 2015 Reviewed by: xmj, eadler (earlier versions) Approved by: portmgr (antoine after some EXP-runs)
Diffstat (limited to 'www')
-rw-r--r--www/linux-c6-flashplugin11/Makefile3
-rw-r--r--www/linux-c6-flashplugin11/distinfo.i686 (renamed from www/linux-c6-flashplugin11/distinfo)0
-rw-r--r--www/linux-c6-flashplugin11/distinfo.x86_644
-rw-r--r--www/linux-c6-flashplugin11/pkg-plist.i686 (renamed from www/linux-c6-flashplugin11/pkg-plist)2
-rw-r--r--www/linux-c6-flashplugin11/pkg-plist.x86_6415
-rw-r--r--www/linux-c6-qt47-webkit/Makefile12
-rw-r--r--www/linux-c6-qt47-webkit/distinfo.i3862
-rw-r--r--www/linux-c6-qt47-webkit/distinfo.i6862
-rw-r--r--www/linux-c6-qt47-webkit/distinfo.x86_642
-rw-r--r--www/linux-c6-qt47-webkit/pkg-plist.i686 (renamed from www/linux-c6-qt47-webkit/pkg-plist)0
-rw-r--r--www/linux-c6-qt47-webkit/pkg-plist.x86_649
-rw-r--r--www/linux-f10-flashplugin11/Makefile1
12 files changed, 42 insertions, 10 deletions
diff --git a/www/linux-c6-flashplugin11/Makefile b/www/linux-c6-flashplugin11/Makefile
index 6f5846577e9d..d7c31d7abc14 100644
--- a/www/linux-c6-flashplugin11/Makefile
+++ b/www/linux-c6-flashplugin11/Makefile
@@ -18,6 +18,9 @@ USE_LINUX?= c6
USE_LINUX_APPS?= curl cyrus-sasl2 gdkpixbuf2 gtk2 nspr nss # libssh2 openldap
WANT_GNOME= yes
+DISTINFO_FILE?= ${MASTERDIR}/distinfo.${LINUX_RPM_ARCH}
+PLIST?= ${MASTERDIR}/pkg-plist.${LINUX_RPM_ARCH}
+
RESTRICTED= Redistribution not allowed
RESTRICTED_FILES= ${DISTFILES:Nlinux-f10-flashsupport*:C/:[^:]+$//}
diff --git a/www/linux-c6-flashplugin11/distinfo b/www/linux-c6-flashplugin11/distinfo.i686
index ab176d1c062b..ab176d1c062b 100644
--- a/www/linux-c6-flashplugin11/distinfo
+++ b/www/linux-c6-flashplugin11/distinfo.i686
diff --git a/www/linux-c6-flashplugin11/distinfo.x86_64 b/www/linux-c6-flashplugin11/distinfo.x86_64
new file mode 100644
index 000000000000..881f646eece0
--- /dev/null
+++ b/www/linux-c6-flashplugin11/distinfo.x86_64
@@ -0,0 +1,4 @@
+SHA256 (flashplugin/11.2r202.466/install_flash_player_11_linux.x86_64.tar.gz) = a884194f5125144b63ba8137f7859ee587acfa4b211ea9d13093bd5330749cb2
+SIZE (flashplugin/11.2r202.466/install_flash_player_11_linux.x86_64.tar.gz) = 7246913
+SHA256 (flashplugin/11.2r202.466/linux-f10-flashsupport-9.0.1.i386.tar.gz) = 4a309b1a326bd2212cc72480628659e5a7fd61d9e0572cb7350c206f030955bf
+SIZE (flashplugin/11.2r202.466/linux-f10-flashsupport-9.0.1.i386.tar.gz) = 3455
diff --git a/www/linux-c6-flashplugin11/pkg-plist b/www/linux-c6-flashplugin11/pkg-plist.i686
index af45ed36bdbe..7ddfcec73079 100644
--- a/www/linux-c6-flashplugin11/pkg-plist
+++ b/www/linux-c6-flashplugin11/pkg-plist.i686
@@ -11,3 +11,5 @@ share/icons/hicolor/48x48/apps/flash-player-properties.png
%%NO_ALSA%%@dir %%LINUXBASE%%/usr
%%NO_ALSA%%@dir %%LINUXBASE%%
%%NO_ALSA%%@dir %%COMPATDIR%%
+@dir share/applications
+@dir share
diff --git a/www/linux-c6-flashplugin11/pkg-plist.x86_64 b/www/linux-c6-flashplugin11/pkg-plist.x86_64
new file mode 100644
index 000000000000..7ddfcec73079
--- /dev/null
+++ b/www/linux-c6-flashplugin11/pkg-plist.x86_64
@@ -0,0 +1,15 @@
+bin/flash-player-properties
+%%WEBPLUGIN_DIR%%/libflashplayer.so
+share/applications/flash-player-properties.desktop
+share/icons/hicolor/16x16/apps/flash-player-properties.png
+share/icons/hicolor/22x22/apps/flash-player-properties.png
+share/icons/hicolor/24x24/apps/flash-player-properties.png
+share/icons/hicolor/32x32/apps/flash-player-properties.png
+share/icons/hicolor/48x48/apps/flash-player-properties.png
+%%NO_ALSA%%%%LINUXBASE%%/usr/lib/libflashsupport.so
+%%NO_ALSA%%@dir %%LINUXBASE%%/usr/lib
+%%NO_ALSA%%@dir %%LINUXBASE%%/usr
+%%NO_ALSA%%@dir %%LINUXBASE%%
+%%NO_ALSA%%@dir %%COMPATDIR%%
+@dir share/applications
+@dir share
diff --git a/www/linux-c6-qt47-webkit/Makefile b/www/linux-c6-qt47-webkit/Makefile
index 5b46f71dcb77..3fdbd6e92d83 100644
--- a/www/linux-c6-qt47-webkit/Makefile
+++ b/www/linux-c6-qt47-webkit/Makefile
@@ -5,21 +5,17 @@ PORTNAME= qt47-webkit
PORTVERSION= 4.7.2
PORTREVISION= 1
CATEGORIES= www linux
-MASTER_SITES= LOCAL/xmj
-PKGNAMEPREFIX= linux-${USE_LINUX}-
-DIST_SUBDIR= rpm/${LINUX_RPM_ARCH}/centos/c5
+MASTER_SITES= http://dl.atrpms.net/el6-${LINUX_REPO_ARCH}/atrpms/testing/ LOCAL/xmj
+DIST_SUBDIR= rpm/${LINUX_RPM_ARCH}/atrpms/6
MAINTAINER= emulation@FreeBSD.org
-COMMENT= RPM of QT4 (Linux CentOS 5)
+COMMENT= RPM of QT4 (Linux CentOS 6)
ONLY_FOR_ARCHS= i386 amd64
-RPMVERSION= 1_18.el5
+RPMVERSION= 1_18.el6
USE_LINUX= c6
-LINUX_RPM_ARCH= i386
USE_LINUX_APPS= fontconfig png xorglibs sqlite3 qt47 qt47-x11
-
USE_LINUX_RPM= yes
-LINUX_DIST_VER= 5
USE_LDCONFIG= yes
DESCR= ${.CURDIR}/../../www/webkit-gtk3/pkg-descr # contains no GTK references, reuse
diff --git a/www/linux-c6-qt47-webkit/distinfo.i386 b/www/linux-c6-qt47-webkit/distinfo.i386
deleted file mode 100644
index 95cd9ec0bac3..000000000000
--- a/www/linux-c6-qt47-webkit/distinfo.i386
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (rpm/i386/centos/c5/qt47-webkit-4.7.2-1_18.el5.i386.rpm) = de86590afcffa2016062bc891530f982445c44a9b599fe2c8a6310f72bcb3f54
-SIZE (rpm/i386/centos/c5/qt47-webkit-4.7.2-1_18.el5.i386.rpm) = 7233670
diff --git a/www/linux-c6-qt47-webkit/distinfo.i686 b/www/linux-c6-qt47-webkit/distinfo.i686
new file mode 100644
index 000000000000..4cafe2dc6bf8
--- /dev/null
+++ b/www/linux-c6-qt47-webkit/distinfo.i686
@@ -0,0 +1,2 @@
+SHA256 (rpm/i686/atrpms/6/qt47-webkit-4.7.2-1_18.el6.i686.rpm) = a0362422d4ea0fb87838ce1e17a2ffcc934d312cd8e8cfac02112d61a9d62bf0
+SIZE (rpm/i686/atrpms/6/qt47-webkit-4.7.2-1_18.el6.i686.rpm) = 5491340
diff --git a/www/linux-c6-qt47-webkit/distinfo.x86_64 b/www/linux-c6-qt47-webkit/distinfo.x86_64
new file mode 100644
index 000000000000..460a3bba0db7
--- /dev/null
+++ b/www/linux-c6-qt47-webkit/distinfo.x86_64
@@ -0,0 +1,2 @@
+SHA256 (rpm/x86_64/atrpms/6/qt47-webkit-4.7.2-1_18.el6.x86_64.rpm) = 49b4dd40492c920f8562764f16dcbef1e976549da715936965be088055f80f65
+SIZE (rpm/x86_64/atrpms/6/qt47-webkit-4.7.2-1_18.el6.x86_64.rpm) = 5384720
diff --git a/www/linux-c6-qt47-webkit/pkg-plist b/www/linux-c6-qt47-webkit/pkg-plist.i686
index b7d58b1927bb..b7d58b1927bb 100644
--- a/www/linux-c6-qt47-webkit/pkg-plist
+++ b/www/linux-c6-qt47-webkit/pkg-plist.i686
diff --git a/www/linux-c6-qt47-webkit/pkg-plist.x86_64 b/www/linux-c6-qt47-webkit/pkg-plist.x86_64
new file mode 100644
index 000000000000..a4f0cf77355b
--- /dev/null
+++ b/www/linux-c6-qt47-webkit/pkg-plist.x86_64
@@ -0,0 +1,9 @@
+usr/lib64/qt47/imports/QtWebKit/libqmlwebkitplugin.so
+usr/lib64/qt47/libQtWebKit.so.4
+usr/lib64/qt47/libQtWebKit.so.4.7
+usr/lib64/qt47/libQtWebKit.so.4.7.2
+usr/lib64/qt47/plugins/designer/libqwebview.so
+usr/lib64/qt47/imports/QtWebKit/qmldir
+@dirrm usr/lib64/qt47/imports/QtWebKit
+@dirrmtry usr/lib64/qt47/plugins/designer
+@dirrmtry usr/lib64/qt47/plugins
diff --git a/www/linux-f10-flashplugin11/Makefile b/www/linux-f10-flashplugin11/Makefile
index 8ed057755a66..a48522a379f1 100644
--- a/www/linux-f10-flashplugin11/Makefile
+++ b/www/linux-f10-flashplugin11/Makefile
@@ -5,5 +5,6 @@ USE_LINUX= f10
ALSA_RUN_DEPENDS= linux-${USE_LINUX}-alsa-lib>=1.0.21_5:${PORTSDIR}/audio/linux-f10-alsa-lib
USE_LINUX_APPS= curl cyrus-sasl2 gtk2 libssh2 nspr nss openldap
MASTERDIR= ${.CURDIR}/../linux-c6-flashplugin11
+LINUX_RPM_ARCH= i686
.include "${MASTERDIR}/Makefile"