aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2007-06-25 14:43:39 +0800
committerhrs <hrs@FreeBSD.org>2007-06-25 14:43:39 +0800
commit8a1ea9653b1d03335395260cbe16ea9a6b521b53 (patch)
tree67a1065ed4730a3dd54b284c66112c18b64df938 /www
parent61565c4037030d3759e7530370fdc2167ca25484 (diff)
downloadfreebsd-ports-gnome-8a1ea9653b1d03335395260cbe16ea9a6b521b53.tar.gz
freebsd-ports-gnome-8a1ea9653b1d03335395260cbe16ea9a6b521b53.tar.zst
freebsd-ports-gnome-8a1ea9653b1d03335395260cbe16ea9a6b521b53.zip
- Remove redundant SUB_LIST.
- Use "find | xargs install" instead of "for i in `find`; do install $i; done". Suggested by: sat
Diffstat (limited to 'www')
-rw-r--r--www/wikicalc/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/www/wikicalc/Makefile b/www/wikicalc/Makefile
index 66e3ba8bcff9..dbf45bac4a24 100644
--- a/www/wikicalc/Makefile
+++ b/www/wikicalc/Makefile
@@ -20,7 +20,6 @@ USE_PERL5= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
SUB_FILES= setup.sh
-SUB_LIST= DATADIR=${DATADIR}
post-extract:
@${RM} -f ${WRKSRC}/gpl.txt
@@ -31,12 +30,10 @@ post-patch:
do-install:
${MKDIR} ${DATADIR}
cd ${WRKSRC} && \
- for i in `${FIND} . -type f -a ! -name \*.pl -a ! -name \*.bak`; do \
- ${INSTALL_DATA} $${i} ${DATADIR}/$${i}; \
- done; \
- for i in `${FIND} . -type f -a -name \*.pl`; do \
- ${INSTALL_SCRIPT} $${i} ${DATADIR}/$${i}; \
- done
+ ${FIND} . -type f -a ! -name \*.pl -a ! -name \*.bak | \
+ ${XARGS} -J % ${INSTALL_DATA} % ${DATADIR}/$${i}; \
+ ${FIND} . -type f -a -name \*.pl | \
+ ${XARGS} -J % ${INSTALL_SCRIPT} % ${DATADIR}/$${i}; \
${INSTALL_SCRIPT} ${WRKDIR}/setup.sh ${DATADIR}
.include <bsd.port.mk>