aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2005-04-22 12:06:12 +0800
committervanilla <vanilla@FreeBSD.org>2005-04-22 12:06:12 +0800
commit918602a2c532cec81483ab5ef03b9f4a536e0aa6 (patch)
tree54c11e20af928cd18ae5a5593247da04c77c51cd /www
parent85c348fa4ff41a86e43f97da8d7c075b095d2463 (diff)
downloadfreebsd-ports-gnome-918602a2c532cec81483ab5ef03b9f4a536e0aa6.tar.gz
freebsd-ports-gnome-918602a2c532cec81483ab5ef03b9f4a536e0aa6.tar.zst
freebsd-ports-gnome-918602a2c532cec81483ab5ef03b9f4a536e0aa6.zip
Add phpmyfaq 1.4.8, a multilingual, completely database-driven
FAQ-system. PR: ports/80004 Submitted by: chinsan <chinsan@mail2000.com.tw>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/phpmyfaq/Makefile75
-rw-r--r--www/phpmyfaq/distinfo2
-rw-r--r--www/phpmyfaq/pkg-descr10
-rw-r--r--www/phpmyfaq/pkg-message22
-rw-r--r--www/phpmyfaq/pkg-plist1
6 files changed, 111 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index f1e688d088c6..6b3291e99237 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -612,6 +612,7 @@
SUBDIR += phpSysInfo
SUBDIR += phpbb
SUBDIR += phpgedview
+ SUBDIR += phpmyfaq
SUBDIR += phpsurveyor
SUBDIR += phpwebapp
SUBDIR += phpwiki
diff --git a/www/phpmyfaq/Makefile b/www/phpmyfaq/Makefile
new file mode 100644
index 000000000000..7a8794345da7
--- /dev/null
+++ b/www/phpmyfaq/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: phpmyfaq
+# Date created: 2005-04-15
+# Whom: chinsan <chinsan@mail2000.com.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= phpmyfaq
+PORTVERSION= 1.4.8
+CATEGORIES= www
+MASTER_SITES= http://www.phpmyfaq.de/download/
+DISTNAME= ${PORTNAME}.${PORTVERSION}.full
+EXTRACT_SUFX= .zip
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A multilingual, completely database-driven FAQ-system
+
+WRKSRC= ${WRKDIR}/${PORTNAME}.${PORTVERSION}.full/${PORTNAME}.${PORTVERSION}
+USE_ZIP= YES
+
+USE_PHP= mysql pcre session
+PHP4_PORT?= www/mod_php4
+NO_BUILD= YES
+WANT_PHP_WEB= YES
+
+WWWDOCROOT?= www/data
+PHPMYFAQURL?= faq
+WWWOWN?= www
+WWWGRP?= www
+
+PHPMYFAQDIR?= ${WWWDOCROOT}/${PHPMYFAQURL}
+PLIST= ${WRKDIR}/pkg-plist
+EXCEPTFILES= ${PREFIX}/${PHPMYFAQDIR}/install/bbcode2xhtml.php \
+ ${PREFIX}/${PHPMYFAQDIR}/install/index.html \
+ ${PREFIX}/${PHPMYFAQDIR}/install/installer.php \
+ ${PREFIX}/${PHPMYFAQDIR}/install/update.php
+
+.include <bsd.port.pre.mk>
+
+pre-install:
+ cd ${WRKSRC} && ${MV} inc/data.php.original inc/data.php \
+ && ${MV} inc/config.php.original inc/config.php \
+ && ${FIND} -s . -type f | \
+ ${SED} -e 's|^./||;s|^|${PHPMYFAQDIR}/|' > ${PLIST} \
+ && ${FIND} -d * -type d | \
+ ${SED} -e 's|^|@dirrm ${PHPMYFAQDIR}/|' >> ${PLIST} \
+ && ${ECHO_CMD} @dirrm ${PHPMYFAQDIR}/attachment/ >> ${PLIST} \
+ && ${ECHO_CMD} @dirrm ${PHPMYFAQDIR}/data/ >> ${PLIST} \
+ && ${ECHO_CMD} @dirrm ${PHPMYFAQDIR}/pdf/ >> ${PLIST} \
+ && ${ECHO_CMD} @dirrm ${PHPMYFAQDIR} >> ${PLIST}
+
+do-install:
+ # Data files
+ -${MKDIR} ${PREFIX}/${PHPMYFAQDIR}
+ @${CHOWN} www:www ${PREFIX}/${PHPMYFAQDIR}
+ @${CHMOD} 755 ${PREFIX}/${PHPMYFAQDIR}
+ @${CP} -R ${WRKSRC}/ ${PREFIX}/${PHPMYFAQDIR}
+ @${MKDIR} ${PREFIX}/${PHPMYFAQDIR}/attachment/
+ @${MKDIR} ${PREFIX}/${PHPMYFAQDIR}/data/
+ @${MKDIR} ${PREFIX}/${PHPMYFAQDIR}/pdf/
+ #set the correct permissions
+ @${CHMOD} 777 ${PREFIX}/${PHPMYFAQDIR}/inc/
+ @${CHMOD} 777 ${PREFIX}/${PHPMYFAQDIR}/attachment/
+ @${CHMOD} 777 ${PREFIX}/${PHPMYFAQDIR}/data/
+ @${CHMOD} 777 ${PREFIX}/${PHPMYFAQDIR}/images/
+ @${CHMOD} 777 ${PREFIX}/${PHPMYFAQDIR}/pdf/
+ @${CHMOD} 777 ${PREFIX}/${PHPMYFAQDIR}/xml/
+
+post-install:
+ @${SED} \
+ -e 's|%%DELETEFILES%%|${EXCEPTFILES}|' \
+ -e 's|%%PHPMYFAQURL%%|${PHPMYFAQURL}|' \
+ -e 's|%%PHPMYFAQDIR%%|${PREFIX}/${PHPMYFAQDIR}|' ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/phpmyfaq/distinfo b/www/phpmyfaq/distinfo
new file mode 100644
index 000000000000..b6cd506db5ad
--- /dev/null
+++ b/www/phpmyfaq/distinfo
@@ -0,0 +1,2 @@
+MD5 (phpmyfaq.1.4.8.full.zip) = 8bedaf800505a784de24de9b70acdcd7
+SIZE (phpmyfaq.1.4.8.full.zip) = 737145
diff --git a/www/phpmyfaq/pkg-descr b/www/phpmyfaq/pkg-descr
new file mode 100644
index 000000000000..9eb05cf0ee20
--- /dev/null
+++ b/www/phpmyfaq/pkg-descr
@@ -0,0 +1,10 @@
+phpMyFAQ is a multilingual, completely database-driven FAQ-system. It
+supports various databases to store all data, PHP 4.1.0 (or higher) is
+needed in order to access this data. phpMyFAQ also offers a Content
+Management-System with a WYSIWYG editor and an Image Manager, flexible
+multi-user support with LDAP support, a news-system, user-tracking, language
+modules, enhanced automatic content negotiation, templates, extensive
+XML-support, PDF-support, a backup-system and an easy to use installation
+script.
+
+WWW: http://www.phpmyfaq.de/
diff --git a/www/phpmyfaq/pkg-message b/www/phpmyfaq/pkg-message
new file mode 100644
index 000000000000..554c094fd847
--- /dev/null
+++ b/www/phpmyfaq/pkg-message
@@ -0,0 +1,22 @@
+----------------------------------------------------------------------------
+ phpMyFAQ has been installed, but is not quite ready to be used yet!
+
+ You have to ensure that you have a database server (or ODBC access to a
+ remote database) installed and configured, and you have to ensure that
+ your PHP installation has been compiled with support for your database or
+ database access method.
+
+ To configure phpMyFAQ point your browser to
+ http://localhost/%%PHPMYFAQURL%%/install/index.php
+ http://localhost/%%PHPMYFAQURL%%/admin/index.php
+
+ Use the username admin and your selected password
+ for your first login into the admin section.
+
+ After configuring phpMyFAQ and ensuring that it is operational,
+ you MUST delete the following files manually for security purposes
+ from %%PHPMYFAQDIR%%:
+
+ %%DELETEFILES%%
+
+----------------------------------------------------------------------------
diff --git a/www/phpmyfaq/pkg-plist b/www/phpmyfaq/pkg-plist
new file mode 100644
index 000000000000..d0ac09258d04
--- /dev/null
+++ b/www/phpmyfaq/pkg-plist
@@ -0,0 +1 @@
+@comment real PLIST will be generated in pre-install phase