aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2010-08-25 21:42:26 +0800
committerbrooks <brooks@FreeBSD.org>2010-08-25 21:42:26 +0800
commit940ebfef02017e23014a2c1645467c18041550eb (patch)
treec85b29f47e36536e15ea9fbdd559eb10a8369fc0 /www
parentc665596688d4f1912d4afed6f1cd23ad50cbf59d (diff)
downloadfreebsd-ports-gnome-940ebfef02017e23014a2c1645467c18041550eb.tar.gz
freebsd-ports-gnome-940ebfef02017e23014a2c1645467c18041550eb.tar.zst
freebsd-ports-gnome-940ebfef02017e23014a2c1645467c18041550eb.zip
This plugin provides downloads section which may contain releases or
other files. It is administrated via WebAdminPlugin and there is an interface to the trac-admin tool that may help during automatic server maintenance. The Downloads section of Trac displays a table with information about the uploaded files such as description, component, version, size, architecture, type and optionally assigned tags which the download is related to. It also collects information about number of downloads which can be displayed on wiki page together with direct links to the specified download. WWW: http://trac-hacks.org/wiki/DownloadsPlugin
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/trac-downloads/Makefile43
-rw-r--r--www/trac-downloads/distinfo3
-rw-r--r--www/trac-downloads/pkg-descr11
4 files changed, 58 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 40345390396a..eef252ef7c5d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1667,6 +1667,7 @@
SUBDIR += trac-datefield
SUBDIR += trac-discussion
SUBDIR += trac-down
+ SUBDIR += trac-downloads
SUBDIR += trac-email2trac
SUBDIR += trac-estimator
SUBDIR += trac-fivestarvote
diff --git a/www/trac-downloads/Makefile b/www/trac-downloads/Makefile
new file mode 100644
index 000000000000..80131a3ae58d
--- /dev/null
+++ b/www/trac-downloads/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: trac-mercurial
+# Date created: January 23, 2009
+# Whom: Brooks Davis <brooks@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${PYDISTUTILS_PKGNAME:S;^Trac;;:L}
+PORTVERSION= ${TRAC_VERSION}.${PLUGIN_VERSION}
+CATEGORIES= www devel python
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= brooks
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
+DIST_SUBDIR= trac
+
+MAINTAINER= brooks@freebsd.org
+COMMENT= A trac plugin providing a downloads section
+
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+
+TRAC_VERSION= 0.11
+PLUGIN_VERSION= 0.2
+
+USE_PYTHON= yes
+NO_BUILD= yes
+USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= TracDownloads
+PYDISTUTILS_NOEGGINFO= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/${PYDISTUTILS_PKGNAME}-${PLUGIN_VERSION}-py${PYTHON_VER}.egg
+
+.if defined(BOOTSTRAP)
+do-fetch:
+ ${MKDIR} ${WRKDIR}
+ svn export http://trac-hacks.org/svn/downloadsplugin/0.11/ ${WRKSRC}
+ ${MKDIR} ${_DISTDIR}
+ cd ${WRKDIR} && \
+ tar cfvz ${_DISTDIR}/${DISTNAME}.tar.gz ${DISTNAME}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/trac-downloads/distinfo b/www/trac-downloads/distinfo
new file mode 100644
index 000000000000..03bbe26027c2
--- /dev/null
+++ b/www/trac-downloads/distinfo
@@ -0,0 +1,3 @@
+MD5 (trac/downloadsplugin-0.11.0.2.tar.gz) = 4aef848025069533add7a21b207a3f4a
+SHA256 (trac/downloadsplugin-0.11.0.2.tar.gz) = 6a4557341619ea9b347b772f87d6a2a62c842a352c18c7f1963a9668a792713f
+SIZE (trac/downloadsplugin-0.11.0.2.tar.gz) = 14066
diff --git a/www/trac-downloads/pkg-descr b/www/trac-downloads/pkg-descr
new file mode 100644
index 000000000000..f9afd3d41f6a
--- /dev/null
+++ b/www/trac-downloads/pkg-descr
@@ -0,0 +1,11 @@
+This plugin provides downloads section which may contain releases or
+other files. It is administrated via WebAdminPlugin and there is an
+interface to the trac-admin tool that may help during automatic server
+maintenance. The Downloads section of Trac displays a table with
+information about the uploaded files such as description, component,
+version, size, architecture, type and optionally assigned tags which the
+download is related to. It also collects information about number of
+downloads which can be displayed on wiki page together with direct links
+to the specified download.
+
+WWW: http://trac-hacks.org/wiki/DownloadsPlugin