aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorfenner <fenner@FreeBSD.org>2000-08-31 07:09:34 +0800
committerfenner <fenner@FreeBSD.org>2000-08-31 07:09:34 +0800
commit98abbdb68d8b3099bd9a2f46d9ab4d5bcc3a09ca (patch)
tree6cd097e24eb51c68e4351360d7dd16139af2a6f8 /www
parent7a07ba5a45c30a4a6b971f5433fdbf34efe31fb9 (diff)
downloadfreebsd-ports-gnome-98abbdb68d8b3099bd9a2f46d9ab4d5bcc3a09ca.tar.gz
freebsd-ports-gnome-98abbdb68d8b3099bd9a2f46d9ab4d5bcc3a09ca.tar.zst
freebsd-ports-gnome-98abbdb68d8b3099bd9a2f46d9ab4d5bcc3a09ca.zip
Don't use ${APXS} if dso support isn't compiled in.
PR: ports/20911 Reviewed by: Jim Housley <jim@thehousleys.net>
Diffstat (limited to 'www')
-rw-r--r--www/mod_auth_mysql/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/www/mod_auth_mysql/Makefile b/www/mod_auth_mysql/Makefile
index a84b84bf3d92..5abf4e954c07 100644
--- a/www/mod_auth_mysql/Makefile
+++ b/www/mod_auth_mysql/Makefile
@@ -22,6 +22,9 @@ APXS= ${LOCALBASE}/sbin/apxs
AP_PORT?= apache13
.if exists(${APXS})
+APXS_WORKS!= ${APXS} -q TARGET 2>/dev/null || echo no
+.endif
+.if exists(${APXS}) && ${APXS_WORKS} != no
AP_TARGET!= ${APXS} -q TARGET
AP_SYSCONF!= ${APXS} -q SYSCONFDIR
AP_INCLUDE!= ${APXS} -q INCLUDEDIR