aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2015-08-19 10:30:25 +0800
committerpgollucci <pgollucci@FreeBSD.org>2015-08-19 10:30:25 +0800
commit9a151e059e08b73fe0624f31ca6113e98948bc41 (patch)
tree4e0a850b21e645bcf3b9c56260f802a903a54a0d /www
parent2011723b3354052f1d59d81103761b81d2edd693 (diff)
downloadfreebsd-ports-gnome-9a151e059e08b73fe0624f31ca6113e98948bc41.tar.gz
freebsd-ports-gnome-9a151e059e08b73fe0624f31ca6113e98948bc41.tar.zst
freebsd-ports-gnome-9a151e059e08b73fe0624f31ca6113e98948bc41.zip
www/qupzilla-qt4(-qt5): add some dependencies, qt4-linguist->qt4-linguisttools
- USE_QT4=linguist_build -> USE_QT4=linguisttools_build. - Add USE_OPENSSL=yes. - Add USE_XORG=x11 (or add NO_X11 instead). - Regenerate patches. - Bump PORTREVISION PR: 201835 Submitted by: s3erios@gmail.com Approved by: matthew@reztek.cz
Diffstat (limited to 'www')
-rw-r--r--www/qupzilla-qt5/Makefile2
-rw-r--r--www/qupzilla-qt5/files/patch-src__lib__3rdparty__processinfo.h8
2 files changed, 6 insertions, 4 deletions
diff --git a/www/qupzilla-qt5/Makefile b/www/qupzilla-qt5/Makefile
index eeec93b62275..3acf92ac6e12 100644
--- a/www/qupzilla-qt5/Makefile
+++ b/www/qupzilla-qt5/Makefile
@@ -20,6 +20,8 @@ USES= desktop-file-utils execinfo pkgconfig qmake tar:xz
USE_QT5= core concurrent gui network script webkit xml \
buildtools_build linguisttools_build \
imageformats_run sql-sqlite3_run
+USE_XORG= x11
+USE_OPENSSL= yes
CONFIGURE_ENV= QUPZILLA_PREFIX=${PREFIX}/
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
diff --git a/www/qupzilla-qt5/files/patch-src__lib__3rdparty__processinfo.h b/www/qupzilla-qt5/files/patch-src__lib__3rdparty__processinfo.h
index 5b4ece17f483..1eb22081140d 100644
--- a/www/qupzilla-qt5/files/patch-src__lib__3rdparty__processinfo.h
+++ b/www/qupzilla-qt5/files/patch-src__lib__3rdparty__processinfo.h
@@ -1,12 +1,12 @@
---- src/lib/3rdparty/processinfo.h.orig 2014-09-26 12:35:35.000000000 +0400
-+++ src/lib/3rdparty/processinfo.h 2014-09-26 23:04:10.000000000 +0400
+--- src/lib/3rdparty/processinfo.h.orig 2015-01-26 14:26:15 UTC
++++ src/lib/3rdparty/processinfo.h
@@ -18,16 +18,12 @@
#ifndef PROCESSINFO_H
#define PROCESSINFO_H
-#include <QtGlobal>
+#include "qzcommon.h"
-
+
#if defined(Q_OS_UNIX) && !defined(Q_OS_MAC)
#include <sys/types.h>
#endif
@@ -17,4 +17,4 @@
-
/*
* Code used from http://ubuntuforums.org/showpost.php?p=6593782&postcount=5
- * written by user WitchCraft
+ * written by user WitchCraft