aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2002-11-14 15:56:53 +0800
committeredwin <edwin@FreeBSD.org>2002-11-14 15:56:53 +0800
commitac7fd87fd65548361cd0232f9e536a14b41f3546 (patch)
tree525df2b911e42e7ef901686951d8f3191918e947 /www
parent3d0f7e6618502e0461dc349248c3c8208869a6a5 (diff)
downloadfreebsd-ports-gnome-ac7fd87fd65548361cd0232f9e536a14b41f3546.tar.gz
freebsd-ports-gnome-ac7fd87fd65548361cd0232f9e536a14b41f3546.tar.zst
freebsd-ports-gnome-ac7fd87fd65548361cd0232f9e536a14b41f3546.zip
Changed REINPLACE_CMD with SED since it needed to modify a file in files/
Noticed on: bento
Diffstat (limited to 'www')
-rw-r--r--www/knowledgekit/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/www/knowledgekit/Makefile b/www/knowledgekit/Makefile
index 9383d9659151..9287dea9074a 100644
--- a/www/knowledgekit/Makefile
+++ b/www/knowledgekit/Makefile
@@ -16,8 +16,6 @@ MAINTAINER= nbm@FreeBSD.org
RUN_DEPENDS= ${LOCALBASE}/${SZOPEBASEDIR}/z2.py:${PORTSDIR}/www/zope
-USE_REINPLACE= yes
-USE_PERL5= yes
NO_BUILD= YES
PKGMESSAGE= ${WRKDIR}/.MESSAGE
@@ -36,7 +34,8 @@ PLIST_SUB= ZOPEBASEDIR=${SZOPEBASEDIR}
do-install:
@${CP} ${WRKSRC}/* \
${ZOPEBASEDIR}/import
- @${REINPLACE_CMD} -e 's#%%PREFIX%%#${PREFIX}#; s#%%VER%%#${PORTVERSION}#' ${FILESDIR}/MESSAGE > ${PKGMESSAGE}
+ @${SED} -e 's#%%PREFIX%%#${PREFIX}#; s#%%VER%%#${PORTVERSION}#' \
+ ${FILESDIR}/MESSAGE > ${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>