aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2010-10-27 18:40:13 +0800
committerkevlo <kevlo@FreeBSD.org>2010-10-27 18:40:13 +0800
commitb190ef1546374982ad778e0f97c60e030ccf56e7 (patch)
tree95cae9b1af20b6011df36b21e5885e0438e2e925 /www
parentb74bfd6b251b88fb3963bbb9b68cba252cfdb19a (diff)
downloadfreebsd-ports-gnome-b190ef1546374982ad778e0f97c60e030ccf56e7.tar.gz
freebsd-ports-gnome-b190ef1546374982ad778e0f97c60e030ccf56e7.tar.zst
freebsd-ports-gnome-b190ef1546374982ad778e0f97c60e030ccf56e7.zip
Initial import of jinzora 3.0
Jinzora is the premiere web based media management system. It allows you to easily stream your media, both audio and video from your webserver to virtualy any media player that supports streaming (WMP, Winamp, Foobar, XMMS, iTunes, etc).
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/jinzora/Makefile46
-rw-r--r--www/jinzora/distinfo3
-rw-r--r--www/jinzora/files/pkg-message.in29
-rw-r--r--www/jinzora/pkg-descr6
5 files changed, 85 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 4f524e31b10a..3c33741dc987 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -340,6 +340,7 @@
SUBDIR += jesred
SUBDIR += jetspeed
SUBDIR += jetty
+ SUBDIR += jinzora
SUBDIR += joomla
SUBDIR += joomla15
SUBDIR += jspacker
diff --git a/www/jinzora/Makefile b/www/jinzora/Makefile
new file mode 100644
index 000000000000..f3817412c9bf
--- /dev/null
+++ b/www/jinzora/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: jinzora
+# Date created: 27 October 2010
+# Whom: Kevin Lo <kevlo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jinzora
+PORTVERSION= 3.0
+CATEGORIES= www multimedia
+MASTER_SITES= SF/${PORTNAME}/Jinzora%20${PORTVERSION}
+
+MAINTAINER= kevlo@FreeBSD.org
+COMMENT= A web based media streaming and management system
+
+USE_PHP= mysql session iconv gd pdf
+
+WWWDOCROOT?= www
+JINZORA?= ${PORTNAME}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+NO_BUILD= yes
+SUB_FILES= pkg-message
+SUB_LIST= JINZORA="${JINZORA}" \
+ JINZORA="${JINZORA}"
+
+JINZORADIR= ${WWWDOCROOT}/${JINZORA}
+
+do-install:
+ ${MKDIR} ${WWWDIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${WWWDIR}
+ @if [ ! -f ${WWWDIR}/settings.php ]; then \
+ ${TOUCH} ${WWWDIR}/settings.php ; fi
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+ ${CHMOD} 755 ${WWWDIR}/jukebox/settings.php
+ ${CHMOD} -R 755 ${WWWDIR}/temp
+ ${CHMOD} -R 755 ${WWWDIR}/data
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+ @${FIND} -s -d ${WWWDIR} -type f -print | \
+ ${SED} -e "s#${PREFIX}/##g" >> ${TMPPLIST}
+ @${FIND} -s -d ${WWWDIR} -type d -print | \
+ ${SED} -E -e "s#${PREFIX}/#@dirrm #g" >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/www/jinzora/distinfo b/www/jinzora/distinfo
new file mode 100644
index 000000000000..3ab790e39bb7
--- /dev/null
+++ b/www/jinzora/distinfo
@@ -0,0 +1,3 @@
+MD5 (jinzora-3.0.tar.gz) = d6dff2efd2f9631b8aa36d02fbed996b
+SHA256 (jinzora-3.0.tar.gz) = 089556677d12bc30bc9c1bdfd653ae2a20b7b6d8387c884767813ca738cc2894
+SIZE (jinzora-3.0.tar.gz) = 2934776
diff --git a/www/jinzora/files/pkg-message.in b/www/jinzora/files/pkg-message.in
new file mode 100644
index 000000000000..02d9d7cf795c
--- /dev/null
+++ b/www/jinzora/files/pkg-message.in
@@ -0,0 +1,29 @@
+POST-INSTALL CONFIGURATION FOR jinzora
+=====================================
+
+1) Create a user and a database for jinzora to store all
+ its tables in (or choose an existing database).
+
+2) Add the following to your Apache configuration, and
+ restart the server:
+
+ ### Add the AcceptPathInfo directive only for Apache 2.0.30 or later.
+ Alias /jinzora %%WWWDIR%%/
+ AcceptPathInfo On
+ <Directory %%WWWDIR%%>
+ AllowOverride None
+ Order Allow,Deny
+ Allow from all
+ </Directory>
+
+3) Visit your jinzora site with a browser (i.e.,
+ http://your.server.com/jinzora/), and it will lead
+ you through creating a settings.php file and then
+ setting up jinzora.
+
+For more information, see the INSTALL DOCUMENTATION:
+
+
+http://www.jinzorahelp.com/documentation
+
+=====================================
diff --git a/www/jinzora/pkg-descr b/www/jinzora/pkg-descr
new file mode 100644
index 000000000000..2a99fe3c8504
--- /dev/null
+++ b/www/jinzora/pkg-descr
@@ -0,0 +1,6 @@
+Jinzora is the premiere web based media management system.
+It allows you to easily stream your media, both audio and video
+from your webserver to virtualy any media player that supports
+streaming (WMP, Winamp, Foobar, XMMS, iTunes, etc).
+
+WWW: http://www.jinzora.com/