aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2013-12-21 05:55:01 +0800
committerthierry <thierry@FreeBSD.org>2013-12-21 05:55:01 +0800
commitb4af81d691cba6f22746d45da6ea5c694b2f6a75 (patch)
tree57688bba6d837a998d2a2f5c5306a612469fa74b /www
parent7b3ffcde72073fd12e58d4ac1b35b904715cb024 (diff)
downloadfreebsd-ports-gnome-b4af81d691cba6f22746d45da6ea5c694b2f6a75.tar.gz
freebsd-ports-gnome-b4af81d691cba6f22746d45da6ea5c694b2f6a75.tar.zst
freebsd-ports-gnome-b4af81d691cba6f22746d45da6ea5c694b2f6a75.zip
- Upgrade to 1.11
Changelog at <http://tt-rss.org/redmine/versions/97> - Support options and stage.
Diffstat (limited to 'www')
-rw-r--r--www/tt-rss/Makefile61
-rw-r--r--www/tt-rss/distinfo4
-rw-r--r--www/tt-rss/pkg-plist24
3 files changed, 49 insertions, 40 deletions
diff --git a/www/tt-rss/Makefile b/www/tt-rss/Makefile
index 84967be589d6..eda4ad94ae8d 100644
--- a/www/tt-rss/Makefile
+++ b/www/tt-rss/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tt-rss
-PORTVERSION= 1.10
+PORTVERSION= 1.11
CATEGORIES= www
MAINTAINER= thierry@FreeBSD.org
@@ -13,19 +13,29 @@ LICENSE= GPLv2
USE_GITHUB= yes
GH_ACCOUNT= gothfox
GH_PROJECT= Tiny-Tiny-RSS
-GH_COMMIT= 02b0d14
+GH_COMMIT= c04fbe3
NO_BUILD= yes
-NO_STAGE= yes
USE_PHP= ctype dom hash json mbstring pcntl posix session xmlrpc
WANT_PHP_WEB= yes
WANT_PHP_CLI= yes
REINPLACE_ARGS= -i ""
+USES= shebangfix
+SHEBANG_FILES= lib/dojo-src/rebuild-dojo.sh utils/extract-i18n-js.pl
USE_RC_SUBR= ttrssd
-.if defined(WITH_PGSQL)
+OPTIONS_DEFINE= CURL GD
+OPTIONS_SINGLE= DB
+OPTIONS_SINGLE_DB= MYSQL PGSQL
+OPTIONS_DEFAULT= CURL GD MYSQL
+CURL_DESC= Use SimplePie instead of Magpie
+GD_DESC= Use OTP QR code generation
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MPGSQL}
USE_PHP+= pgsql
DB= pgsql
.else
@@ -33,28 +43,23 @@ USE_PHP+= mysql
DB= mysql
.endif
-.if !defined(WITHOUT_CURL)
+.if ${PORT_OPTIONS:MCURL}
USE_PHP+= curl
.endif
+.if ${PORT_OPTIONS:MGD}
+USE_PHP+= gd
+.endif
+
SUB_FILES= httpd-tt-rss.conf pkg-message
SUB_LIST= DB=${DB} WWWOWN=${WWWOWN}
-PLIST_SUB= WWWOWN=${WWWOWN}:${WWWGRP}
+PLIST_SUB= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
PKGMESSAGE= ${WRKDIR}/pkg-message
PHP2FIX= config.php-dist update.php update_daemon2.php
SCRIPTS= update.php update_daemon2.php
-pre-everything::
- @${ECHO_MSG}
- @${ECHO_MSG} " By default, Tiny Tiny RSS will use MySQL as a back-end;"
- @${ECHO_MSG} " define WITH_PGSQL if you prefer PostgreSQL."
- @${ECHO_MSG}
- @${ECHO_MSG} " CURL is required for SimplePie, but if you prefer Magpie,"
- @${ECHO_MSG} " you can define WITHOUT_CURL."
- @${ECHO_MSG}
-
pre-configure:
.for script in ${PHP2FIX}
${REINPLACE_CMD} -e 's|/usr/bin/php|${LOCALBASE}/bin/php|' \
@@ -63,29 +68,17 @@ pre-configure:
.endfor
do-configure:
-.if !defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
${REINPLACE_CMD} -e '/DB_TYPE/s|pgsql|mysql|;s|mysql$$|pgsql|' \
${WRKSRC}/config.php-dist
.endif
do-install:
- ${MKDIR} ${WWWDIR} ${DATADIR}
- (cd ${WRKSRC} && ${COPYTREE_SHARE} "*" ${WWWDIR} "! -name LICENSE")
- ${RM} -rf ${WWWDIR}/debian
- ${MKDIR} ${WWWDIR}/icons/ # Not used for fresh installation
- ${TOUCH} ${WWWDIR}/icons/.empty
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
- ${CHMOD} ug+x ${SCRIPTS:S|^|${WWWDIR}/|}
- ${CHMOD} ug+x ${WWWDIR}/utils/*.sh ${WWWDIR}/utils/*.pl
- ${INSTALL_DATA} ${WRKDIR}/httpd-tt-rss.conf ${DATADIR}
- if [ ! -f ${WWWDIR}/config.php ]; then \
- ${CP} -p ${WWWDIR}/config.php-dist ${WWWDIR}/config.php; \
- ${CHMOD} go-r ${WWWDIR}/config.php; \
- fi
-
-post-install:
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
+ ${MKDIR} ${STAGEDIR}${WWWDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "*" ${STAGEDIR}${WWWDIR} "! -name LICENSE")
+ ${RM} -rf ${STAGEDIR}${WWWDIR}/debian
+ ${MKDIR} ${STAGEDIR}${WWWDIR}/icons/ # Not used for fresh installation
+ ${TOUCH} ${STAGEDIR}${WWWDIR}/icons/.empty
+ ${INSTALL_DATA} ${WRKDIR}/httpd-tt-rss.conf ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>
diff --git a/www/tt-rss/distinfo b/www/tt-rss/distinfo
index 3471da059127..e72de5b92bbb 100644
--- a/www/tt-rss/distinfo
+++ b/www/tt-rss/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tt-rss-1.10.tar.gz) = d823cabcabf07f51f2446618a9da3691072889e748f61ee890217767fea29f20
-SIZE (tt-rss-1.10.tar.gz) = 2535158
+SHA256 (tt-rss-1.11.tar.gz) = babf4291d2cbe5c4a9c7e177bbe60792ba2737660ea6420b0994190a230343db
+SIZE (tt-rss-1.11.tar.gz) = 2586798
diff --git a/www/tt-rss/pkg-plist b/www/tt-rss/pkg-plist
index c120138dc013..6a41d61219ee 100644
--- a/www/tt-rss/pkg-plist
+++ b/www/tt-rss/pkg-plist
@@ -1,4 +1,6 @@
%%DATADIR%%/httpd-tt-rss.conf
+@owner %%WWWOWN%%
+@group %%WWWGRP%%
%%WWWDIR%%/README.md
%%WWWDIR%%/api/index.php
%%WWWDIR%%/atom-to-html.xsl
@@ -2030,6 +2032,8 @@
%%WWWDIR%%/locale/ru_RU/LC_MESSAGES/messages.po
%%WWWDIR%%/locale/sv_SE/LC_MESSAGES/messages.mo
%%WWWDIR%%/locale/sv_SE/LC_MESSAGES/messages.po
+%%WWWDIR%%/locale/tr_TR/LC_MESSAGES/messages.mo
+%%WWWDIR%%/locale/tr_TR/LC_MESSAGES/messages.po
%%WWWDIR%%/locale/zh_CN/LC_MESSAGES/messages.mo
%%WWWDIR%%/locale/zh_CN/LC_MESSAGES/messages.po
%%WWWDIR%%/lock/.empty
@@ -2040,11 +2044,13 @@
%%WWWDIR%%/plugins/af_buttersafe/init.php
%%WWWDIR%%/plugins/af_dilbert/init.php
%%WWWDIR%%/plugins/af_explosm/init.php
+%%WWWDIR%%/plugins/af_fsckportal/init.php
%%WWWDIR%%/plugins/af_gocomics/init.php
%%WWWDIR%%/plugins/af_natgeo/init.php
%%WWWDIR%%/plugins/af_pennyarcade/init.php
%%WWWDIR%%/plugins/af_redditimgur/init.php
%%WWWDIR%%/plugins/af_sciam/init.php
+%%WWWDIR%%/plugins/af_threewordphrase/init.php
%%WWWDIR%%/plugins/af_unburn/init.php
%%WWWDIR%%/plugins/af_whomp/init.php
%%WWWDIR%%/plugins/auth_internal/init.php
@@ -2075,6 +2081,8 @@
%%WWWDIR%%/plugins/no_iframes/init.php
%%WWWDIR%%/plugins/no_title_counters/init.js
%%WWWDIR%%/plugins/no_title_counters/init.php
+%%WWWDIR%%/plugins/no_url_hashes/init.js
+%%WWWDIR%%/plugins/no_url_hashes/init.php
%%WWWDIR%%/plugins/note/init.php
%%WWWDIR%%/plugins/note/note.js
%%WWWDIR%%/plugins/note/note.png
@@ -2349,16 +2357,17 @@
%%WWWDIR%%/templates/resetpass_template.txt
%%WWWDIR%%/themes/.empty
%%WWWDIR%%/themes/default.css
+@mode u=rx
%%WWWDIR%%/update.php
%%WWWDIR%%/update_daemon2.php
+@mode
%%WWWDIR%%/utils/.htaccess
-%%WWWDIR%%/utils/extract-i18n-js.pl
%%WWWDIR%%/utils/localized_schema.txt
+@mode u=rx
+%%WWWDIR%%/utils/extract-i18n-js.pl
%%WWWDIR%%/utils/regen_config_checks.sh
%%WWWDIR%%/utils/update-translations.sh
-@exec chmod -R 777 %B
-@exec chmod 444 %D/%F
-@exec chown -R %%WWWOWN%% %D/%%WWWDIR%%
+@mode
@dirrm %%WWWDIR%%/utils
@dirrm %%WWWDIR%%/themes
@dirrm %%WWWDIR%%/templates
@@ -2372,6 +2381,7 @@
@dirrm %%WWWDIR%%/plugins/shorten_expanded
@dirrm %%WWWDIR%%/plugins/share
@dirrm %%WWWDIR%%/plugins/nsfw
+@dirrm %%WWWDIR%%/plugins/no_url_hashes
@dirrm %%WWWDIR%%/plugins/note
@dirrm %%WWWDIR%%/plugins/no_title_counters
@dirrm %%WWWDIR%%/plugins/no_iframes
@@ -2390,11 +2400,13 @@
@dirrm %%WWWDIR%%/plugins/auth_internal
@dirrm %%WWWDIR%%/plugins/af_whomp
@dirrm %%WWWDIR%%/plugins/af_unburn
+@dirrm %%WWWDIR%%/plugins/af_threewordphrase
@dirrm %%WWWDIR%%/plugins/af_sciam
@dirrm %%WWWDIR%%/plugins/af_redditimgur
@dirrm %%WWWDIR%%/plugins/af_pennyarcade
@dirrm %%WWWDIR%%/plugins/af_natgeo
@dirrm %%WWWDIR%%/plugins/af_gocomics
+@dirrm %%WWWDIR%%/plugins/af_fsckportal
@dirrm %%WWWDIR%%/plugins/af_explosm
@dirrm %%WWWDIR%%/plugins/af_dilbert
@dirrm %%WWWDIR%%/plugins/af_buttersafe
@@ -2403,6 +2415,8 @@
@dirrmtry %%WWWDIR%%/lock
@dirrm %%WWWDIR%%/locale/zh_CN/LC_MESSAGES
@dirrm %%WWWDIR%%/locale/zh_CN
+@dirrm %%WWWDIR%%/locale/tr_TR/LC_MESSAGES
+@dirrm %%WWWDIR%%/locale/tr_TR
@dirrm %%WWWDIR%%/locale/sv_SE/LC_MESSAGES
@dirrm %%WWWDIR%%/locale/sv_SE
@dirrm %%WWWDIR%%/locale/ru_RU/LC_MESSAGES
@@ -2708,4 +2722,6 @@
@dirrmtry %%WWWDIR%%/cache
@dirrm %%WWWDIR%%/api
@dirrmtry %%WWWDIR%%
+@owner
+@group
@dirrm %%DATADIR%%