aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2015-08-28 23:22:34 +0800
committerkoobs <koobs@FreeBSD.org>2015-08-28 23:22:34 +0800
commitb5a16491d54740b9cb9ff9454049f61f2706218f (patch)
tree0af95674daf27ed43c991a3eff1a962f59dce41f /www
parent0139f9470745348b6074e34187939e84e47911b4 (diff)
downloadfreebsd-ports-gnome-b5a16491d54740b9cb9ff9454049f61f2706218f.tar.gz
freebsd-ports-gnome-b5a16491d54740b9cb9ff9454049f61f2706218f.tar.zst
freebsd-ports-gnome-b5a16491d54740b9cb9ff9454049f61f2706218f.zip
www/pelican: Prefix according to Python conventions
- Rename (move) according to Python package naming conventions [1] - Switch temporarily to GITHUB for source files until missing content files for the test suite is merged/fixed [2] - Add python (virtual category) to CATEGORIES - Add LICENSE_FILE - Add OPTIONS for Markdown and Syntax Highlighting, they are OPTION'al features - Add MARKDOWN and SYNTAX to OPTIONS_DEFAULT (for package convenience). - Use OPTIONS helpers for TESTS option. - Refactor TEST_DEPENDS so it only declares tests_require, moving the RUN_DEPENDS assignment to TESTS_BUILD_DEPENDS. - Rename TEST option to TESTS to match other Python ports, and tweak description to canonicalize - Deprecate OPTIONSFILE override (no longer necessary) - Canonicalize regression-test target, so it gets the setuptools wrapped setup.py arguments for proper 'test' command support. - Re-order makefile sections (DEPENDS|USES|OPTIONS) While here: - Add MOVED entry - Update www/Makefile [1] https://wiki.freebsd.org/Python/PortsPolicy [2] https://github.com/getpelican/pelican/pull/1793 Reviewed by: jlaffaye (maintainer) Approved by: jlaffaye (maintainer) Differential Revision: https://reviews.freebsd.org/D3328
Diffstat (limited to 'www')
-rw-r--r--www/Makefile2
-rw-r--r--www/pelican/distinfo2
-rw-r--r--www/py-pelican/Makefile (renamed from www/pelican/Makefile)31
-rw-r--r--www/py-pelican/distinfo2
-rw-r--r--www/py-pelican/pkg-descr (renamed from www/pelican/pkg-descr)0
5 files changed, 20 insertions, 17 deletions
diff --git a/www/Makefile b/www/Makefile
index 6b655d72490d..6850bcf0cad7 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1434,7 +1434,6 @@
SUBDIR += pecl-yaf
SUBDIR += pecl-yar
SUBDIR += pecl-zendopcache
- SUBDIR += pelican
SUBDIR += perlbal
SUBDIR += pglogd
SUBDIR += phalcon
@@ -1618,6 +1617,7 @@
SUBDIR += py-paste
SUBDIR += py-pastedeploy
SUBDIR += py-pastescript
+ SUBDIR += py-pelican
SUBDIR += py-plone.alterego
SUBDIR += py-plone.app.blob
SUBDIR += py-plone.app.caching
diff --git a/www/pelican/distinfo b/www/pelican/distinfo
deleted file mode 100644
index 425ac730114f..000000000000
--- a/www/pelican/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (pelican-3.6.3.tar.gz) = 13b9c41ea3342b7eb0fd7f74078b5a8d5035632f05d8680266f50f4c5626c9c2
-SIZE (pelican-3.6.3.tar.gz) = 264389
diff --git a/www/pelican/Makefile b/www/py-pelican/Makefile
index 4b78cbc87fc0..d52ebdbcfcb3 100644
--- a/www/pelican/Makefile
+++ b/www/py-pelican/Makefile
@@ -3,40 +3,43 @@
PORTNAME= pelican
PORTVERSION= 3.6.3
-CATEGORIES= www textproc
-MASTER_SITES= CHEESESHOP
+CATEGORIES= www textproc python
MAINTAINER= jlaffaye@FreeBSD.org
COMMENT= Static site generator written in Python
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= rst2html:${PORTSDIR}/textproc/py-docutils \
- ${PYTHON_PKGNAMEPREFIX}markdown>0:${PORTSDIR}/textproc/py-markdown \
${PYTHON_PKGNAMEPREFIX}Jinja2>=2.7:${PORTSDIR}/devel/py-Jinja2 \
- ${PYTHON_PKGNAMEPREFIX}pygments>=1.4:${PORTSDIR}/textproc/py-pygments \
${PYTHON_PKGNAMEPREFIX}feedgenerator>=1.6:${PORTSDIR}/www/py-feedgenerator \
${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz \
${PYTHON_PKGNAMEPREFIX}blinker>0:${PORTSDIR}/devel/py-blinker \
${PYTHON_PKGNAMEPREFIX}unidecode>0:${PORTSDIR}/converters/py-unidecode \
${PYTHON_PKGNAMEPREFIX}six>=1.4:${PORTSDIR}/devel/py-six \
${PYTHON_PKGNAMEPREFIX}dateutil>0:${PORTSDIR}/devel/py-dateutil
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock
-TEST_DEPENDS:= ${RUN_DEPENDS} \
- ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock \
+USES= python
+USE_GITHUB= yes
+USE_PYTHON= autoplist distutils
-OPTIONS_DEFINE= TEST
+GH_ACCOUNT= getpelican
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= MARKDOWN SYNTAX TESTS
+OPTIONS_DEFAULT= MARKDOWN SYNTAX
-USES=python
-USE_PYTHON=autoplist distutils
+MARKDOWN_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}markdown>0:${PORTSDIR}/textproc/py-markdown
-.if ${PORT_OPTIONS:MTEST}
-BUILD_DEPENDS:= ${TEST_DEPENDS}
-.endif
+SYNTAX_DESC= Syntax Highlighting (via pygments)
+SYNTAX_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygments>=1.4:${PORTSDIR}/textproc/py-pygments
+
+TESTS_DESC= Install test suite requirements
+TESTS_BUILD_DEPENDS= ${TEST_DEPENDS} \
+ ${RUN_DEPENDS}
regression-test: build
- @cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>
diff --git a/www/py-pelican/distinfo b/www/py-pelican/distinfo
new file mode 100644
index 000000000000..dc41d7e0bc66
--- /dev/null
+++ b/www/py-pelican/distinfo
@@ -0,0 +1,2 @@
+SHA256 (getpelican-pelican-3.6.3_GH0.tar.gz) = d19bc7df61afc5b68eba028f0cf0832ee2a12a04a01d7fe11bdfdd847ddd417b
+SIZE (getpelican-pelican-3.6.3_GH0.tar.gz) = 775060
diff --git a/www/pelican/pkg-descr b/www/py-pelican/pkg-descr
index 398b0de28b74..398b0de28b74 100644
--- a/www/pelican/pkg-descr
+++ b/www/py-pelican/pkg-descr