aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2006-10-01 01:49:10 +0800
committerbsam <bsam@FreeBSD.org>2006-10-01 01:49:10 +0800
commitbe6cbd9e6d8cb5c77316d97bb7babc9f5b0feff7 (patch)
tree9a2c49c14b99a2276d35ea645190438826b32eb4 /www
parent36c7bc784c0259bc8d6d57a7aed3f9d4b954f2ae (diff)
downloadfreebsd-ports-gnome-be6cbd9e6d8cb5c77316d97bb7babc9f5b0feff7.tar.gz
freebsd-ports-gnome-be6cbd9e6d8cb5c77316d97bb7babc9f5b0feff7.tar.zst
freebsd-ports-gnome-be6cbd9e6d8cb5c77316d97bb7babc9f5b0feff7.zip
Flash Operator Panel is a switchboard type application for the Asterisk PBX.
It runs on a web browser with the flash plugin. It is able to display information about your PBX activity in real time. WWW: http://www.asternic.org/ - Marcelo Araujo araujo@bsdmail.org PR: ports/103838 Submitted by: Marcelo Araujo <araujo at bsdmail.org>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/asterisk-fop/Makefile33
-rw-r--r--www/asterisk-fop/distinfo3
-rw-r--r--www/asterisk-fop/pkg-descr8
-rw-r--r--www/asterisk-fop/pkg-plist86
5 files changed, 131 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 0e9fa301f19d..81b69dd53037 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -31,6 +31,7 @@
SUBDIR += aria2
SUBDIR += ashe
SUBDIR += asp2php
+ SUBDIR += asterisk-fop
SUBDIR += aswedit
SUBDIR += aswiki
SUBDIR += august
diff --git a/www/asterisk-fop/Makefile b/www/asterisk-fop/Makefile
new file mode 100644
index 000000000000..e685480c7cac
--- /dev/null
+++ b/www/asterisk-fop/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: asterisk-fop
+# Date created: 22 Sep 2006
+# Whom: Marcelo Araujo <araujo@bsdmail.org>
+#
+# $FreeBSD$
+
+PORTNAME= op_panel
+PORTVERSION= 0.26
+CATEGORIES= www
+MASTER_SITES= http://www.asternic.org/files/
+
+MAINTAINER= araujo@bsdmail.org
+COMMENT= Flash Operator Panel for the Asterisk PBX
+
+NO_BUILD= yes
+USE_PERL5= yes
+USE_PHP= pcre zlib session xml gd
+WANT_PHP_WEB= yes
+
+LIB_DEPENDS+= flash.0:${PORTSDIR}/www/flashplugin-mozilla \
+ ming.4:${PORTSDIR}/graphics/p5-ming
+
+WEBOWN?= www
+WEBGRP?= www
+APACHEDIR= ${LOCALBASE}/www
+INSTALLDIR= ${APACHEDIR}/${PORTNAME}
+
+do-install:
+ ${MKDIR} ${INSTALLDIR}
+ cd ${WRKSRC}; ${FIND} . \
+ | ${CPIO} -pdm -R ${WEBOWN}:${WEBGRP} ${INSTALLDIR}
+
+.include <bsd.port.mk>
diff --git a/www/asterisk-fop/distinfo b/www/asterisk-fop/distinfo
new file mode 100644
index 000000000000..b37fc811d672
--- /dev/null
+++ b/www/asterisk-fop/distinfo
@@ -0,0 +1,3 @@
+MD5 (op_panel-0.26.tar.gz) = 54b4f328c11172cbe0be3361c2a3160c
+SHA256 (op_panel-0.26.tar.gz) = 1f3e4ea76618b583a5cdaf8bddf44a3f8f7288703fac7c46c3968dba34061f58
+SIZE (op_panel-0.26.tar.gz) = 323886
diff --git a/www/asterisk-fop/pkg-descr b/www/asterisk-fop/pkg-descr
new file mode 100644
index 000000000000..c0b875ceeed8
--- /dev/null
+++ b/www/asterisk-fop/pkg-descr
@@ -0,0 +1,8 @@
+Flash Operator Panel is a switchboard type application for the Asterisk PBX.
+It runs on a web browser with the flash plugin.
+It is able to display information about your PBX activity in real time.
+
+WWW: http://www.asternic.org/
+
+- Marcelo Araujo
+araujo@bsdmail.org
diff --git a/www/asterisk-fop/pkg-plist b/www/asterisk-fop/pkg-plist
new file mode 100644
index 000000000000..0f27d0f9ea79
--- /dev/null
+++ b/www/asterisk-fop/pkg-plist
@@ -0,0 +1,86 @@
+www/op_panel/CHANGES
+www/op_panel/FAQ
+www/op_panel/LICENSE
+www/op_panel/README
+www/op_panel/RECIPES
+www/op_panel/TODO
+www/op_panel/UPGRADE
+www/op_panel/dhtml/comunicator.pl
+www/op_panel/dhtml/comunicator.swf
+www/op_panel/dhtml/css/default.css
+www/op_panel/dhtml/css/operator.css
+www/op_panel/dhtml/images/bottom_left.gif
+www/op_panel/dhtml/images/bottom_mid.gif
+www/op_panel/dhtml/images/bottom_right.gif
+www/op_panel/dhtml/images/bottom_right_resize.gif
+www/op_panel/dhtml/images/bug.png
+www/op_panel/dhtml/images/center_left.gif
+www/op_panel/dhtml/images/center_right.gif
+www/op_panel/dhtml/images/close.gif
+www/op_panel/dhtml/images/email.png
+www/op_panel/dhtml/images/group.png
+www/op_panel/dhtml/images/mail.gif
+www/op_panel/dhtml/images/overlay.png
+www/op_panel/dhtml/images/phone.png
+www/op_panel/dhtml/images/phone_sound.png
+www/op_panel/dhtml/images/resize.gif
+www/op_panel/dhtml/images/sizer.gif
+www/op_panel/dhtml/images/status_online.png
+www/op_panel/dhtml/images/telephone.png
+www/op_panel/dhtml/images/telephone_go.png
+www/op_panel/dhtml/images/top_left.gif
+www/op_panel/dhtml/images/top_mid.gif
+www/op_panel/dhtml/images/top_right.gif
+www/op_panel/dhtml/index.php
+www/op_panel/dhtml/js/base64.js
+www/op_panel/dhtml/js/builder.js
+www/op_panel/dhtml/js/controls.js
+www/op_panel/dhtml/js/dhtmltooltip.js
+www/op_panel/dhtml/js/dragdrop.js
+www/op_panel/dhtml/js/effects.js
+www/op_panel/dhtml/js/operator.js
+www/op_panel/dhtml/js/prototype.js
+www/op_panel/dhtml/js/scriptaculous.js
+www/op_panel/dhtml/js/slider.js
+www/op_panel/dhtml/js/window.js
+www/op_panel/dhtml/variables.php
+www/op_panel/extensions.conf.sample
+www/op_panel/flash/help_de.html
+www/op_panel/flash/help_en.html
+www/op_panel/flash/help_es.html
+www/op_panel/flash/help_fr.html
+www/op_panel/flash/help_it.html
+www/op_panel/flash/help_se.html
+www/op_panel/flash/index-clicktodial.html
+www/op_panel/flash/index-crm.html
+www/op_panel/flash/index-fixed.html
+www/op_panel/flash/index-restrict.html
+www/op_panel/flash/index.html
+www/op_panel/flash/mypage.php
+www/op_panel/flash/operator_panel.swf
+www/op_panel/init/op_panel_debian.sh
+www/op_panel/init/op_panel_redhat.sh
+www/op_panel/init/op_panel_suse.sh
+www/op_panel/ming-source/README
+www/op_panel/ming-source/operator_panel.pl
+www/op_panel/op_astdb.cfg
+www/op_panel/op_buttons.cfg
+www/op_panel/op_lang_ca.cfg
+www/op_panel/op_lang_de.cfg
+www/op_panel/op_lang_en.cfg
+www/op_panel/op_lang_es.cfg
+www/op_panel/op_lang_fr.cfg
+www/op_panel/op_lang_it.cfg
+www/op_panel/op_lang_se.cfg
+www/op_panel/op_server.cfg
+www/op_panel/op_server.pl
+www/op_panel/op_style.cfg
+
+@dirrm www/op_panel/dhtml/css
+@dirrm www/op_panel/dhtml/images
+@dirrm www/op_panel/dhtml/js
+@dirrm www/op_panel/dhtml
+@dirrm www/op_panel/flash
+@dirrm www/op_panel/init
+@dirrm www/op_panel/ming-source
+@dirrm www/op_panel