aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-11-05 18:43:16 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-11-05 18:43:16 +0800
commitc821055aa9fa944ab3e9ccb8a9e6a16183e9c3e3 (patch)
tree96ba6e2275ecb1977dc8e6d770de7d3c39bbc37c /www
parent77b60e111580225bce01556fc43f78b2bb2e4524 (diff)
downloadfreebsd-ports-gnome-c821055aa9fa944ab3e9ccb8a9e6a16183e9c3e3.tar.gz
freebsd-ports-gnome-c821055aa9fa944ab3e9ccb8a9e6a16183e9c3e3.tar.zst
freebsd-ports-gnome-c821055aa9fa944ab3e9ccb8a9e6a16183e9c3e3.zip
- Fix shebangs
- Add NO_ARCH - Switch to options helpers Approved by: portmgr blanket
Diffstat (limited to 'www')
-rw-r--r--www/p5-CGI_Lite/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/www/p5-CGI_Lite/Makefile b/www/p5-CGI_Lite/Makefile
index 56eeebb2ec94..935a47b5bc5e 100644
--- a/www/p5-CGI_Lite/Makefile
+++ b/www/p5-CGI_Lite/Makefile
@@ -3,6 +3,7 @@
PORTNAME= CGI-Lite
PORTVERSION= 3.00
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -13,17 +14,21 @@ COMMENT= Process and decode WWW forms and cookies
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= examples/*
USE_PERL5= configure
+NO_ARCH= yes
DOCS= CHANGES README TODO
EXAMPLES= cookies get_post print upload file post reference
OPTIONS_DEFINE= DOCS EXAMPLES
-post-install:
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
+
+post-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/examples && ${INSTALL_SCRIPT} ${EXAMPLES} ${STAGEDIR}${EXAMPLESDIR}