aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2010-10-28 17:37:55 +0800
committerkevlo <kevlo@FreeBSD.org>2010-10-28 17:37:55 +0800
commitc82965d1c0acddae424a6e28e2f2fa6e3a436281 (patch)
treefcd474a3dc7cfd35ac6b569e9413bc9d85a7c448 /www
parent93ba3860e5f53a6baf2eb9446959958521c643cd (diff)
downloadfreebsd-ports-gnome-c82965d1c0acddae424a6e28e2f2fa6e3a436281.tar.gz
freebsd-ports-gnome-c82965d1c0acddae424a6e28e2f2fa6e3a436281.tar.zst
freebsd-ports-gnome-c82965d1c0acddae424a6e28e2f2fa6e3a436281.zip
Initial import of kplaylist 1.8.505
kPlaylist is a free PHP system that makes your music collection available via the Internet. kPlaylist is a music database that you manage via the web. With kPlaylist you can stream your music (ogg, mp3, wav, wma, etc.), you can upload, make playlists, share, search, download and a lot more.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/kplaylist/Makefile35
-rw-r--r--www/kplaylist/distinfo3
-rw-r--r--www/kplaylist/files/patch-kplaylist.1.8.505.php20
-rw-r--r--www/kplaylist/pkg-descr7
5 files changed, 66 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 3c33741dc987..ad879cc9d627 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -355,6 +355,7 @@
SUBDIR += khtml2png
SUBDIR += knowledgekit
SUBDIR += kompozer
+ SUBDIR += kplaylist
SUBDIR += kwebkitpart
SUBDIR += larbin
SUBDIR += libapreq2
diff --git a/www/kplaylist/Makefile b/www/kplaylist/Makefile
new file mode 100644
index 000000000000..b93ca42860df
--- /dev/null
+++ b/www/kplaylist/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: kplaylist
+# Date created: 28 October 2010
+# Whom: Kevin Lo <kevlo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kplaylist
+PORTVERSION= 1.8.505
+CATEGORIES= www multimedia
+MASTER_SITES= http://www.kplaylist.net/archive.php?file=1.8.505&tar=true/
+DISTNAME= ${PORTNAME}.${PORTVERSION}
+
+MAINTAINER= kevlo@FreeBSD.org
+COMMENT= A PHP based music database
+
+RUN_DEPENDS= lame:${PORTSDIR}/audio/lame \
+ oggenc:${PORTSDIR}/audio/vorbis-tools \
+ zip:${PORTSDIR}/archivers/zip
+
+USE_PHP= curl mysql session iconv
+
+WRKSRC= ${WRKDIR}
+WWWDIR?= ${PREFIX}/www/${PORTNAME}
+NO_BUILD= yes
+
+PLIST_FILES= %%WWWDIR%%/index.php
+PLIST_DIRS= %%WWWDIR%%
+
+do-install:
+ ${MKDIR} ${WWWDIR}
+ @cd ${WRKSRC} && ${CP} kplaylist.1.8.505.php ${WWWDIR}/index.php
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+
+.include <bsd.port.mk>
diff --git a/www/kplaylist/distinfo b/www/kplaylist/distinfo
new file mode 100644
index 000000000000..1f7af55c5faf
--- /dev/null
+++ b/www/kplaylist/distinfo
@@ -0,0 +1,3 @@
+MD5 (kplaylist.1.8.505.tar.gz) = c5dded81bd14bf9b094c5700d4fc8a28
+SHA256 (kplaylist.1.8.505.tar.gz) = cdc4fa12d881732f535f93be5213ba4278c2650e956692df2dc375f8a906bb48
+SIZE (kplaylist.1.8.505.tar.gz) = 237854
diff --git a/www/kplaylist/files/patch-kplaylist.1.8.505.php b/www/kplaylist/files/patch-kplaylist.1.8.505.php
new file mode 100644
index 000000000000..448ea1105114
--- /dev/null
+++ b/www/kplaylist/files/patch-kplaylist.1.8.505.php
@@ -0,0 +1,20 @@
+--- kplaylist.1.8.505.php.orig 2010-10-28 16:21:51.000000000 +0800
++++ kplaylist.1.8.505.php 2010-10-28 16:27:03.000000000 +0800
+@@ -155,7 +155,7 @@
+ $cfg['lamecmd'] = '/usr/local/bin/lame --silent --nores --nohist --mp3input -h -m s -b %bitrate% "%file%" -';
+
+ // ogg command (transcode)
+-$cfg['oggcmd'] = '/usr/bin/oggdec -Q "%file%" -o - | /usr/bin/oggenc - --quiet --managed -b %bitrate% -o -';
++$cfg['oggcmd'] = '/usr/local/bin/oggdec -Q "%file%" -o - | /usr/local/bin/oggenc - --quiet --managed -b %bitrate% -o -';
+
+ // enable ogg transcoding, look the line above for the command, check this before enabling
+ $cfg['oggtranscode'] = false;
+@@ -166,7 +166,7 @@
+ // YOU MUST SUIT THESE ARCHIVERS TO YOUR OWN NEED. DO NOT USE THE DEFAULT BLINDLY.
+ $archivers = array();
+
+-$archivers[] = array(1, 'zip', '/usr/bin/zip -j -0 %D "%F"', 'application/zip', 'zip');
++$archivers[] = array(1, 'zip', '/usr/local/bin/zip -j -0 %D "%F"', 'application/zip', 'zip');
+ $archivers[] = array(1, 'tar','/bin/tar cf %D --files-from "%LIST"', 'application/x-tar', 'tar');
+ $archivers[] = array(0, 'rar', 'C:\Programfiler\WinRAR\rar.exe -m0 a %D "%F"', 'application/x-rar', 'rar');
+
diff --git a/www/kplaylist/pkg-descr b/www/kplaylist/pkg-descr
new file mode 100644
index 000000000000..47cb56722609
--- /dev/null
+++ b/www/kplaylist/pkg-descr
@@ -0,0 +1,7 @@
+kPlaylist is a free PHP system that makes your music collection
+available via the Internet.
+kPlaylist is a music database that you manage via the web. With kPlaylist
+you can stream your music (ogg, mp3, wav, wma, etc.), you can upload,
+make playlists, share, search, download and a lot more.
+
+WWW: http://www.kplaylist.net/