aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2008-03-19 13:26:22 +0800
committerdanfe <danfe@FreeBSD.org>2008-03-19 13:26:22 +0800
commitc99ec0b2357e227cc1bda470487fbf069778f78f (patch)
treec1a833b9cbcb07166a7ab1896ccbe170c0c0ce13 /www
parent42fe16adca562b06c4863fdc8d4f39159068f545 (diff)
downloadfreebsd-ports-gnome-c99ec0b2357e227cc1bda470487fbf069778f78f.tar.gz
freebsd-ports-gnome-c99ec0b2357e227cc1bda470487fbf069778f78f.tar.zst
freebsd-ports-gnome-c99ec0b2357e227cc1bda470487fbf069778f78f.zip
- Reformat Makefile header
- Unmute INSTALL_FOO statements - Other small Makefile cleanups - Take maintainership - Improve on port description
Diffstat (limited to 'www')
-rw-r--r--www/thttpd/Makefile44
-rw-r--r--www/thttpd/pkg-descr10
2 files changed, 25 insertions, 29 deletions
diff --git a/www/thttpd/Makefile b/www/thttpd/Makefile
index 8af6e5c1a5c9..920d7426c36d 100644
--- a/www/thttpd/Makefile
+++ b/www/thttpd/Makefile
@@ -1,6 +1,6 @@
# New ports collection makefile for: thttpd
-# Date created: 24 May 1999
-# Whom: Anders Nordby <anders@fix.no>
+# Date created: 24 May 1999
+# Whom: Anders Nordby <anders@fix.no>
#
# $FreeBSD$
#
@@ -15,7 +15,7 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} notes.html
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= Tiny/turbo/throttling HTTP server
IGNOREFILES= notes.html
@@ -34,7 +34,7 @@ MAN8= thttpd.8 redirect.8 ssi.8 syslogtocern.8
post-patch:
.for f in extras/htpasswd.1 extras/htpasswd.c thttpd.8 extras/Makefile.in
- ${REINPLACE_CMD} -e \
+ @${REINPLACE_CMD} -e \
's|htpasswd|thttpdpasswd|g;s|\.thttpdpasswd|.htpasswd|g' ${WRKSRC}/${f}
.endfor
${MV} ${WRKSRC}/extras/htpasswd.1 ${WRKSRC}/extras/thttpdpasswd.1
@@ -46,29 +46,29 @@ post-configure:
.endif
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/thttpd ${PREFIX}/sbin/
- @${INSTALL_MAN} ${WRKSRC}/thttpd.8 ${PREFIX}/man/man8
- @${INSTALL} -d -o root -g wheel -m 0755 ${PREFIX}/www
- @${INSTALL} -d -o root -g wheel -m 0755 ${PREFIX}/www/data
- @${INSTALL} -d -o root -g wheel -m 0755 ${PREFIX}/www/cgi-bin
- @${INSTALL_PROGRAM} ${WRKSRC}/cgi-src/redirect ${PREFIX}/www/cgi-bin/
- @${INSTALL_PROGRAM} ${WRKSRC}/cgi-src/ssi ${PREFIX}/www/cgi-bin/
- @${INSTALL_PROGRAM} ${WRKSRC}/cgi-src/phf ${PREFIX}/www/cgi-bin/
- @${INSTALL_MAN} ${WRKSRC}/cgi-src/redirect.8 ${PREFIX}/man/man8
- @${INSTALL_MAN} ${WRKSRC}/cgi-src/ssi.8 ${PREFIX}/man/man8
- @${INSTALL_PROGRAM} ${WRKSRC}/extras/makeweb ${PREFIX}/bin/
- @${INSTALL_PROGRAM} ${WRKSRC}/extras/thttpdpasswd ${PREFIX}/bin/
- @${INSTALL_SCRIPT} ${WRKSRC}/extras/syslogtocern ${PREFIX}/bin/
- @${INSTALL_MAN} ${WRKSRC}/extras/makeweb.1 ${PREFIX}/man/man1
- @${INSTALL_MAN} ${WRKSRC}/extras/thttpdpasswd.1 ${PREFIX}/man/man1
- @${INSTALL_MAN} ${WRKSRC}/extras/syslogtocern.8 ${PREFIX}/man/man8
- @${INSTALL_DATA} ${WRKDIR}/thttpd.conf.sample ${PREFIX}/etc/thttpd.conf.sample
+ ${INSTALL_PROGRAM} ${WRKSRC}/thttpd ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/thttpd.8 ${PREFIX}/man/man8
+ @${MKDIR} ${PREFIX}/www/data ${PREFIX}/www/cgi-bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/cgi-src/redirect ${PREFIX}/www/cgi-bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/cgi-src/ssi ${PREFIX}/www/cgi-bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/cgi-src/phf ${PREFIX}/www/cgi-bin
+ ${INSTALL_MAN} ${WRKSRC}/cgi-src/redirect.8 ${PREFIX}/man/man8
+ ${INSTALL_MAN} ${WRKSRC}/cgi-src/ssi.8 ${PREFIX}/man/man8
+ ${INSTALL_PROGRAM} ${WRKSRC}/extras/makeweb ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/extras/thttpdpasswd ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/extras/syslogtocern ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/extras/makeweb.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/extras/thttpdpasswd.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/extras/syslogtocern.8 ${PREFIX}/man/man8
+ ${INSTALL_DATA} ${WRKDIR}/thttpd.conf.sample ${PREFIX}/etc
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/notes.html ${DOCSDIR}/
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/notes.html ${DOCSDIR}
.endif
post-install:
+ @${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
.include <bsd.port.post.mk>
diff --git a/www/thttpd/pkg-descr b/www/thttpd/pkg-descr
index d47449fb38e5..e1682a4f80c5 100644
--- a/www/thttpd/pkg-descr
+++ b/www/thttpd/pkg-descr
@@ -1,13 +1,9 @@
- thttpd - tiny/turbo/throttling HTTP server
-
-thttpd is a simple, small, portable, fast, and secure HTTP server.
+thttpd is a simple, small, portable, fast, and secure HTTP server.
Simple: It handles only the minimum necessary to implement HTTP/1.1.
-Small: See the size comparison chart at
-http://www.acme.com/software/thttpd/notes.html#sizes. It also has a
-very small run-time size, since it does not fork and is very careful about
-memory allocation.
+Small: It also has a very small run-time size, since it does not fork and
+is very careful about memory allocation.
Portable: It compiles cleanly on SunOS 4.1.x, Solaris 2.x, BSD/OS 2.x,
Linux 1.2.x, and OSF/1 (on a 64-bit Alpha).