aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorjoneum <joneum@FreeBSD.org>2017-10-14 20:32:17 +0800
committerjoneum <joneum@FreeBSD.org>2017-10-14 20:32:17 +0800
commitd0662cbdc12b83dc7f3ad14a52a86a29454ea6e5 (patch)
tree7da8957cf783f438bf4f411714d0d59ed3d3e720 /www
parentaca74a6174b0464b3b06570f23fbfbcd03d88023 (diff)
downloadfreebsd-ports-gnome-d0662cbdc12b83dc7f3ad14a52a86a29454ea6e5.tar.gz
freebsd-ports-gnome-d0662cbdc12b83dc7f3ad14a52a86a29454ea6e5.tar.zst
freebsd-ports-gnome-d0662cbdc12b83dc7f3ad14a52a86a29454ea6e5.zip
- www/nginx: fix for fastdfs module
- As of ftp/fastdfs 5.0.11 nginx wont start by default if the fastdfs module is loaded. Provided patch sorts that out by adding the missing params to the mod_fastdfs.conf file. While patching mod_fastdfs.conf i also changed the storage paths to match the ftp/fastds port PR: 222067 Reported by: Daniel Ylitalo <daniel@blodan.se> Approved by: miwi (mentor) MFH: 2017Q4 Differential Revision: https://reviews.freebsd.org/D12246
Diffstat (limited to 'www')
-rw-r--r--www/nginx/Makefile5
-rw-r--r--www/nginx/files/extra-patch-fastdfs-src-mod_fastdfs.conf92
2 files changed, 95 insertions, 2 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 12d4e4ba6fa9..8b8b89801399 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nginx
PORTVERSION= 1.12.1
-PORTREVISION?= 1
+PORTREVISION?= 2
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
@@ -479,7 +479,8 @@ NGINX_FASTDFS_VERSION= 5a8110f
GH_ACCOUNT+= happyfish100:fastdfs
GH_PROJECT+= fastdfs-nginx-module:fastdfs
GH_TAGNAME+= ${NGINX_FASTDFS_VERSION}:fastdfs
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-fastdfs-src-config
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-fastdfs-src-config \
+ ${PATCHDIR}/extra-patch-fastdfs-src-mod_fastdfs.conf
BUILD_DEPENDS+= ${LOCALBASE}/include/fastcommon/logger.h:devel/libfastcommon \
${LOCALBASE}/include/fastdfs/fdfs_client.h:ftp/fastdfs
LIB_DEPENDS+= libfastcommon.so:devel/libfastcommon \
diff --git a/www/nginx/files/extra-patch-fastdfs-src-mod_fastdfs.conf b/www/nginx/files/extra-patch-fastdfs-src-mod_fastdfs.conf
new file mode 100644
index 000000000000..944ffc415eb6
--- /dev/null
+++ b/www/nginx/files/extra-patch-fastdfs-src-mod_fastdfs.conf
@@ -0,0 +1,92 @@
+--- ../fastdfs-nginx-module-5a8110f/src/mod_fastdfs.conf.orig 2017-09-05 14:19:44.560907000 +0200
++++ ../fastdfs-nginx-module-5a8110f/src/mod_fastdfs.conf 2017-09-05 14:24:43.475900000 +0200
+@@ -59,8 +59,8 @@
+ # store_path#, based 0, if store_path0 not exists, it's value is base_path
+ # the paths must be exist
+ # must same as storage.conf
+-store_path0=/home/yuqing/fastdfs
+-#store_path1=/home/yuqing/fastdfs1
++store_path0=/var/db/fastdfs/storage
++#store_path1=/var/db/fastdfs/storage2
+
+ # standard log level as syslog, case insensitive, value list:
+ ### emerg for emergency
+@@ -92,6 +92,14 @@
+ # NOTE: #include is an include directive, do NOT remove the # before include
+ #include http.conf
+
++# HTTP default content type
++http.default_content_type = application/octet-stream
++
++# MIME types mapping filename
++# MIME types file format: MIME_type extensions
++# such as: image/jpeg jpeg jpg jpe
++# you can use apache's MIME file: mime.types
++http.mime_types_filename=/usr/local/etc/nginx/mime.types
+
+ # if support flv
+ # default value is false
+@@ -119,8 +127,8 @@
+ #group_name=group1
+ #storage_server_port=23000
+ #store_path_count=2
+-#store_path0=/home/yuqing/fastdfs
+-#store_path1=/home/yuqing/fastdfs1
++#store_path0=/var/db/fastdfs/storage
++#store_path1=/var/db/fastdfs/storage2
+
+ # group settings for group #2
+ # since v1.14
+@@ -129,5 +137,5 @@
+ #group_name=group2
+ #storage_server_port=23000
+ #store_path_count=1
+-#store_path0=/home/yuqing/fastdfs
++#store_path0=/var/db/fastdfs/storage
+
+--- ../fastdfs-nginx-module-5a8110f/src/mod_fastdfs.conf.orig 2017-09-05 14:19:44.560907000 +0200
++++ ../fastdfs-nginx-module-5a8110f/src/mod_fastdfs.conf 2017-09-05 14:24:43.475900000 +0200
+@@ -59,8 +59,8 @@
+ # store_path#, based 0, if store_path0 not exists, it's value is base_path
+ # the paths must be exist
+ # must same as storage.conf
+-store_path0=/home/yuqing/fastdfs
+-#store_path1=/home/yuqing/fastdfs1
++store_path0=/var/db/fastdfs/storage
++#store_path1=/var/db/fastdfs/storage2
+
+ # standard log level as syslog, case insensitive, value list:
+ ### emerg for emergency
+@@ -92,6 +92,14 @@
+ # NOTE: #include is an include directive, do NOT remove the # before include
+ #include http.conf
+
++# HTTP default content type
++http.default_content_type = application/octet-stream
++
++# MIME types mapping filename
++# MIME types file format: MIME_type extensions
++# such as: image/jpeg jpeg jpg jpe
++# you can use apache's MIME file: mime.types
++http.mime_types_filename=/usr/local/etc/nginx/mime.types
+
+ # if support flv
+ # default value is false
+@@ -119,8 +127,8 @@
+ #group_name=group1
+ #storage_server_port=23000
+ #store_path_count=2
+-#store_path0=/home/yuqing/fastdfs
+-#store_path1=/home/yuqing/fastdfs1
++#store_path0=/var/db/fastdfs/storage
++#store_path1=/var/db/fastdfs/storage2
+
+ # group settings for group #2
+ # since v1.14
+@@ -129,5 +137,5 @@
+ #group_name=group2
+ #storage_server_port=23000
+ #store_path_count=1
+-#store_path0=/home/yuqing/fastdfs
++#store_path0=/var/db/fastdfs/storage
+