aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-06-10 14:22:15 +0800
committerclement <clement@FreeBSD.org>2004-06-10 14:22:15 +0800
commitd37042ea58e76686e06261b3affcb68723eed200 (patch)
treed09955d939bc88771c1f0583443de20a9f8af5ee /www
parent46897a3fa34871269b6e3ba26fc53886e706170e (diff)
downloadfreebsd-ports-gnome-d37042ea58e76686e06261b3affcb68723eed200.tar.gz
freebsd-ports-gnome-d37042ea58e76686e06261b3affcb68723eed200.tar.zst
freebsd-ports-gnome-d37042ea58e76686e06261b3affcb68723eed200.zip
- Move httperf from www to benchmarks category
Noticed by: ben @ EFNet Repocopied by: marcus
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/httperf/Makefile30
-rw-r--r--www/httperf/distinfo2
-rw-r--r--www/httperf/files/patch-Makefile.in10
-rw-r--r--www/httperf/files/patch-httperf.c13
-rw-r--r--www/httperf/files/patch-lib::Makefile.in11
-rw-r--r--www/httperf/files/patch-lib::ssl_writev.c13
-rw-r--r--www/httperf/pkg-descr21
-rw-r--r--www/httperf/pkg-plist6
9 files changed, 0 insertions, 107 deletions
diff --git a/www/Makefile b/www/Makefile
index bb5de74eac18..c2a0f28f1221 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -145,7 +145,6 @@
SUBDIR += http-analyze
SUBDIR += http_get
SUBDIR += http_load
- SUBDIR += httperf
SUBDIR += httpgrabber
SUBDIR += httptunnel
SUBDIR += httrack
diff --git a/www/httperf/Makefile b/www/httperf/Makefile
deleted file mode 100644
index 3b1dcb09f492..000000000000
--- a/www/httperf/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-# New ports collection makefile for: httperf
-# Date created: 28 Jul 1999
-# Whom: Will Andrews <andrews@technologist.com>
-#
-# $FreeBSD$
-#
-
-PORTNAME= httperf
-PORTVERSION= 0.8
-CATEGORIES= www
-MASTER_SITES= ftp://ftp.hpl.hp.com/pub/httperf/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A tool for measuring webserver performance
-
-USE_OPENSSL= yes
-USE_GETOPT_LONG= yes
-GNU_CONFIGURE= yes
-
-MAN1= httperf.1
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for file in ChangeLog NEWS README TODO
- ${INSTALL_MAN} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
-.endif
-
-.include <bsd.port.mk>
diff --git a/www/httperf/distinfo b/www/httperf/distinfo
deleted file mode 100644
index 02baa300ce8e..000000000000
--- a/www/httperf/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (httperf-0.8.tar.gz) = 2971956d4846349f9e8d3c54acd591a5
-SIZE (httperf-0.8.tar.gz) = 146107
diff --git a/www/httperf/files/patch-Makefile.in b/www/httperf/files/patch-Makefile.in
deleted file mode 100644
index 59491595c46d..000000000000
--- a/www/httperf/files/patch-Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- Makefile.in.orig Thu Oct 19 16:38:59 2000
-+++ Makefile.in Wed Nov 13 06:30:08 2002
-@@ -6,6 +6,7 @@
- top_builddir = .
-
- prefix = @prefix@
-+exec_prefix = @exec_prefix@
- bindir = @bindir@
- mandir = @mandir@
-
diff --git a/www/httperf/files/patch-httperf.c b/www/httperf/files/patch-httperf.c
deleted file mode 100644
index 8e735afadb8d..000000000000
--- a/www/httperf/files/patch-httperf.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- httperf.c.orig Wed Nov 1 05:20:00 2000
-+++ httperf.c Wed Nov 13 06:19:41 2002
-@@ -68,6 +68,10 @@
- #include <conn.h>
- #include <timer.h>
-
-+#ifdef __FreeBSD__
-+#include <machine/floatingpoint.h>
-+#endif
-+
- #ifdef HAVE_SSL
- # include <openssl/rand.h>
- #endif
diff --git a/www/httperf/files/patch-lib::Makefile.in b/www/httperf/files/patch-lib::Makefile.in
deleted file mode 100644
index 1b6cfa626b87..000000000000
--- a/www/httperf/files/patch-lib::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/Makefile.in.orig Thu Oct 12 10:04:32 2000
-+++ lib/Makefile.in Fri Jan 24 05:57:18 2003
-@@ -27,7 +27,7 @@
- .c.o:
- $(COMPILE) $<
-
--LIBUTIL_OBJS = getopt.o getopt1.o ssl_writev.o
-+LIBUTIL_OBJS = ssl_writev.o
-
- all: libutil.a
-
diff --git a/www/httperf/files/patch-lib::ssl_writev.c b/www/httperf/files/patch-lib::ssl_writev.c
deleted file mode 100644
index 81c05af1e52c..000000000000
--- a/www/httperf/files/patch-lib::ssl_writev.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- lib/ssl_writev.c.orig Thu Oct 12 09:09:47 2000
-+++ lib/ssl_writev.c Wed Nov 13 06:22:01 2002
-@@ -31,7 +31,10 @@
-
- #ifdef HAVE_OPENSSL_SSL_H
-
-+#ifdef HAVE_ALLOCA_H
- #include <alloca.h>
-+#endif
-+
- #include <string.h>
-
- #include <sys/types.h>
diff --git a/www/httperf/pkg-descr b/www/httperf/pkg-descr
deleted file mode 100644
index 3aee471c8cbf..000000000000
--- a/www/httperf/pkg-descr
+++ /dev/null
@@ -1,21 +0,0 @@
-Quoted from the website below:
-
- "This paper describes httperf, a tool for measuring web server
-performance. It provides a flexible facility for generating various
-HTTP workloads and for measuring server performance. The focus of httperf
-is not on implementing one particular benchmark but on providing a robust,
-high-performance tool that facilitates the construction of both micro-
-and macro-level benchmarks. The three distinguishing characteristics of
-httperf are its robustness, which includes the ability to generate and
-sustain server overload, support for the HTTP/1.1 protocol, and its
-extensibility to new workload generators and performance measurements.
-In addition to reporting on the design and implementation of httperf this
-paper also discusses some of the experiences and insights gained while
-realizing this tool."
-
-"This paper" refers to the paper that was written on this program. I don't
-think I could possibly summarize it better than the above paragraph.
-
-WWW: http://www.hpl.hp.com/personal/David_Mosberger/httperf.html
-
-- Will <andrews@technologist.com>
diff --git a/www/httperf/pkg-plist b/www/httperf/pkg-plist
deleted file mode 100644
index 0fec88272ceb..000000000000
--- a/www/httperf/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-bin/httperf
-%%PORTDOCS%%share/doc/httperf/ChangeLog
-%%PORTDOCS%%share/doc/httperf/NEWS
-%%PORTDOCS%%share/doc/httperf/README
-%%PORTDOCS%%share/doc/httperf/TODO
-%%PORTDOCS%%@dirrm share/doc/httperf