aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2008-12-22 23:21:51 +0800
committeraz <az@FreeBSD.org>2008-12-22 23:21:51 +0800
commitd47f208879f319253e75b2c27bdd240569b47eae (patch)
tree1045c70d848b9d06bb2370bdb011adafb690376e /www
parentb6b43731749709705b087b19f0455bbfeb7fb0ae (diff)
downloadfreebsd-ports-gnome-d47f208879f319253e75b2c27bdd240569b47eae.tar.gz
freebsd-ports-gnome-d47f208879f319253e75b2c27bdd240569b47eae.tar.zst
freebsd-ports-gnome-d47f208879f319253e75b2c27bdd240569b47eae.zip
This view generates RRD graph images from the graph defintion placed in the
stash. The controller is responsable of placing an ARRAYREF in $c-stash->{'graph'}> with the same data as to generate a graph with the RRDs module, except for filename, that will be automatically generated by the view.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Catalyst-View-RRDGraph/Makefile28
-rw-r--r--www/p5-Catalyst-View-RRDGraph/distinfo3
-rw-r--r--www/p5-Catalyst-View-RRDGraph/pkg-descr6
-rw-r--r--www/p5-Catalyst-View-RRDGraph/pkg-plist8
5 files changed, 46 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 507eb386d676..0939189714a7 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -776,6 +776,7 @@
SUBDIR += p5-Catalyst-View-JSON
SUBDIR += p5-Catalyst-View-Jemplate
SUBDIR += p5-Catalyst-View-Mason
+ SUBDIR += p5-Catalyst-View-RRDGraph
SUBDIR += p5-Catalyst-View-TT
SUBDIR += p5-Catalyst-View-TT-ControllerLocal
SUBDIR += p5-Catalyst-View-Templated
diff --git a/www/p5-Catalyst-View-RRDGraph/Makefile b/www/p5-Catalyst-View-RRDGraph/Makefile
new file mode 100644
index 000000000000..107b9c70507b
--- /dev/null
+++ b/www/p5-Catalyst-View-RRDGraph/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Catalyst-View-RRDGraph
+# Date created: 2008-12-22
+# Whom: Andrej Zverev <az@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-View-RRDGraph
+PORTVERSION= 0.03
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/J/JL/JLMARTIN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= az@FreeBSD.org
+COMMENT= RRD graph view class for catalyst
+
+BUILD_DEPENDS= p5-Catalyst-Runtime>=5.7000:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ ${SITE_PERL}/Catalyst/Plugin/Static/Simple.pm:${PORTSDIR}/www/p5-Catalyst-Plugin-Static-Simple \
+ ${SITE_PERL}/RRDp.pm:${PORTSDIR}/databases/rrdtool
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Helper::View::RRDGraph.3 \
+ Catalyst::View::RRDGraph.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Catalyst-View-RRDGraph/distinfo b/www/p5-Catalyst-View-RRDGraph/distinfo
new file mode 100644
index 000000000000..0673ecb6b21d
--- /dev/null
+++ b/www/p5-Catalyst-View-RRDGraph/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-View-RRDGraph-0.03.tar.gz) = aa80d0cd78cc4f14eca3e4849a8ecc9b
+SHA256 (Catalyst-View-RRDGraph-0.03.tar.gz) = 4163518ac508e314481b4034a08eb12b506406d491b7973992650186415a71d5
+SIZE (Catalyst-View-RRDGraph-0.03.tar.gz) = 13769
diff --git a/www/p5-Catalyst-View-RRDGraph/pkg-descr b/www/p5-Catalyst-View-RRDGraph/pkg-descr
new file mode 100644
index 000000000000..6a3c5b333eb1
--- /dev/null
+++ b/www/p5-Catalyst-View-RRDGraph/pkg-descr
@@ -0,0 +1,6 @@
+This view generates RRD graph images from the graph defintion placed in the
+stash. The controller is responsable of placing an ARRAYREF in
+$c-stash->{'graph'}> with the same data as to generate a graph with the RRDs
+module, except for filename, that will be automatically generated by the view.
+
+WWW: http://search.cpan.org/~jlmartin/Catalyst-View-RRDGraph/
diff --git a/www/p5-Catalyst-View-RRDGraph/pkg-plist b/www/p5-Catalyst-View-RRDGraph/pkg-plist
new file mode 100644
index 000000000000..6fe841aa6a6b
--- /dev/null
+++ b/www/p5-Catalyst-View-RRDGraph/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Catalyst/Helper/View/RRDGraph.pm
+%%SITE_PERL%%/Catalyst/View/RRDGraph.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/View/RRDGraph/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/View/RRDGraph
+@dirrmtry %%SITE_PERL%%/Catalyst/Helper/View
+@dirrmtry %%SITE_PERL%%/Catalyst/Helper
+@dirrmtry %%SITE_PERL%%/Catalyst/View