aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-09-09 05:26:18 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-09-09 05:26:18 +0800
commitd4a0fd43def7a3b4454afbd40c600057a24db040 (patch)
treed297f46facff92b7efb880d4d7565c666bd47c4d /www
parent7e4b7296121ec9c86f077301cec211bdd9b54897 (diff)
downloadfreebsd-ports-gnome-d4a0fd43def7a3b4454afbd40c600057a24db040.tar.gz
freebsd-ports-gnome-d4a0fd43def7a3b4454afbd40c600057a24db040.tar.zst
freebsd-ports-gnome-d4a0fd43def7a3b4454afbd40c600057a24db040.zip
Rack::Cache is suitable as a quick drop-in component
to enable HTTP caching for Rack-based applications that produce freshness (Expires, Cache-Control) and/or validation (Last-Modified, ETag) information. * Standards-based (see RFC 2616 / Section 13). * Freshness/expiration based caching * Validation * Vary support * Portable: 100% Ruby / works with any Rack-enabled framework. * Disk, memcached, and heap memory storage backends. WWW: http://rtomayko.github.com/rack-cache/ PR: ports/150379 Submitted by: Eric Freeman <freebsdports at chillibear.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-rack-cache/Makefile22
-rw-r--r--www/rubygem-rack-cache/distinfo3
-rw-r--r--www/rubygem-rack-cache/pkg-descr13
4 files changed, 39 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 089fe6681424..7075a2d34772 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1549,6 +1549,7 @@
SUBDIR += rubygem-nicovideo
SUBDIR += rubygem-passenger
SUBDIR += rubygem-rack
+ SUBDIR += rubygem-rack-cache
SUBDIR += rubygem-rack-mount
SUBDIR += rubygem-rack-test
SUBDIR += rubygem-rails
diff --git a/www/rubygem-rack-cache/Makefile b/www/rubygem-rack-cache/Makefile
new file mode 100644
index 000000000000..b7ba518a8afa
--- /dev/null
+++ b/www/rubygem-rack-cache/Makefile
@@ -0,0 +1,22 @@
+# Ports collection makefile for: rubygem-rack-cache
+# Date created: 8 Sept 2010
+# Whom: Eric Freeman <freebsdports@chillibear.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rack-cache
+PORTVERSION= 0.5.2
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= freebsdports@chillibear.com
+COMMENT= A piece of rack middleware to enable HTTP caching
+
+RUN_DEPENDS= rubygem-rack>=0.4.0:${PORTSDIR}/www/rubygem-rack
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-rack-cache/distinfo b/www/rubygem-rack-cache/distinfo
new file mode 100644
index 000000000000..d5618baa3981
--- /dev/null
+++ b/www/rubygem-rack-cache/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/rack-cache-0.5.2.gem) = b3fc80c1b9414d169e4a477170879977
+SHA256 (rubygem/rack-cache-0.5.2.gem) = 7fb3e3deaacfb583830d0f334021a77be63f524778c8e734d1cd972700d541db
+SIZE (rubygem/rack-cache-0.5.2.gem) = 258048
diff --git a/www/rubygem-rack-cache/pkg-descr b/www/rubygem-rack-cache/pkg-descr
new file mode 100644
index 000000000000..87972fdf8fda
--- /dev/null
+++ b/www/rubygem-rack-cache/pkg-descr
@@ -0,0 +1,13 @@
+Rack::Cache is suitable as a quick drop-in component
+to enable HTTP caching for Rack-based applications
+that produce freshness (Expires, Cache-Control)
+and/or validation (Last-Modified, ETag) information.
+
+ * Standards-based (see RFC 2616 / Section 13).
+ * Freshness/expiration based caching
+ * Validation
+ * Vary support
+ * Portable: 100% Ruby / works with any Rack-enabled framework.
+ * Disk, memcached, and heap memory storage backends.
+
+WWW: http://rtomayko.github.com/rack-cache/