aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-05-12 02:34:57 +0800
committermat <mat@FreeBSD.org>2015-05-12 02:34:57 +0800
commitd843ecd4966c8a5bed60cf3aaeb27edb6b5b2389 (patch)
tree634e1ef4990207301493f26b46d80abe56b9f2b3 /www
parent925f5606448b4e40652ba0a13bfb8cd44c8aac89 (diff)
downloadfreebsd-ports-gnome-d843ecd4966c8a5bed60cf3aaeb27edb6b5b2389.tar.gz
freebsd-ports-gnome-d843ecd4966c8a5bed60cf3aaeb27edb6b5b2389.tar.zst
freebsd-ports-gnome-d843ecd4966c8a5bed60cf3aaeb27edb6b5b2389.zip
Cleanup DIST* variables.
When appropriate: - Try to use DISTVERSION{SUF,PRE}FIX - Replace PORTNAME-PORTVERSION by DISTNAME - Convert MASTER_SITES to use macros - Other light cleanup With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'www')
-rw-r--r--www/apache-forrest/Makefile7
-rw-r--r--www/axis2/Makefile3
-rw-r--r--www/b2evolution/Makefile2
-rw-r--r--www/boa/Makefile3
-rw-r--r--www/htmlcompressor/Makefile5
-rw-r--r--www/linux-c6-qt47-webkit/Makefile4
-rw-r--r--www/madsonic/Makefile4
-rw-r--r--www/mohawk/Makefile2
-rw-r--r--www/p5-Apache-Clean2/Makefile2
-rw-r--r--www/p5-CGI-Ajax/Makefile1
-rw-r--r--www/p5-Catalyst-Model-Tarantool/Makefile2
-rw-r--r--www/p5-URI-ParseSearchString/Makefile3
-rw-r--r--www/py-albatross/Makefile2
-rw-r--r--www/py-django-crispy-forms/Makefile1
-rw-r--r--www/py-django-signals-ahoy/Makefile3
-rw-r--r--www/py-html5lib/Makefile4
-rw-r--r--www/tomcat-native/Makefile3
-rw-r--r--www/tomcat6/Makefile3
-rw-r--r--www/tomcat7/Makefile3
-rw-r--r--www/tomcat8/Makefile3
-rw-r--r--www/trac-wikinotification/Makefile4
-rw-r--r--www/wikicalc/Makefile3
-rw-r--r--www/woof/Makefile3
-rw-r--r--www/yuicompressor/Makefile9
-rw-r--r--www/zend-framework1/Makefile4
25 files changed, 32 insertions, 51 deletions
diff --git a/www/apache-forrest/Makefile b/www/apache-forrest/Makefile
index 6ee1fc6b6bb8..06c1c2042acb 100644
--- a/www/apache-forrest/Makefile
+++ b/www/apache-forrest/Makefile
@@ -5,10 +5,9 @@ PORTNAME= apache-forrest
PORTVERSION= 0.9
PORTREVISION= 0
CATEGORIES= www java
-MASTER_SITES= ${MASTER_SITE_APACHE}
-MASTER_SITE_SUBDIR= forrest
-DISTFILES= ${PORTNAME}-${PORTVERSION}-sources.tar.gz \
- ${PORTNAME}-${PORTVERSION}-dependencies.tar.gz
+MASTER_SITES= SITE_APACHE/forrest
+DISTFILES= ${DISTNAME}-sources.tar.gz \
+ ${DISTNAME}-dependencies.tar.gz
MAINTAINER= nivit@FreeBSD.org
COMMENT= Tool for rapid development of small sites
diff --git a/www/axis2/Makefile b/www/axis2/Makefile
index 1713f096f729..889782815133 100644
--- a/www/axis2/Makefile
+++ b/www/axis2/Makefile
@@ -4,8 +4,7 @@ PORTNAME= axis2
PORTVERSION= 1.6.2
PORTREVISION= 1
CATEGORIES= www java
-MASTER_SITES= APACHE
-MASTER_SITE_SUBDIR= axis/${PORTNAME}/java/core/${PORTVERSION}/
+MASTER_SITES= APACHE/axis/${PORTNAME}/java/core/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-bin
MAINTAINER= ports@FreeBSD.org
diff --git a/www/b2evolution/Makefile b/www/b2evolution/Makefile
index 63e600bf05d1..daa40031549c 100644
--- a/www/b2evolution/Makefile
+++ b/www/b2evolution/Makefile
@@ -3,10 +3,10 @@
PORTNAME= b2evolution
PORTVERSION= 4.0.5
+DISTVERSIONSUFFIX= -${B2EVO_DATE}
PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= SF/evocms/${PORTNAME}/b2evo%20${PORTVERSION}-stable
-DISTNAME= ${PORTNAME}-${PORTVERSION}-${B2EVO_DATE}
MAINTAINER= ports@FreeBSD.org
COMMENT= Multilingual, multiuser, multi-blog engine
diff --git a/www/boa/Makefile b/www/boa/Makefile
index 0430f4c7a6a4..dcef55b18ead 100644
--- a/www/boa/Makefile
+++ b/www/boa/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= boa
-PORTVERSION= 0.94.14.r21
+DISTVERSION= 0.94.14rc21
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= http://www.boa.org/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/rc/}
MAINTAINER= ports@FreeBSD.org
COMMENT= High performance single-tasking web server
diff --git a/www/htmlcompressor/Makefile b/www/htmlcompressor/Makefile
index 73c15734382f..3f63badb9034 100644
--- a/www/htmlcompressor/Makefile
+++ b/www/htmlcompressor/Makefile
@@ -6,8 +6,7 @@ PORTVERSION= 1.5.3
PORTREVISION= 2
CATEGORIES= www java
MASTER_SITES= GOOGLE_CODE
-DISTNAME= ${PORTNAME}-${PORTVERSION}.jar
-EXTRACT_SUFX= # empty
+EXTRACT_SUFX= .jar
EXTRACT_ONLY= # empty
MAINTAINER= ports@FreeBSD.org
@@ -25,7 +24,7 @@ SUB_LIST+= JAVA_VERSION=${JAVA_PORT_VERSION:R}
do-install:
@${MKDIR} ${STAGEDIR}${JAVAJARDIR}
- ${INSTALL_DATA} ${DISTDIR}/${DISTNAME} ${STAGEDIR}${JAVAJARDIR}/htmlcompressor.jar
+ ${INSTALL_DATA} ${DISTDIR}/${DISTNAME}.jar ${STAGEDIR}${JAVAJARDIR}/htmlcompressor.jar
${INSTALL_SCRIPT} ${WRKDIR}/htmlcompressor ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/www/linux-c6-qt47-webkit/Makefile b/www/linux-c6-qt47-webkit/Makefile
index 56c997fa9d36..5b46f71dcb77 100644
--- a/www/linux-c6-qt47-webkit/Makefile
+++ b/www/linux-c6-qt47-webkit/Makefile
@@ -5,10 +5,8 @@ PORTNAME= qt47-webkit
PORTVERSION= 4.7.2
PORTREVISION= 1
CATEGORIES= www linux
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= xmj
+MASTER_SITES= LOCAL/xmj
PKGNAMEPREFIX= linux-${USE_LINUX}-
-DISTNAME= ${PORTNAME}-${PORTVERSION}-${RPMVERSION}
DIST_SUBDIR= rpm/${LINUX_RPM_ARCH}/centos/c5
MAINTAINER= emulation@FreeBSD.org
diff --git a/www/madsonic/Makefile b/www/madsonic/Makefile
index 05ee6dc5b0f9..60214faec1ed 100644
--- a/www/madsonic/Makefile
+++ b/www/madsonic/Makefile
@@ -5,8 +5,8 @@ PORTNAME= madsonic
PORTVERSION= 5.1.5200
CATEGORIES= www java
MASTER_SITES= http://www.madsonic.org/download/5.1/
-DISTFILES= ${DISTDATE}_${PORTNAME}-${PORTVERSION}-war-tomcat.zip \
- ${DISTDATE}_${PORTNAME}-${PORTVERSION}-war-jspc.zip
+DISTFILES= ${DISTDATE}_${DISTNAME}-war-tomcat.zip \
+ ${DISTDATE}_${DISTNAME}-war-jspc.zip
MAINTAINER= root@cooltrainer.org
COMMENT= Madsonic streaming media server
diff --git a/www/mohawk/Makefile b/www/mohawk/Makefile
index 4b4a979cab7d..100a08266919 100644
--- a/www/mohawk/Makefile
+++ b/www/mohawk/Makefile
@@ -5,7 +5,7 @@ PORTVERSION= 2.0.17
CATEGORIES= www ipv6
MASTER_SITES= http://fossil.bsdsx.fr/mohawk/tarball/ \
http://fossil.etoilebsd.net/mohawk/tarball/
-DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz?uuid=${PORTVERSION}
+DISTFILES= ${DISTNAME}.tar.gz?uuid=${PORTVERSION}
MAINTAINER= mohawk@bsdsx.fr
COMMENT= Simple and lightweight HTTP daemon
diff --git a/www/p5-Apache-Clean2/Makefile b/www/p5-Apache-Clean2/Makefile
index 157c19039d52..57adac6d411d 100644
--- a/www/p5-Apache-Clean2/Makefile
+++ b/www/p5-Apache-Clean2/Makefile
@@ -3,12 +3,12 @@
PORTNAME= Apache-Clean
PORTVERSION= 2.00
+DISTVERSIONSUFFIX= _7
PORTREVISION= 3
CATEGORIES= www perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= Apache/GEOFF
PKGNAMEPREFIX= p5-
-DISTNAME= ${PORTNAME}-${PORTVERSION}_7
MAINTAINER= perl@FreeBSD.org
COMMENT= Mod_perl interface into HTML::Clean
diff --git a/www/p5-CGI-Ajax/Makefile b/www/p5-CGI-Ajax/Makefile
index db7959af786f..e066e5a558af 100644
--- a/www/p5-CGI-Ajax/Makefile
+++ b/www/p5-CGI-Ajax/Makefile
@@ -7,7 +7,6 @@ PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-DISTNAME= ${PORTNAME}-${PORTVERSION:C/0$//}
MAINTAINER= lth@FreeBSD.org
COMMENT= Module for writing AJAX/DHTML-based web apps
diff --git a/www/p5-Catalyst-Model-Tarantool/Makefile b/www/p5-Catalyst-Model-Tarantool/Makefile
index cd724d9fe636..c6991cc47c6e 100644
--- a/www/p5-Catalyst-Model-Tarantool/Makefile
+++ b/www/p5-Catalyst-Model-Tarantool/Makefile
@@ -3,11 +3,11 @@
PORTNAME= Catalyst-Model-Tarantool
PORTVERSION= 0.0.1
+DISTVERSIONSUFFIX= -1
PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-DISTNAME= ${PORTNAME}-${PORTVERSION}-1
MAINTAINER= vg@FreeBSD.org
COMMENT= Tarantool interface for Catalyst based application
diff --git a/www/p5-URI-ParseSearchString/Makefile b/www/p5-URI-ParseSearchString/Makefile
index 5883bcff9019..000693778b59 100644
--- a/www/p5-URI-ParseSearchString/Makefile
+++ b/www/p5-URI-ParseSearchString/Makefile
@@ -2,12 +2,11 @@
# $FreeBSD$
PORTNAME= URI-ParseSearchString
-PORTVERSION= 3.51.0
+PORTVERSION= 3.51
PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-DISTNAME= ${PORTNAME}-${PORTVERSION:C/.0$//}
MAINTAINER= perl@FreeBSD.org
COMMENT= Parse Apache referer logs and extract search engine query strings
diff --git a/www/py-albatross/Makefile b/www/py-albatross/Makefile
index 3f1c93145497..16783e2e60c6 100644
--- a/www/py-albatross/Makefile
+++ b/www/py-albatross/Makefile
@@ -6,7 +6,7 @@ PORTVERSION= 1.36
CATEGORIES= www python
MASTER_SITES= http://object-craft.com.au/projects/albatross/download/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
${PORTNAME}-html-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= gnb@itga.com.au
diff --git a/www/py-django-crispy-forms/Makefile b/www/py-django-crispy-forms/Makefile
index 1323aa0bf6b9..0b36144c297b 100644
--- a/www/py-django-crispy-forms/Makefile
+++ b/www/py-django-crispy-forms/Makefile
@@ -7,7 +7,6 @@ PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= xmj@chaot.net
COMMENT= The best way to have Django DRY forms
diff --git a/www/py-django-signals-ahoy/Makefile b/www/py-django-signals-ahoy/Makefile
index b6594315fe59..e3837230172f 100644
--- a/www/py-django-signals-ahoy/Makefile
+++ b/www/py-django-signals-ahoy/Makefile
@@ -2,12 +2,11 @@
# $FreeBSD$
PORTNAME= django-signals-ahoy
-PORTVERSION= 0.1.0
+DISTVERSION= 0.1-0
PORTREVISION= 2
CATEGORIES= www python
MASTER_SITES= http://cdn.bitbucket.org/bkroeze/django-signals-ahoy/downloads/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= ${PORTNAME}-${PORTVERSION:C/([[:digit:]]\.[[:digit:]])\./\1-/g}
MAINTAINER= ports@caomhin.org
COMMENT= Extended set of signals for use by Django apps
diff --git a/www/py-html5lib/Makefile b/www/py-html5lib/Makefile
index ccf7f9d86b9c..e0e9998fb2e4 100644
--- a/www/py-html5lib/Makefile
+++ b/www/py-html5lib/Makefile
@@ -25,8 +25,8 @@ USE_PYTHON= distutils autoplist
.include <bsd.port.options.mk>
.if !empty(PORT_OPTIONS:MTEST)
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:master \
- ${PORTNAME}-${PORTVERSION}-testdata${EXTRACT_SUFX}:test
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:master \
+ ${DISTNAME}-testdata${EXTRACT_SUFX}:test
BUILD_DEPENDS+= ${TEST_DEPENDS}
.endif
diff --git a/www/tomcat-native/Makefile b/www/tomcat-native/Makefile
index 55ff1f7ff1a6..54bdff4dfada 100644
--- a/www/tomcat-native/Makefile
+++ b/www/tomcat-native/Makefile
@@ -4,8 +4,7 @@
PORTNAME= tomcat-native
PORTVERSION= 1.1.32
CATEGORIES= www java
-MASTER_SITES= APACHE
-MASTER_SITE_SUBDIR= tomcat/tomcat-connectors/native/${PORTVERSION}/source
+MASTER_SITES= APACHE/tomcat/tomcat-connectors/native/${PORTVERSION}/source
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ale@FreeBSD.org
diff --git a/www/tomcat6/Makefile b/www/tomcat6/Makefile
index 4512c2e7afd1..13dc2bd047be 100644
--- a/www/tomcat6/Makefile
+++ b/www/tomcat6/Makefile
@@ -4,8 +4,7 @@
PORTNAME= tomcat
PORTVERSION= 6.0.43
CATEGORIES= www java
-MASTER_SITES= ${MASTER_SITE_APACHE}
-MASTER_SITE_SUBDIR= tomcat/tomcat-6/v${PORTVERSION}/bin
+MASTER_SITES= APACHE/tomcat/tomcat-6/v${PORTVERSION}/bin
PKGNAMESUFFIX= 6
DISTNAME= apache-${PORTNAME}-${PORTVERSION}
diff --git a/www/tomcat7/Makefile b/www/tomcat7/Makefile
index af22c9f3b371..95ef65e25834 100644
--- a/www/tomcat7/Makefile
+++ b/www/tomcat7/Makefile
@@ -4,8 +4,7 @@
PORTNAME= tomcat
PORTVERSION= 7.0.59
CATEGORIES= www java
-MASTER_SITES= APACHE
-MASTER_SITE_SUBDIR= tomcat/tomcat-7/v${PORTVERSION}/bin
+MASTER_SITES= APACHE/tomcat/tomcat-7/v${PORTVERSION}/bin
PKGNAMESUFFIX= 7
DISTNAME= apache-${PORTNAME}-${PORTVERSION}
diff --git a/www/tomcat8/Makefile b/www/tomcat8/Makefile
index 2592b05e8395..724b4d0335c3 100644
--- a/www/tomcat8/Makefile
+++ b/www/tomcat8/Makefile
@@ -4,8 +4,7 @@
PORTNAME= tomcat
PORTVERSION= 8.0.18
CATEGORIES= www java
-MASTER_SITES= APACHE
-MASTER_SITE_SUBDIR= tomcat/tomcat-8/v${PORTVERSION}/bin
+MASTER_SITES= APACHE/tomcat/tomcat-8/v${PORTVERSION}/bin
PKGNAMESUFFIX= 8
DISTNAME= apache-${PORTNAME}-${PORTVERSION}
diff --git a/www/trac-wikinotification/Makefile b/www/trac-wikinotification/Makefile
index 6565ce9a7bb0..2ad5fa01725b 100644
--- a/www/trac-wikinotification/Makefile
+++ b/www/trac-wikinotification/Makefile
@@ -5,10 +5,8 @@ PORTNAME= wikinotificationplugin
PORTVERSION= 0.2.1
PORTREVISION= 5
CATEGORIES= www devel python
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= brooks
+MASTER_SITES= LOCAL/brooks
PKGNAMEPREFIX= trac-
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/p/rc/}
MAINTAINER= ports@FreeBSD.org
COMMENT= Allow email notifications on wiki page changes
diff --git a/www/wikicalc/Makefile b/www/wikicalc/Makefile
index 124505a8389c..077ce3c787fe 100644
--- a/www/wikicalc/Makefile
+++ b/www/wikicalc/Makefile
@@ -1,10 +1,9 @@
# $FreeBSD$
PORTNAME= wikicalc
-PORTVERSION= 1.0
+DISTVERSION= 1-0
CATEGORIES= www math
MASTER_SITES= http://www.peapodcast.com/sgi/downloads/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S,.,-,}
MAINTAINER= hrs@FreeBSD.org
COMMENT= Open Source Wiki-Spreadsheet
diff --git a/www/woof/Makefile b/www/woof/Makefile
index 169bdec7f9f7..59a3556ff4a2 100644
--- a/www/woof/Makefile
+++ b/www/woof/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= woof
-PORTVERSION= 2012.05.31
+DISTVERSION= 2012-05-31
CATEGORIES= www
MASTER_SITES= http://www.home.unix-ag.org/simon/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/./-/g}
EXTRACT_SUFX= .py
EXTRACT_ONLY= # empty
diff --git a/www/yuicompressor/Makefile b/www/yuicompressor/Makefile
index 780d0351f3f6..6cc7e2aab3e1 100644
--- a/www/yuicompressor/Makefile
+++ b/www/yuicompressor/Makefile
@@ -6,10 +6,9 @@ PORTVERSION= 2.4.8
PORTREVISION= 1
CATEGORIES= www java
#MASTER_SITES= http://tml.github.io/yui/
-MASTER_SITES+= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= az
-DISTNAME= ${PORTNAME}-${PORTVERSION}.jar
-EXTRACT_SUFX= # empty
+MASTER_SITES+= LOCAL/az
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+EXTRACT_SUFX= .jar
EXTRACT_ONLY= # empty
MAINTAINER= citrin@citrin.ru
@@ -25,7 +24,7 @@ PLIST_FILES= bin/yuicompressor %%JAVAJARDIR%%/yuicompressor.jar
SUB_FILES= yuicompressor
do-install:
- ${INSTALL_DATA} ${DISTDIR}/${DISTNAME} ${STAGEDIR}${JAVAJARDIR}/yuicompressor.jar
+ ${INSTALL_DATA} ${DISTDIR}/${DISTNAME}.jar ${STAGEDIR}${JAVAJARDIR}/yuicompressor.jar
${INSTALL_SCRIPT} ${WRKDIR}/yuicompressor ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/www/zend-framework1/Makefile b/www/zend-framework1/Makefile
index 2e97a808640a..27b6c2348a52 100644
--- a/www/zend-framework1/Makefile
+++ b/www/zend-framework1/Makefile
@@ -38,8 +38,8 @@ OPTPHP_DESC= Install optional PHP dependencies
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MDOCS}
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
- ${PORTNAME}-${PORTVERSION}-manual-en${EXTRACT_SUFX}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${DISTNAME}-manual-en${EXTRACT_SUFX}
.endif
INSTALL_DIRS= library extras/library externals/dojo/dijit \