aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2014-03-10 01:42:56 +0800
committerohauer <ohauer@FreeBSD.org>2014-03-10 01:42:56 +0800
commitd97b4d64808537e4da3c9e9df5b65f0beca40387 (patch)
treea1c16e6455ba7a2f3dbffd0eaabf234eed314261 /www
parentab13e212e96acf1193533431f81cf75565e26d5d (diff)
downloadfreebsd-ports-gnome-d97b4d64808537e4da3c9e9df5b65f0beca40387.tar.gz
freebsd-ports-gnome-d97b4d64808537e4da3c9e9df5b65f0beca40387.tar.zst
freebsd-ports-gnome-d97b4d64808537e4da3c9e9df5b65f0beca40387.zip
add stage support
Diffstat (limited to 'www')
-rw-r--r--www/mod_layout22/Makefile15
-rw-r--r--www/mod_layout22/files/patch-Makefile18
2 files changed, 24 insertions, 9 deletions
diff --git a/www/mod_layout22/Makefile b/www/mod_layout22/Makefile
index 96513ee8d5aa..1c8a4dc8b997 100644
--- a/www/mod_layout22/Makefile
+++ b/www/mod_layout22/Makefile
@@ -11,7 +11,6 @@ PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache2.2 module to wrap served pages with a header and/or footer
-
CONFLICTS= mod_layout-3.* mod_layout-4.*
PORTSCOUT= limit:^5
@@ -21,11 +20,15 @@ LATEST_LINK= mod_layout22
MAKE_ARGS+= builddir=${WRKSRC}
-NO_STAGE= yes
+post-patch:
+ ${REINPLACE_CMD} -e 's|@APXS_STAGE@|-S LIBEXECDIR=${STAGEDIR}${PREFIX}/${APACHEMODDIR}|' \
+ ${WRKSRC}/Makefile
+
+pre-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}
+
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/README
.include <bsd.port.mk>
diff --git a/www/mod_layout22/files/patch-Makefile b/www/mod_layout22/files/patch-Makefile
index adabd148898e..ab0cc9e1ffeb 100644
--- a/www/mod_layout22/files/patch-Makefile
+++ b/www/mod_layout22/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2007-02-21 22:29:07.000000000 +0100
-+++ Makefile 2008-08-31 21:53:05.000000000 +0200
-@@ -1,10 +1,10 @@
+--- ./Makefile.orig 2008-01-07 07:44:50.000000000 +0100
++++ ./Makefile 2014-03-09 18:38:09.000000000 +0100
+@@ -1,10 +1,11 @@
##
## Makefile -- Build procedure for mod_layout Apache module
##
@@ -10,6 +10,18 @@
# the used tools
-APXS=apxs
+APXS=${LOCALBASE}/sbin/apxs
++APXS_STAGE= @APXS_STAGE@
APACHECTL=apachectl
CC=`$(APXS) -q CC`
INC=-I`$(APXS) -q INCLUDEDIR` `$(APXS) -q CFLAGS` #-DLAYOUT_FILEOWNER_NAME
+@@ -57,8 +58,8 @@
+ header.o : header.c
+ $(APXS) -c header.c
+ # install the shared object file into Apache
+-install:
+- $(APXS) -iac $(INCLUDES) $(LIBS) $(SRC)
++install: mod_layout.so
++ $(APXS) $(APXS_STAGE) -i -n layout mod_layout.la
+ @echo "+--------------------------------------------------------+"; \
+ echo "| All done. |"; \
+ echo "| |"; \